gnu: python-gst: Fix build with Python 3.8.
[jackhill/guix/guix.git] / gnu / packages / gstreamer.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
4 ;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
5 ;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
8 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
9 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
11 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages gstreamer)
29 #:use-module ((guix licenses) #:prefix license:)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system meson)
34 #:use-module (guix utils)
35 #:use-module (gnu packages)
36 #:use-module (gnu packages audio)
37 #:use-module (gnu packages bison)
38 #:use-module (gnu packages cdrom)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages compression)
41 #:use-module (gnu packages flex)
42 #:use-module (gnu packages freedesktop)
43 #:use-module (gnu packages gl)
44 #:use-module (gnu packages glib)
45 #:use-module (gnu packages gnome)
46 #:use-module (gnu packages gnupg)
47 #:use-module (gnu packages graphics)
48 #:use-module (gnu packages gtk)
49 #:use-module (gnu packages image)
50 #:use-module (gnu packages libusb)
51 #:use-module (gnu packages linux)
52 #:use-module (gnu packages mp3)
53 #:use-module (gnu packages ncurses)
54 #:use-module (gnu packages perl)
55 #:use-module (gnu packages pulseaudio)
56 #:use-module (gnu packages qt)
57 #:use-module (gnu packages rdf)
58 #:use-module (gnu packages video)
59 #:use-module (gnu packages xorg)
60 #:use-module (gnu packages xiph)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages python)
63 #:use-module (gnu packages ssh)
64 #:use-module (gnu packages telephony)
65 #:use-module (gnu packages tls)
66 #:use-module (gnu packages version-control)
67 #:use-module (gnu packages assembly)
68 #:use-module (gnu packages xml))
69
70 (define-public orc
71 (package
72 (name "orc")
73 (version "0.4.31")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "https://gstreamer.freedesktop.org/data/src/"
77 "orc/orc-" version ".tar.xz"))
78 (sha256
79 (base32
80 "0xb0c7q3xv1ldmz5ipybazb01gy3cijj8622dcx7rbm9lq85zax0"))))
81 (build-system meson-build-system)
82 (arguments
83 `(#:phases
84 (modify-phases %standard-phases
85 (add-after 'unpack 'disable-faulty-test
86 (lambda _
87 ;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
88 ;; tests, which fail on some machines. See:
89 ;; https://bugzilla.gnome.org/show_bug.cgi?id=735273
90 (substitute* '("testsuite/test-limits.c"
91 "testsuite/exec_opcodes_sys.c")
92 (("if \\(error\\) return 1;")
93 "if (error) return 77;"))
94 #t)))))
95 (native-inputs
96 `(("gtk-doc" ,gtk-doc)))
97 (home-page "https://gstreamer.freedesktop.org/modules/orc.html")
98 (synopsis "Oil runtime compiler")
99 (description
100 "Orc is a just-in-time compiler implemented as a library and set of
101 associated tools for compiling and executing simple programs that operate on
102 arrays of data.")
103 ;; The source code implementing the Marsenne Twister algorithm is licensed
104 ;; under the 3-clause BSD license, the rest is under 2-clause BSD license.
105 (license (list license:bsd-2 license:bsd-3))))
106
107 (define-public gstreamer
108 (package
109 (name "gstreamer")
110 (version "1.16.2")
111 (source
112 (origin
113 (method url-fetch)
114 (uri (string-append
115 "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
116 version ".tar.xz"))
117 (sha256
118 (base32
119 "0kp93622y29pck8asvil1fmzf55s2gx76wv475a6izc3cwj49w73"))))
120 (build-system meson-build-system)
121 (outputs '("out" "doc"))
122 (arguments
123 `(#:phases
124 (modify-phases %standard-phases
125 ;; FIXME: Since switching to the meson-build-system, two tests
126 ;; started failing on i686. See
127 ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/499>.
128 ,@(if (string-prefix? "i686" (or (%current-target-system)
129 (%current-system)))
130 `((add-after 'unpack 'disable-some-tests
131 (lambda _
132 (substitute* "tests/check/gst/gstsystemclock.c"
133 (("tcase_add_test \\(tc_chain, test_stress_cleanup_unschedule.*")
134 "")
135 (("tcase_add_test \\(tc_chain, test_stress_reschedule.*")
136 ""))
137 #t)))
138 '())
139 (add-after 'install 'move-docs
140 (lambda* (#:key outputs #:allow-other-keys)
141 (let ((out (assoc-ref outputs "out"))
142 (doc (assoc-ref outputs "doc")))
143 (mkdir-p (string-append doc "/share"))
144 (copy-recursively (string-append out "/share/gtk-doc")
145 (string-append doc "/share/gtk-doc"))
146 (delete-file-recursively (string-append out "/share/gtk-doc"))
147 #t))))))
148 (propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
149 (native-inputs
150 `(("bison" ,bison)
151 ("flex" ,flex)
152 ("glib" ,glib "bin")
153 ("gobject-introspection" ,gobject-introspection)
154 ("gtk-doc" ,gtk-doc)
155 ("perl" ,perl)
156 ("pkg-config" ,pkg-config)
157 ("python-wrapper" ,python-wrapper)))
158 (native-search-paths
159 (list (search-path-specification
160 (variable "GST_PLUGIN_SYSTEM_PATH")
161 (files '("lib/gstreamer-1.0")))))
162 (home-page "https://gstreamer.freedesktop.org/")
163 (synopsis "Multimedia library")
164 (description
165 "GStreamer is a library for constructing graphs of media-handling
166 components. The applications it supports range from simple Ogg/Vorbis
167 playback, audio/video streaming to complex audio mixing and video
168 non-linear editing.
169
170 Applications can take advantage of advances in codec and filter technology
171 transparently. Developers can add new codecs and filters by writing a
172 simple plugin with a clean, generic interface.
173
174 This package provides the core library and elements.")
175 (license license:lgpl2.0+)))
176
177 (define-public gst-plugins-base
178 (package
179 (name "gst-plugins-base")
180 (version "1.16.2")
181 (source
182 (origin
183 (method url-fetch)
184 (uri (string-append "https://gstreamer.freedesktop.org/src/" name "/"
185 name "-" version ".tar.xz"))
186 (sha256
187 (base32
188 "0sl1hxlyq46r02k7z70v09vx1gi4rcypqmzra9jid93lzvi76gmi"))))
189 (build-system meson-build-system)
190 (propagated-inputs
191 `(("glib" ,glib) ;required by gstreamer-sdp-1.0.pc
192 ("gstreamer" ,gstreamer) ;required by gstreamer-plugins-base-1.0.pc
193
194 ;; XXX: Do not enable Orc optimizations on ARM systems because
195 ;; it leads to two test failures.
196 ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/issues/683
197 ,@(if (string-prefix? "arm" (or (%current-target-system)
198 (%current-system)))
199 '()
200 `(("orc" ,orc))))) ;required by gstreamer-audio-1.0.pc
201 (inputs
202 `(("cdparanoia" ,cdparanoia)
203 ("pango" ,pango)
204 ("libogg" ,libogg)
205 ("libtheora" ,libtheora)
206 ("libvorbis" ,libvorbis)
207 ("libx11" ,libx11)
208 ("zlib" ,zlib)
209 ("libXext" ,libxext)
210 ("libxv" ,libxv)
211 ("alsa-lib" ,alsa-lib)
212 ;; XXX Don't build with opus on 32-bit systems:
213 ;; <https://bugs.gnu.org/32360>
214 ,@(if (target-64bit?)
215 `(("opus" ,opus))
216 '())))
217 (native-inputs
218 `(("pkg-config" ,pkg-config)
219 ("glib:bin" ,glib "bin")
220 ("gobject-introspection" ,gobject-introspection)
221 ("python-wrapper" ,python-wrapper)))
222 (arguments
223 '(#:configure-flags '("-Dgl=disabled"
224 ;; FIXME: Documentation fails to build without
225 ;; enabling GL above, which causes other problems.
226 "-Ddoc=false")
227 #:phases
228 (modify-phases %standard-phases
229 (add-before 'configure 'patch
230 (lambda _
231 (substitute* "tests/check/libs/pbutils.c"
232 (("/bin/sh") (which "sh")))
233 #t)))))
234 (home-page "https://gstreamer.freedesktop.org/")
235 (synopsis
236 "Plugins for the GStreamer multimedia library")
237 (description "This package provides an essential exemplary set of plug-ins
238 for the GStreamer multimedia library.")
239 (license license:lgpl2.0+)))
240
241 (define-public gst-plugins-good
242 (package
243 (name "gst-plugins-good")
244 (version "1.16.2")
245 (source
246 (origin
247 (method url-fetch)
248 (uri (string-append
249 "https://gstreamer.freedesktop.org/src/" name "/"
250 name "-" version ".tar.xz"))
251 (sha256
252 (base32
253 "068k3cbv1yf3gbllfdzqsg263kzwh21y8dpwr0wvgh15vapkpfs0"))))
254 (build-system meson-build-system)
255 (inputs
256 `(("aalib" ,aalib)
257 ("cairo" ,cairo)
258 ("flac" ,flac)
259 ("gdk-pixbuf" ,gdk-pixbuf)
260 ("gst-plugins-base" ,gst-plugins-base)
261 ("gtk+" ,gtk+)
262 ("jack" ,jack-1)
263 ("lame" ,lame)
264 ("libavc1394" ,libavc1394)
265 ("libcaca" ,libcaca)
266 ("libdv" ,libdv)
267 ("libiec61883" ,libiec61883)
268 ("libjpeg" ,libjpeg-turbo)
269 ("libpng" ,libpng)
270 ("libshout" ,libshout)
271 ("libsoup" ,libsoup)
272 ("libvpx" ,libvpx)
273 ("mpg123" ,mpg123)
274 ("orc" ,orc)
275 ("pulseaudio" ,pulseaudio)
276 ("speex" ,speex)
277 ("taglib" ,taglib)
278 ("twolame" ,twolame)
279 ("wavpack" ,wavpack)))
280 (native-inputs
281 `(("glib:bin" ,glib "bin")
282 ("pkg-config" ,pkg-config)
283 ("python-wrapper" ,python-wrapper)))
284 (arguments
285 `(#:phases
286 (modify-phases %standard-phases
287 ,@(if (string-prefix? "arm" (or (%current-target-system)
288 (%current-system)))
289 ;; FIXME: These tests started failing on armhf after switching to Meson.
290 ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/issues/689
291 `((add-after 'unpack 'disable-tests-for-armhf
292 (lambda _
293 (substitute* "tests/check/elements/rtpbin_buffer_list.c"
294 (("tcase_add_test \\(tc_chain, test_bufferlist\\);")
295 ""))
296 (substitute* "tests/check/elements/rtpulpfec.c"
297 (("tcase_add_loop_test.*rtpulpfecdec_recovered_from_many.*")
298 "")
299 (("tcase_add.*rtpulpfecdec_recovered_using_recovered_packet.*")
300 ""))
301 #t)))
302 '())
303 (add-after
304 'unpack 'disable-failing-tests
305 (lambda _
306 ;; Disable tests that fail non-deterministically.
307 ;; This test fails on aarch64 on 1.12.x.
308 (substitute* "tests/check/elements/alpha.c"
309 (("tcase_add_test \\(tc_chain, test_chromakeying\\);" all)
310 (string-append "/* " all " */")))
311 #t)))))
312 (home-page "https://gstreamer.freedesktop.org/")
313 (synopsis
314 "Plugins for the GStreamer multimedia library")
315 (description "GStreamer Good Plug-ins is a set of plug-ins for the
316 GStreamer multimedia library. This set contains those plug-ins which the
317 developers consider to have good quality code and correct functionality.")
318 (license license:lgpl2.0+)))
319
320 (define-public gst-plugins-bad
321 (package
322 (name "gst-plugins-bad")
323 (version "1.16.2")
324 (source (origin
325 (method url-fetch)
326 (uri (string-append "https://gstreamer.freedesktop.org/src/"
327 name "/" name "-" version ".tar.xz"))
328 (sha256
329 (base32
330 "0x0y0hm0ga3zqi5q4090hw5sjh59y1ry9ak16qsaascm72i7mjzi"))))
331 (build-system meson-build-system)
332 (arguments
333 `(#:phases
334 (modify-phases %standard-phases
335 ,@(if (string-prefix? "arm" (or (%current-target-system)
336 (%current-system)))
337 ;; Disable test that fails on ARMv7.
338 ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/issues/1188
339 `((add-after 'unpack 'disable-asfmux-test
340 (lambda _
341 (substitute* "tests/check/meson.build"
342 (("\\[\\['elements/asfmux\\.c'\\]\\],")
343 ""))
344 #t)))
345 '())
346 (add-after 'unpack 'disable-failing-test
347 (lambda _
348 ;; FIXME: Why is this failing.
349 (substitute* "tests/check/meson.build"
350 ((".*elements/dash_mpd\\.c.*")
351 ""))
352 #t)))))
353 (propagated-inputs
354 `(("gst-plugins-base" ,gst-plugins-base)))
355 (native-inputs
356 `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
357 ("gobject-introspection" ,gobject-introspection)
358 ;; TODO: Enable documentation for 1.18.
359 ;;("gtk-doc" ,gtk-doc)
360 ("pkg-config" ,pkg-config)
361 ("python" ,python)))
362 (inputs
363 ;; XXX: The following dependencies are missing:
364 ;; vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,
365 ;; faac, flite, libgsm, libde265, libmms, libmimic, mjpegtools,
366 ;; mpeg2enc, libofa, opencv, openh264, openni2, libtimemmgr, wildmidi,
367 ;; openspc, gme, sbc, schroedinger, zbar, librtmp, spandsp
368 `(("bluez" ,bluez)
369 ("curl" ,curl)
370 ("faad2" ,faad2)
371 ("fluidsynth" ,fluidsynth)
372 ("gtk+" ,gtk+)
373 ("ladspa" ,ladspa)
374 ("libass" ,libass)
375 ("libdvdnav" ,libdvdnav)
376 ("libdvdread" ,libdvdread)
377 ("libgcrypt" ,libgcrypt)
378 ("libgudev" ,libgudev)
379 ("libkate" ,libkate)
380 ("libmodplug" ,libmodplug)
381 ("librsvg" ,librsvg)
382 ("libsndfile" ,libsndfile)
383 ("libsrtp" ,libsrtp)
384 ("libssh2" ,libssh2)
385 ("libusb" ,libusb)
386 ("libvdpau" ,libvdpau)
387 ("libwebp" ,libwebp)
388 ("libxml2" ,libxml2)
389 ("lrdf" ,lrdf)
390 ("mesa" ,mesa)
391 ("neon" ,neon)
392 ("openal" ,openal)
393 ("openexr" ,openexr)
394 ("openjpeg" ,openjpeg)
395 ("openssl" ,openssl)
396 ("opus" ,opus)
397 ("orc" ,orc)
398 ;("qtbase" ,qtbase)
399 ;("qtdeclarative" ,qtdeclarative)
400 ;("qtx11extras" ,qtx11extras)
401 ("soundtouch" ,soundtouch)
402 ("x265" ,x265)
403 ("wayland" ,wayland)))
404 (home-page "https://gstreamer.freedesktop.org/")
405 (synopsis "Plugins for the GStreamer multimedia library")
406 (description
407 "GStreamer Bad Plug-ins is a set of plug-ins whose quality aren't up to
408 par compared to the rest.")
409 (license license:lgpl2.0+)))
410
411 (define-public gst-plugins-ugly
412 (package
413 (name "gst-plugins-ugly")
414 (version "1.16.2")
415 (source
416 (origin
417 (method url-fetch)
418 (uri (string-append "https://gstreamer.freedesktop.org/src/"
419 name "/" name "-" version ".tar.xz"))
420 (sha256
421 (base32
422 "1jpvc32x6q01zjkfgh6gmq6aaikiyfwwnhj7bmvn52syhrdl202m"))))
423 (build-system meson-build-system)
424 (inputs
425 `(("gst-plugins-base" ,gst-plugins-base)
426 ("liba52" ,liba52)
427 ("libcdio" ,libcdio)
428 ("libmpeg2" ,libmpeg2)
429 ("libdvdread" ,libdvdread)
430 ("libx264" ,libx264)
431 ;; TODO:
432 ;; * opencore-amr (for the AMR-NB decoder and encoder and the
433 ;; AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>
434 ("orc" ,orc)))
435 (native-inputs
436 `(("glib:bin" ,glib "bin")
437 ("pkg-config" ,pkg-config)
438 ("python-wrapper" ,python-wrapper)))
439 (home-page "https://gstreamer.freedesktop.org/")
440 (synopsis "GStreamer plugins from the \"ugly\" set")
441 (description "GStreamer Ugly Plug-ins. This set contains those plug-ins
442 which the developers consider to have good quality code but that might pose
443 distribution problems in some jurisdictions, e.g. due to patent threats.")
444 (license license:lgpl2.0+)))
445
446 (define-public gst-libav
447 (package
448 (name "gst-libav")
449 (version "1.16.2")
450 (source (origin
451 (method url-fetch)
452 (uri (string-append
453 "https://gstreamer.freedesktop.org/src/" name "/"
454 name "-" version ".tar.xz"))
455 (sha256
456 (base32
457 "1wpfilc98bad9nsv3y1qapxp35dvn2mvwvrmqwrsj58cf09gc967"))
458 (modules '((guix build utils)))
459 (snippet
460 '(begin
461 ;; Drop bundled ffmpeg.
462 (delete-file-recursively "gst-libs/ext/libav")
463 #t))))
464 (build-system meson-build-system)
465 (native-inputs
466 `(("pkg-config" ,pkg-config)
467 ("python" ,python)))
468 (inputs
469 `(("gst-plugins-base" ,gst-plugins-base)
470 ("ffmpeg" ,ffmpeg)
471 ("orc" ,orc)
472 ("zlib" ,zlib)))
473 (home-page "https://gstreamer.freedesktop.org/")
474 (synopsis "Plugins for the GStreamer multimedia library")
475 (description
476 "This GStreamer plugin supports a large number of audio and video
477 compression formats through the use of the libav library.")
478 (license license:gpl2+)))
479
480 (define-public gst-editing-services
481 (package
482 (name "gst-editing-services")
483 (version "1.16.2")
484 (source (origin
485 (method url-fetch)
486 (uri (string-append
487 "https://gstreamer.freedesktop.org/src/" name "/"
488 "gstreamer-editing-services-" version ".tar.xz"))
489 (sha256
490 (base32
491 "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
492 (build-system meson-build-system)
493 (arguments
494 ;; FIXME: 16/22 failing tests.
495 `(#:tests? #f))
496 (inputs
497 `(("gst-plugins-base" ,gst-plugins-base)
498 ("libxml2" ,libxml2)))
499 (native-inputs
500 `(("flex" ,flex)
501 ("gst-plugins-bad" ,gst-plugins-bad)
502 ("gst-plugins-good" ,gst-plugins-good)
503 ("perl" ,perl)
504 ("pkg-config" ,pkg-config)
505 ("python" ,python)))
506 (home-page "https://gstreamer.freedesktop.org/")
507 (synopsis "GStreamer library for non-linear editors")
508 (description
509 "This is a high-level library for facilitating the creation of audio/video
510 non-linear editors.")
511 (license license:gpl2+)))
512
513 (define-public python-gst
514 (package
515 (name "python-gst")
516 (version "1.16.2")
517 (source (origin
518 (method url-fetch)
519 (uri (string-append
520 "https://gstreamer.freedesktop.org/src/gst-python/"
521 "gst-python-" version ".tar.xz"))
522 (sha256
523 (base32
524 "1a48ca66izmm8hnp608jv5isg3jxb0vlfmhns0bg9nbkilag7390"))
525 (patches
526 (search-patches "python-gst-fix-build-with-python-3.8.patch"))))
527 (build-system meson-build-system)
528 (arguments
529 `(#:modules ((guix build meson-build-system)
530 (guix build utils)
531 ((guix build python-build-system) #:prefix python:))
532 #:imported-modules (,@%meson-build-system-modules
533 (guix build python-build-system))
534 #:configure-flags
535 (list (string-append
536 "-Dpygi-overrides-dir="
537 (python:site-packages %build-inputs %outputs) "gi/overrides"))))
538 (native-inputs
539 `(("pkg-config" ,pkg-config)
540 ("python" ,python)))
541 (propagated-inputs
542 `(("gst-plugins-base" ,gst-plugins-base)
543 ("python-pygobject" ,python-pygobject)))
544 (home-page "https://gstreamer.freedesktop.org/")
545 (synopsis "GStreamer GObject Introspection overrides for Python")
546 (description
547 "This package contains GObject Introspection overrides for Python that can
548 be used by Python applications using GStreamer.")
549 (license license:lgpl2.1+)
550 (properties `((python2-variant . ,(delay python2-gst))))))
551
552 (define-public python2-gst
553 (package (inherit python-gst)
554 (name "python2-gst")
555 (native-inputs
556 `(("pkg-config" ,pkg-config)
557 ("python" ,python-2)))
558 (propagated-inputs
559 `(("gst-plugins-base" ,gst-plugins-base)
560 ("python-pygobject" ,python2-pygobject)))))
561
562 (define-public gst123
563 (package
564 (name "gst123")
565 (version "0.3.5")
566 (source (origin
567 (method url-fetch)
568 (uri (string-append "http://space.twc.de/~stefan/gst123/gst123-"
569 version ".tar.bz2"))
570 (sha256
571 (base32
572 "0zaa117n4wkya9p903vkj8hj58lmdb66pxsdx5wwcv7nffbp5d67"))))
573 (build-system gnu-build-system)
574 (inputs
575 `(("gtk+" ,gtk+-2)
576 ("ncurses" ,ncurses)
577 ("gstreamer" ,gstreamer)
578 ("gst-plugins-base" ,gst-plugins-base)))
579 (native-inputs
580 `(("pkg-config" ,pkg-config)))
581 (home-page "http://space.twc.de/~stefan/gst123.php")
582 (synopsis "Flexible command line media player based on gstreamer")
583 (description "The program gst123 is designed to be a more flexible command
584 line player in the spirit of ogg123 and mpg123, based on the gstreamer media
585 framework. It plays all file formats gstreamer supports, so if you have a
586 music collection which contains different file formats, like flac, ogg and
587 mp3, you can use gst123 to play all your music files.")
588 (license license:lgpl2.0+)))