Merge branch 'gnome-updates'
[jackhill/guix/guix.git] / gnu / packages / patches / tophat-build-with-later-seqan.patch
1 This patch resolves a build failure when building TopHat 2.1.0 with SeqAn 1.4.
2 This is the relevant part of a patch originally posted here:
3 https://lists.fu-berlin.de/pipermail/seqan-dev/2014-July/msg00001.html
4
5 --- a/src/segment_juncs.cpp
6 +++ b/src/segment_juncs.cpp
7 @@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
8 typedef map<uint32_t, IntronMotifs> MotifMap;
9
10 MotifMap ims;
11 -
12 - seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
13 - seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
14 -
15 +
16 + typedef seqan::ModifiedString<
17 + seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,
18 + seqan::ModReverse> ConstDnaStringReverseComplement;
19 + ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
20 + ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
21 +
22 if (talkative)
23 fprintf(stderr, "Collecting potential splice sites in islands\n");
24