Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / vim.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages vim)
20 #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gawk)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages admin) ; For GNU hostname
29 #:use-module (gnu packages tcsh))
30
31 (define-public vim
32 (package
33 (name "vim")
34 (version "7.4")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "ftp://ftp.vim.org/pub/vim/unix/vim-"
38 version ".tar.bz2"))
39 (sha256
40 (base32
41 "1pjaffap91l2rb9pjnlbrpvb3ay5yhhr3g91zabjvw1rqk9adxfh"))))
42 (build-system gnu-build-system)
43 (arguments
44 `(#:test-target "test"
45 #:parallel-tests? #f
46 #:phases
47 (alist-replace
48 'configure
49 (lambda* (#:key #:allow-other-keys #:rest args)
50 (let ((configure (assoc-ref %standard-phases 'configure)))
51 (apply configure args)
52 (substitute* "runtime/tools/mve.awk"
53 (("/usr/bin/nawk") (which "gawk")))
54 (substitute* "src/testdir/Makefile"
55 (("/bin/sh") (which "sh")))))
56 %standard-phases)))
57 (inputs
58 `(("gawk", gawk)
59 ("inetutils", inetutils)
60 ("ncurses", ncurses)
61 ("perl", perl)
62 ("tcsh" ,tcsh))) ; For runtime/tools/vim32
63 (home-page "http://www.vim.org/")
64 (synopsis "VIM 7.3, a text editor based on vi.")
65 (description
66 "Vim is a highly configurable text editor built to enable efficient text
67 editing. It is an improved version of the vi editor distributed with most UNIX
68 systems.
69
70 Vim is often called a \"programmer's editor,\" and so useful for programming
71 that many consider it an entire IDE. It's not just for programmers, though. Vim
72 is perfect for all kinds of text editing, from composing email to editing
73 configuration files. ")
74 (license license:vim)))