distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / zile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages zile)
20 #:use-module (guix licenses)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages bdw-gc)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages help2man)
27 #:use-module (gnu packages ncurses))
28
29 (define-public zile
30 (package
31 (name "zile")
32 (version "2.4.9")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/zile/zile-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0j801c28ypm924rw3lqyb6khxyslg6ycrv16wmmwcam0mk3mj6f7"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("boehm-gc" ,libgc)
44 ("ncurses" ,ncurses)
45 ("perl" ,perl)
46 ("help2man" ,help2man)))
47 (home-page "http://www.gnu.org/software/zile/")
48 (synopsis "GNU Zile, a lightweight Emacs clone")
49 (description
50 "GNU Zile, which is a lightweight Emacs clone. Zile is short
51 for Zile Is Lossy Emacs. Zile has been written to be as
52 similar as possible to Emacs; every Emacs user should feel at
53 home.
54
55 Zile has all of Emacs's basic editing features: it is 8-bit
56 clean (though it currently lacks Unicode support), and the
57 number of editing buffers and windows is only limited by
58 available memory and screen space respectively. Registers,
59 minibuffer completion and auto fill are available. Function
60 and variable names are identical with Emacs's (except those
61 containing the word \"emacs\", which instead contain the word
62 \"zile\"!).
63
64 However, all of this is packed into a program which typically
65 compiles to about 130Kb.")
66 (license gpl3+)))