distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / pkg-config.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pkg-config)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu))
25
26 (define-public pkg-config
27 (package
28 (name "pkg-config")
29 (version "0.27.1")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "http://pkgconfig.freedesktop.org/releases/pkg-config-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "05wc5nwkqz7saj2v33ydmz1y6jdg659dll4jjh91n41m63gx0qsg"))))
38 (build-system gnu-build-system)
39 (arguments `(#:configure-flags '("--with-internal-glib")))
40 (home-page "http://www.freedesktop.org/wiki/Software/pkg-config")
41 (license gpl2+)
42 (synopsis "a helper tool used when compiling applications and
43 libraries")
44 (description
45 "pkg-config is a helper tool used when compiling applications and
46 libraries. It helps you insert the correct compiler options on the
47 command line so an application can use gcc -o test test.c `pkg-config
48 --libs --cflags glib-2.0` for instance, rather than hard-coding values
49 on where to find glib (or other libraries). It is language-agnostic, so
50 it can be used for defining the location of documentation tools, for
51 instance.")))