distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / patches / guile-1.8-cpp-4.5.patch
1 Fix doc snarfing with GCC 4.5+.
2 From <http://git.savannah.gnu.org/cgit/guile.git/commit/?h=branch_release-1-8&id=aac41d28358cea594bb30f6e547afb82bb6004a6>.
3
4 diff --git a/scripts/snarf-check-and-output-texi b/scripts/snarf-check-and-output-texi
5 index ea33e17..8cd42e8 100755
6 --- a/scripts/snarf-check-and-output-texi
7 +++ b/scripts/snarf-check-and-output-texi
8 @@ -267,6 +267,17 @@ exec ${GUILE-guile} -l $0 -c "(apply $main (cdr (command-line)))" "$@"
9 (set! *file* file)
10 (set! *line* line))
11
12 + ;; newer gccs like to throw around more location markers into the
13 + ;; preprocessed source; these (hash . hash) bits are what they translate to
14 + ;; in snarfy terms.
15 + (('location ('string . file) ('int . line) ('hash . 'hash))
16 + (set! *file* file)
17 + (set! *line* line))
18 +
19 + (('location ('hash . 'hash) ('string . file) ('int . line) ('hash . 'hash))
20 + (set! *file* file)
21 + (set! *line* line))
22 +
23 (('arglist rest ...)
24 (set! *args* (do-arglist rest)))