distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / patches / flex-bison-tests.patch
1 The `test-bison-yyl{loc,val}' tests fail with "conflicting types for
2 'testparse'" because `YYPARSE_PARAM' is undefined; work around that.
3
4 --- flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:01.000000000 +0100
5 +++ flex-2.5.37/tests/test-bison-yylloc/main.c 2012-11-22 18:17:07.000000000 +0100
6 @@ -21,6 +21,7 @@
7 * PURPOSE.
8 */
9
10 +#define YYPARSE_PARAM scanner
11 #include "parser.h"
12 #include "scanner.h"
13
14
15 --- flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:42.000000000 +0100
16 +++ flex-2.5.37/tests/test-bison-yylval/main.c 2012-11-22 18:17:49.000000000 +0100
17 @@ -21,6 +21,7 @@
18 * PURPOSE.
19 */
20
21 +#define YYPARSE_PARAM scanner
22 #include "parser.h"
23 #include "scanner.h"
24