distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / mit-krb5.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mit-krb5)
20 #:use-module (distro)
21 #:use-module (gnu packages bison)
22 #:use-module (gnu packages perl)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public mit-krb5
29 (package
30 (name "mit-krb5")
31 (version "1.11")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "http://web.mit.edu/kerberos/www/dist/krb5/"
35 version
36 "/krb5-" version
37 "-signed.tar"))
38 (sha256 (base32
39 "0lc6lxb98qzg4x01lppq700vkr1ax9rld09znahrinwqnf9zndzy"))))
40 (build-system gnu-build-system)
41 (inputs `(("bison" ,bison)
42 ("perl" ,perl)
43 ))
44 (arguments
45 (lambda (system)
46 `(#:tests? #f
47 #:phases
48 (alist-replace
49 'unpack
50 (lambda* (#:key source #:allow-other-keys)
51 (system* "echo" source)
52 (let ((inner
53 (substring source
54 (string-index-right source #\k)
55 (string-index-right source #\-))))
56 (system* "echo" inner)
57 (and (zero? (system* "tar" "xvf" source))
58 (zero? (system* "tar" "xvf" (string-append inner ".tar.gz")))
59 (chdir inner)
60 (chdir "src"))))
61 %standard-phases))))
62 (synopsis "MIT Kerberos 5")
63 (description
64 "Massachusetts Institute of Technology implementation of Kerberos.
65 Kerberos is a network authentication protocol designed to provide strong
66 authentication for client/server applications by using secret-key cryptography.")
67 (license (bsd-style "file://NOTICE"
68 "See NOTICE in the distribution."))
69 (home-page "http://web.mit.edu/kerberos/")))