distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / libsigsegv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libsigsegv)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu))
25
26 (define-public libsigsegv
27 (package
28 (name "libsigsegv")
29 (version "2.10")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "mirror://gnu/libsigsegv/libsigsegv-"
34 version ".tar.gz"))
35 (sha256
36 (base32 "16hrs8k3nmc7a8jam5j1fpspd6sdpkamskvsdpcw6m29vnis8q44"))))
37 (build-system gnu-build-system)
38 (home-page "http://www.gnu.org/software/libsigsegv/")
39 (synopsis "GNU libsigsegv, a library to handle page faults in user mode")
40 (description
41 "GNU libsigsegv is a library for handling page faults in user mode. A page
42 fault occurs when a program tries to access to a region of memory that is
43 currently not available. Catching and handling a page fault is a useful
44 technique for implementing pageable virtual memory, memory-mapped access to
45 persistent databases, generational garbage collectors, stack overflow
46 handlers, distributed shared memory, and more.")
47 (license gpl2+)))