distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / gnupg.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnupg)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages pth)
22 #:use-module (gnu packages readline)
23 #:use-module ((gnu packages compression)
24 #:renamer (symbol-prefix-proc 'guix:))
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public libgpg-error
30 (package
31 (name "libgpg-error")
32 (version "1.10")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnupg/libgpg-error/libgpg-error-"
37 version ".tar.bz2"))
38 (sha256
39 (base32
40 "0cal3jdnzdailr13qcy74grfbplbghkgr3qwk6qjjp4bass2j1jj"))))
41 (build-system gnu-build-system)
42 (home-page "http://gnupg.org")
43 (synopsis
44 "Libgpg-error, a small library that defines common error values for all GnuPG components")
45 (description
46 "Libgpg-error is a small library that defines common error values
47 for all GnuPG components. Among these are GPG, GPGSM, GPGME,
48 GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard
49 Daemon and possibly more in the future.")
50 (license lgpl2.0+)))
51
52 (define-public libgcrypt
53 (package
54 (name "libgcrypt")
55 (version "1.5.0")
56 (source
57 (origin
58 (method url-fetch)
59 (uri (string-append "mirror://gnupg/libgcrypt/libgcrypt-"
60 version ".tar.bz2"))
61 (sha256
62 (base32
63 "1ykkh7dm0gyndz7bbpvn3agijj8xb2h02m02f42hm504c18zqqjb"))))
64 (build-system gnu-build-system)
65 (propagated-inputs
66 `(("libgpg-error" ,libgpg-error)))
67 (home-page "http://gnupg.org/")
68 (synopsis
69 "GNU Libgcrypt, a general-pupose cryptographic library")
70 (description
71 "GNU Libgcrypt is a general purpose cryptographic library based on
72 the code from GnuPG. It provides functions for all
73 cryptographic building blocks: symmetric ciphers, hash
74 algorithms, MACs, public key algorithms, large integer
75 functions, random numbers and a lot of supporting functions.")
76 (license lgpl2.0+)))
77
78 (define-public libassuan
79 (package
80 (name "libassuan")
81 (version "2.0.3")
82 (source
83 (origin
84 (method url-fetch)
85 (uri (string-append "mirror://gnupg/libassuan/libassuan-"
86 version ".tar.bz2"))
87 (sha256
88 (base32
89 "06xckkvxxlx7cj77803m8x58gxksap4k8yhspc5cqsy7fhinimds"))))
90 (build-system gnu-build-system)
91 (propagated-inputs
92 `(("libgpg-error" ,libgpg-error) ("pth" ,pth)))
93 (home-page "http://gnupg.org")
94 (synopsis
95 "Libassuan, the IPC library used by GnuPG and related software")
96 (description
97 "Libassuan is a small library implementing the so-called Assuan
98 protocol. This protocol is used for IPC between most newer
99 GnuPG components. Both, server and client side functions are
100 provided.")
101 (license lgpl2.0+)))
102
103 (define-public libksba
104 (package
105 (name "libksba")
106 (version "1.2.0")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append
111 "mirror://gnupg/libksba/libksba-"
112 version ".tar.bz2"))
113 (sha256
114 (base32
115 "0jwk7hm3x3g4hd7l12z3d79dy7359x7lc88dq6z7q0ixn1jwxbq9"))))
116 (build-system gnu-build-system)
117 (propagated-inputs
118 `(("libgpg-error" ,libgpg-error)))
119 (home-page "http://www.gnupg.org")
120 (synopsis
121 "Libksba is a CMS and X.509 access library under development")
122 (description
123 "KSBA (pronounced Kasbah) is a library to make X.509 certificates
124 as well as the CMS easily accessible by other applications. Both
125 specifications are building blocks of S/MIME and TLS.")
126 (license gpl3+)))
127
128 (define-public gnupg
129 (package
130 (name "gnupg")
131 (version "2.0.19")
132 (source
133 (origin
134 (method url-fetch)
135 (uri (string-append "mirror://gnupg/gnupg/gnupg-" version
136 ".tar.bz2"))
137 (sha256
138 (base32
139 "08n636sfffs5qvg9ppiprvsh00q0dmdw425psg3m3nssja53m8pg"))))
140 (build-system gnu-build-system)
141 (inputs
142 `(;; TODO: Add missing optional deps.
143 ;; ("curl" ,curl)
144 ;; ("libusb" ,libusb)
145 ;; ("openldap" ,openldap)
146
147 ("bzip2" ,guix:bzip2)
148 ("libassuan" ,libassuan)
149 ("libgcrypt" ,libgcrypt)
150 ("libksba" ,libksba)
151 ("pth" ,pth)
152 ("libgpg-error" ,libgpg-error)
153 ("zlib" ,guix:zlib)
154 ("readline" ,readline)))
155 (home-page "http://gnupg.org/")
156 (synopsis
157 "GNU Privacy Guard (GnuPG), GNU Project's implementation of the OpenPGP standard")
158 (description
159 "GnuPG is the GNU project's complete and free implementation of
160 the OpenPGP standard as defined by RFC4880. GnuPG allows to
161 encrypt and sign your data and communication, features a
162 versatile key managment system as well as access modules for all
163 kind of public key directories. GnuPG, also known as GPG, is a
164 command line tool with features for easy integration with other
165 applications. A wealth of frontend applications and libraries
166 are available. Version 2 of GnuPG also provides support for
167 S/MIME.")
168 (license gpl3+)))