distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / ed.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ed)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public ed
26 (package
27 (name "ed")
28 (version "1.5")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append
33 "mirror://gnu/ed/ed-"
34 version
35 ".tar.gz"))
36 (sha256
37 (base32
38 "18gvhyhwpabmgv4lh21lg8vl3z7acdyhh2mr2kj9g75wksj39pcp"))))
39 (build-system gnu-build-system)
40 (arguments '(#:configure-flags '("CC=gcc")))
41 (home-page "http://www.gnu.org/software/ed/")
42 (synopsis
43 "GNU ed, an implementation of the standard Unix editor")
44 (description
45 "GNU ed is a line-oriented text editor. It is used to create,
46 display, modify and otherwise manipulate text files, both
47 interactively and via shell scripts. A restricted version of ed,
48 red, can only edit files in the current directory and cannot
49 execute shell commands. Ed is the \"standard\" text editor in the
50 sense that it is the original editor for Unix, and thus widely
51 available. For most purposes, however, it is superseded by
52 full-screen editors such as GNU Emacs or GNU Moe.")
53 (license gpl3+)))