distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / bdw-gc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages bdw-gc)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu))
25
26 (define-public libgc
27 (package
28 (name "libgc")
29 (version "7.2alpha6")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append
33 "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "05jwadjbrv8pr7z9cb4miskicxqpxm0pca4h2rg5cgbpajr2bx7b"))))
38 (build-system gnu-build-system)
39 (synopsis "The Boehm-Demers-Weiser conservative garbage collector
40 for C and C++")
41 (description
42 "The Boehm-Demers-Weiser conservative garbage collector can be used
43 as a garbage collecting replacement for C malloc or C++ new. It allows
44 you to allocate memory basically as you normally would, without
45 explicitly deallocating memory that is no longer useful. The collector
46 automatically recycles memory when it determines that it can no longer
47 be otherwise accessed.
48
49 The collector is also used by a number of programming language
50 implementations that either use C as intermediate code, want to
51 facilitate easier interoperation with C libraries, or just prefer the
52 simple collector interface.
53
54 Alternatively, the garbage collector may be used as a leak detector for
55 C or C++ programs, though that is not its primary goal.")
56 (home-page "http://www.hpl.hp.com/personal/Hans_Boehm/gc/")
57
58 ;; permissive X11-style license:
59 ;; http://www.hpl.hp.com/personal/Hans_Boehm/gc/license.txt
60 (license x11)))