distro: Change the module name space to (gnu ...).
[jackhill/guix/guix.git] / gnu / packages / acl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages acl)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages attr)
22 #:use-module (gnu packages perl)
23 #:use-module ((gnu packages gettext)
24 #:renamer (symbol-prefix-proc 'guix:))
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public acl
30 (package
31 (name "acl")
32 (version "2.2.51")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://savannah/acl/acl-"
37 version ".src.tar.gz"))
38 (sha256
39 (base32
40 "09aj30m49ivycl3irram8c3givc0crivjm3ymw0nhfaxrwhlb186"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:phases
44 (alist-cons-after
45 'configure 'patch-makefile-SHELL
46 (lambda _
47 (patch-makefile-SHELL "include/buildmacros"))
48 (alist-replace
49 'check
50 (lambda _
51 (system* "make" "tests" "-C" "test")
52
53 ;; XXX: Ignore the test result since this is
54 ;; dependent on the underlying file system.
55 #t)
56 %standard-phases))))
57 (inputs `(("attr" ,attr)
58 ("gettext" ,guix:gettext)
59 ("perl" ,perl)))
60 (home-page
61 "http://savannah.nongnu.org/projects/acl")
62 (synopsis
63 "Library and tools for manipulating access control lists")
64 (description
65 "Library and tools for manipulating access control lists.")
66 (license '(gpl2+ lgpl2.1+))))