gnu: xf86-input-libinput: Update to 0.25.0.
[jackhill/guix/guix.git] / gnu / packages / gprolog.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gprolog)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix build-system gnu)
25 #:use-module (srfi srfi-1))
26
27 (define-public gprolog
28 (package
29 (name "gprolog")
30 (version "1.4.4")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/gprolog/gprolog-" version
35 ".tar.gz"))
36 (sha256
37 (base32
38 "13miyas47bmijmadm68cbvb21n4s156gjafz7kfx9brk9djfkh0q"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:configure-flags
42 (list (string-append
43 "--with-install-dir=" %output "/share/gprolog"))
44 #:phases (alist-cons-before
45 'configure 'change-dir-n-fix-shells
46 (lambda _
47 (chdir "src")
48 (substitute* "configure"
49 (("-/bin/sh") (string-append "-" (which "sh")))
50 (("= /bin/sh") (string-append "= " (which "sh")))))
51 %standard-phases)))
52 (home-page "https://www.gnu.org/software/gprolog/")
53 (synopsis "Prolog compiler")
54 (description
55 "GNU Prolog is a standards-compliant Prolog compiler with constraint
56 solving over finite domains. It accepts Prolog+ constraint programs and
57 produces a compiled, native binary which can function in a stand-alone
58 manner. It also features an interactive interpreter.")
59 (license (list gpl2+ lgpl3+))
60
61 ;; See 'configure' for the list of supported architectures.
62 (supported-systems (fold delete
63 %supported-systems
64 '("armhf-linux" "mips64el-linux")))))