gnu: seahorse: Update to 3.34.
[jackhill/guix/guix.git] / gnu / packages / patches / crda-optional-gcrypt.patch
1 This patch allows us to make the libgcrypt dependency optional (which it
2 is, if you look at the code), which in turns allows us to build CRDA
3 without the signature-checking capability on 'regulatory.bin'.
4
5 --- crda/Makefile 2015-07-17 11:33:33.546712893 +0200
6 +++ crda/Makefile 2015-07-17 11:34:05.210994373 +0200
7 @@ -45,12 +45,14 @@ LDLIBS += `pkg-config --libs openssl`
8 $(LIBREG): keys-ssl.c
9
10 else
11 +ifeq ($(USE_GCRYPT),1)
12 CFLAGS += -DUSE_GCRYPT
13 LDLIBS += -lgcrypt
14
15 $(LIBREG): keys-gcrypt.c
16
17 endif
18 +endif
19 MKDIR ?= mkdir -p
20 INSTALL ?= install