gnu: gettext: Rename binding to 'gnu-gettext'.
[jackhill/guix/guix.git] / gnu / packages / parted.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages parted)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages check)
25 #:use-module (gnu packages gettext)
26 #:use-module (gnu packages linux)
27 #:use-module (gnu packages readline))
28
29 (define-public parted
30 (package
31 (name "parted")
32 (version "3.1")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/parted/parted-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "05fa4m1bky9d13hqv91jlnngzlyn7y4rnnyq6d86w0dg3vww372y"))))
41 (build-system gnu-build-system)
42 (arguments `(#:configure-flags '("--disable-device-mapper")
43 #:phases (alist-cons-before
44 'configure 'fix-mkswap
45 (lambda* (#:key inputs #:allow-other-keys)
46 (let ((util-linux (assoc-ref inputs
47 "util-linux")))
48 (substitute*
49 "tests/t9050-partition-table-types.sh"
50 (("mkswap")
51 (string-append util-linux "/sbin/mkswap")))))
52 %standard-phases)))
53 (inputs
54 ;; XXX: add 'lvm2'.
55 `(("check" ,check)
56 ("gettext" ,gnu-gettext)
57 ("readline" ,readline)
58 ("util-linux" ,util-linux)))
59 (home-page "http://www.gnu.org/software/parted/")
60 (synopsis "Disk partition editor")
61 (description
62 "Parted is a tool for creating and manipulating disk partition tables.
63 It consists of a library and a command-line tool for performing these tasks.")
64 (license gpl3+)))