gnu: gettext: Rename binding to 'gnu-gettext'.
[jackhill/guix/guix.git] / gnu / packages / cdrom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cdrom)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages acl)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages help2man)
31 #:use-module (gnu packages ncurses)
32 #:use-module (gnu packages patchelf)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages readline)
35 #:use-module (gnu packages which))
36
37 (define-public libcddb
38 (package
39 (name "libcddb")
40 (version "1.3.0")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "mirror://sourceforge/libcddb/libcddb-"
44 version ".tar.bz2"))
45 (sha256
46 (base32
47 "1y8bfy12dwm41m1jahayn3v47dm34fmz7m9cjxyh7xcw6fp3lzaf"))))
48 (build-system gnu-build-system)
49 (arguments '(#:tests? #f)) ; tests rely on access to external servers
50 (home-page "http://libcddb.sourceforge.net/")
51 (synopsis "C library to access data on a CDDB server")
52 (description
53 "Libcddb is a C library to access data on a CDDB server (freedb.org). It
54 allows you to:
55
56 1. search the database for possible CD matches;
57
58 2. retrieve detailed information about a specific CD;
59
60 3. submit new CD entries to the database.
61
62 Libcddb supports both the custom CDDB protocol and tunnelling the query and
63 read operations over plain HTTP. It is also possible to use an HTTP proxy
64 server. If you want to speed things up, you can make use of the built-in
65 caching facility provided by the library.")
66 (license lgpl2.1+)))
67
68 (define-public libcdio
69 (package
70 (name "libcdio")
71 (version "0.90")
72 (source (origin
73 (method url-fetch)
74 (uri (string-append "mirror://gnu/libcdio/libcdio-"
75 version ".tar.gz"))
76 (sha256
77 (base32
78 "0kpp6gr5sjr30pb9klncc37fhkw0wi6r41d2fmvmw17cbj176zmg"))))
79 (build-system gnu-build-system)
80 (inputs
81 `(("help2man" ,help2man)
82 ("ncurses" ,ncurses)
83 ("pkg-config" ,pkg-config)
84 ("libcddb" ,libcddb)))
85 (home-page "http://www.gnu.org/software/libcdio/")
86 (synopsis "CD Input and Control library")
87 (description
88 "The GNU Compact Disc Input and Control Library (libcdio) is a library
89 for CD-ROM and CD image file access. It allows the developer to add CD
90 access to an application without having to worry about the OS- and
91 device-dependent properties of CD-ROM or the specific details of CD image
92 formats.")
93 (license gpl3+)))
94
95 (define-public xorriso
96 (package
97 (name "xorriso")
98 (version "1.3.2")
99 (source (origin
100 (method url-fetch)
101 (uri (string-append "mirror://gnu/xorriso/xorriso-"
102 version ".tar.gz"))
103 (sha256
104 (base32
105 "1z04580nkkziy2flbxjjx0q6vp9p7vcp7yp0agx2aqz3l1vjcwhf"))))
106 (build-system gnu-build-system)
107 (inputs
108 `(("acl" ,acl)
109 ("readline" ,readline)
110 ("bzip2" ,bzip2)
111 ("zlib" ,zlib)
112 ("libcdio" ,libcdio)))
113 (home-page "http://www.gnu.org/software/xorriso/")
114 (synopsis "Create, manipulate, burn ISO-9660 filesystems")
115 (description
116 "xorriso is a tool for copying files to and from ISO 9660 Rock Ridge,
117 a.k.a Compact Disc File System, filesystems and it allows session- wise
118 manipulation of them. It features a formatter and burner for CD DVD and BD.
119 It can operate on existing ISO images or it can create new ones. xorriso can
120 then be used to copy files directly into or out of ISO files.")
121 (license gpl3+)))
122
123 (define-public cdparanoia
124 (package
125 (name "cdparanoia")
126 (version "10.2")
127 (source (origin
128 (method url-fetch)
129 (uri (string-append "http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-"
130 version ".src.tgz"))
131 (sha256
132 (base32
133 "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))
134 (patches (list (search-patch "cdparanoia-fpic.patch")))))
135 (build-system gnu-build-system)
136 (inputs
137 `(("patchelf" ,patchelf)))
138 (arguments
139 `(#:tests? #f ; there is no check target
140 #:modules ((guix build gnu-build-system)
141 (guix build utils)
142 (guix build rpath)
143 (srfi srfi-26))
144 #:imported-modules ((guix build gnu-build-system)
145 (guix build utils)
146 (guix build rpath))
147 #:phases
148 (alist-cons-after
149 'strip 'add-lib-to-runpath
150 (lambda* (#:key outputs #:allow-other-keys)
151 (let* ((out (assoc-ref outputs "out"))
152 (lib (string-append out "/lib")))
153 ;; Add LIB to the RUNPATH of all the executables.
154 (with-directory-excursion out
155 (for-each (cut augment-rpath <> lib)
156 (find-files "bin" ".*")))))
157 %standard-phases)))
158 (home-page "http://www.xiph.org/paranoia/")
159 (synopsis "audio CD reading utility which includes extra data verification features")
160 (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
161 drives. The data can be saved to a file or directed to standard output
162 in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
163 proprietary CDROM drive makes are supported; cdparanoia can determine if the
164 target drive is CDDA capable. In addition to simple reading, cdparanoia adds
165 extra-robust data verification, synchronization, error handling and scratch
166 reconstruction capability.")
167 (license gpl2))) ; libraries under lgpl2.1
168
169 (define-public dvdisaster
170 (package
171 (name "dvdisaster")
172 (version "0.72.4")
173 (source (origin
174 (method url-fetch)
175 (uri (string-append "http://dvdisaster.net/downloads/dvdisaster-"
176 version ".tar.bz2"))
177 (sha256
178 (base32
179 "0pm039a78h7m9vvjmmjfkl05ii6qdmfhvbypxjbc7j5w82y66is4"))))
180 (build-system gnu-build-system)
181 (inputs
182 `(("gettext" ,gnu-gettext)
183 ("gtk+" ,gtk+-2)
184 ("pkg-config" ,pkg-config)
185 ("which" ,which)))
186 (arguments
187 `(#:tests? #f)) ; no check target
188 (home-page "http://dvdisaster.net/en/index.html")
189 (synopsis "error correcting codes for optical media images")
190 (description "Optical media (CD,DVD,BD) keep their data only for a
191 finite time (typically for many years). After that time, data loss develops
192 slowly with read errors growing from the outer media region towards the
193 inside.
194
195 Dvdisaster stores data on CD/DVD/BD (supported media) in a way that it is
196 fully recoverable even after some read errors have developed. This enables
197 you to rescue the complete data to a new medium.
198
199 Data loss is prevented by using error correcting codes. Error correction
200 data is either added to the medium or kept in separate error correction
201 files. Dvdisaster works at the image level so that the recovery does not
202 depend on the file system of the medium. The maximum error correction
203 capacity is user-selectable.")
204 (license gpl2+)))