Merge branch 'staging'
[jackhill/guix/guix.git] / gnu / packages / popt.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages popt)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix build-system cmake)
25 #:use-module (guix licenses))
26
27 (define-public argtable
28 (package
29 (name "argtable")
30 (version "2.13")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "mirror://sourceforge/argtable/argtable/"
35 "argtable-" version "/argtable"
36 (string-join (string-split version #\.) "-")
37 ".tar.gz"))
38 (sha256
39 (base32
40 "1gyxf4bh9jp5gb3l6g5qy90zzcf3vcpk0irgwbv1lc6mrskyhxwg"))))
41 (build-system gnu-build-system)
42 (home-page "http://argtable.sourceforge.net/")
43 (synopsis "Command line option parsing library")
44 (description
45 "Argtable is an ANSI C library for parsing GNU style command line
46 options. It enables a program's command line syntax to be defined in the
47 source code as an array of argtable structs. The command line is then parsed
48 according to that specification and the resulting values are returned in those
49 same structs where they are accessible to the main program. Both tagged (-v,
50 --verbose, --foo=bar) and untagged arguments are supported, as are multiple
51 instances of each argument. Syntax error handling is automatic and the library
52 also provides the means for generating a textual description of the command
53 line syntax.")
54 (license lgpl2.0+)))
55
56 (define-public popt
57 (package
58 (name "popt")
59 (version "1.16")
60 (source (origin
61 (method url-fetch)
62 (uri (string-append "http://rpm5.org/files/popt/popt-"
63 version ".tar.gz"))
64 (sha256
65 (base32
66 "1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))
67 (build-system gnu-build-system)
68 (arguments
69 '(#:phases
70 (modify-phases %standard-phases
71 (add-before 'configure 'patch-test
72 (lambda _
73 (substitute* "test-poptrc.in"
74 (("/bin/echo") (which "echo")))
75 (substitute* "testit.sh" ; don't expect old libtool names
76 (("lt-test1") "test1"))
77 #t)))))
78 (home-page "http://rpm5.org/files/popt/")
79 (synopsis "Command line option parsing library")
80 (description
81 "This is the popt(3) command line option parsing library. While it is
82 similar to getopt(3), it contains a number of enhancements, including:
83
84 - popt is fully reentrant;
85
86 - popt can parse arbitrary argv[] style arrays while getopt(3) makes this
87 quite difficult;
88
89 - popt allows users to alias command line arguments;
90
91 - popt provides convience functions for parsing strings into argv[] style
92 arrays.")
93 (license x11)))
94
95 (define-public gflags
96 (package
97 (name "gflags")
98 (version "2.2.0")
99 (source (origin
100 (method url-fetch)
101 (uri (string-append "https://github.com/gflags/gflags"
102 "/archive/v" version ".tar.gz"))
103 (sha256
104 (base32
105 "120z4w40zr4s8wvfyw1bdmqvincwrwjnimzlwhs1ficaa333cv26"))
106 (file-name (string-append name "-" version ".tar.gz"))))
107 (build-system cmake-build-system)
108 (arguments
109 '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON"
110 "-DBUILD_TESTING=ON")))
111 (home-page "https://gflags.github.io/gflags/")
112 (synopsis "C++ library for command-line argument parsing")
113 (description
114 "Gflags is a C++ library to parse command-line flags. It differs from
115 other such libraries in that command-line flag definitions can be scattered
116 around the source code, and not just listed in one place such as @code{main}.
117 This means that a single source-code file will define and use flags that are
118 meaningful to that file. Any application that links in that file will get the
119 flags, and the gflags library will automatically handle that flag
120 appropriately.")
121 (license bsd-3)))
122
123 (define-public gengetopt
124 (package
125 (name "gengetopt")
126 (version "2.22.6")
127 (source
128 (origin
129 (method url-fetch)
130 (uri (string-append "mirror://gnu/gengetopt/gengetopt-"
131 version ".tar.gz"))
132 (sha256
133 (base32
134 "1xq1kcfs6hri101ss4dhym0jn96z4v6jdvx288mfywadc245mc1h"))))
135 (build-system gnu-build-system)
136 (arguments
137 `(#:parallel-build? #f)) ; not supported
138 (synopsis "Create parsers for command line options")
139 (description
140 "GNU Gengetopt is a program to generate a C/C++ function for parsing
141 command-line options using the getopt_long function found in GNU
142 libc, removing some of the tedium of this task for large programs
143 that accept many options. The options parsed by the generated
144 function may be in both short (e.g., \"-h\") and long (\"--help\")
145 formats, as specified by the GNU coding standards. Additionally, the
146 output of the standard options \"--help\" and \"--version\" is generated
147 automatically.")
148 (home-page "https://www.gnu.org/software/gengetopt/gengetopt.html")
149 (license gpl3+)))