gnu: bedops: Update to 2.4.14.
[jackhill/guix/guix.git] / gnu / packages / mtools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mtools)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public mtools
26 (package
27 (name "mtools")
28 (version "4.0.18")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/mtools/mtools-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "1hxciksv7av5ilnkvwbidyxxr1gzn24lr0mz9z8drkml7780im1h"))))
37 (build-system gnu-build-system)
38 (home-page "https://www.gnu.org/software/mtools/")
39 (synopsis "Access MS-DOS disks without mounting")
40 (description
41 "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
42 or Unix system. It supports long file names and multiple disk formats. It
43 also supports some FAT-specific features such as volume labels and
44 FAT-specific file attributes.")
45 (license gpl3+)))