gnu: ceph: Update to 13.2.2.
[jackhill/guix/guix.git] / gnu / packages / patches / ceph-skip-unittest_blockdev.patch
1 This test tries to walk a sysfs path and hits a null pointer exception.
2
3 /tmp/guix-build-ceph-12.0.0.drv-0/ceph-12.0.0/src/test/common/test_blkdev.cc:32: Failure
4 Expected: (dir) != (nullptr), actual: NULL vs 8-byte object <00-00 00-00 00-00 00-00>
5
6 diff --git a/src/test/common/CMakeLists.txt b/src/test/common/CMakeLists.txt
7 --- a/src/test/common/CMakeLists.txt
8 +++ b/src/test/common/CMakeLists.txt
9 @@ -12,15 +12,6 @@
10 ${CMAKE_DL_LIBS}
11 )
12
13 -if(HAVE_BLKID)
14 - # unittest_blkdev
15 - add_executable(unittest_blkdev
16 - test_blkdev.cc
17 - )
18 - add_ceph_unittest(unittest_blkdev)
19 - target_link_libraries(unittest_blkdev ceph-common ${BLKID_LIBRARIES})
20 -endif()
21 -
22 # unittest_bloom_filter
23 add_executable(unittest_bloom_filter
24 test_bloom_filter.cc