gnu: sbcl-cl-cffi-gtk: Update to 20200417.
[jackhill/guix/guix.git] / gnu / packages / tryton.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages tryton)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages check)
23 #:use-module (gnu packages databases)
24 #:use-module (gnu packages finance)
25 #:use-module (gnu packages gtk)
26 #:use-module (gnu packages python)
27 #:use-module (gnu packages python-web)
28 #:use-module (gnu packages python-xyz)
29 #:use-module (gnu packages time)
30 #:use-module (gnu packages xml)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix build-system python))
34
35 (define-public python-trytond
36 (package
37 (name "python-trytond")
38 (version "4.6.2")
39 (source
40 (origin
41 (method url-fetch)
42 (uri (pypi-uri "trytond" version))
43 (sha256
44 (base32
45 "0asc3pd37h8ky8j66iqxr0fv0k6mpjcwxwm0xgm5hrdi32l5cdda"))))
46 (build-system python-build-system)
47 (inputs
48 `(("python-dateutil" ,python-dateutil)
49 ("python-genshi" ,python-genshi)
50 ("python-polib" ,python-polib)
51 ("python-magic" ,python-magic)
52 ;; there's no python-mysql in Guix right now
53 ;; so python-psycopg2 (postgresql) only for now
54 ("python-psycopg2" ,python-psycopg2)
55 ("python-relatorio" ,python-relatorio)
56 ("python-lxml" ,python-lxml)
57 ("python-sql" ,python-sql)
58 ("python-werkzeug" ,python-werkzeug)
59 ("python-wrapt" ,python-wrapt)))
60 (native-inputs
61 `(("python-mock" ,python-mock)))
62 (arguments
63 `(#:phases
64 (modify-phases %standard-phases
65 (add-before 'check 'preparations
66 (lambda _
67 (setenv "DB_NAME" ":memory:")
68 #t)))))
69 (home-page "https://www.tryton.org/")
70 (synopsis "Server component of Tryton")
71 (description "Tryton is a three-tier high-level general purpose
72 application platform using PostgreSQL as its main database engine. It is the
73 core base of a complete business solution providing modularity, scalability
74 and security.")
75 (license license:gpl3+)))
76
77 (define-public tryton
78 (package
79 (name "tryton")
80 (version "4.6.2")
81 (source
82 (origin
83 (method url-fetch)
84 (uri (pypi-uri "tryton" version))
85 (sha256
86 (base32
87 "0bamr040np02gfjk8c734rw3mbgg75irfgpdcl2npgkdzyw1ksf9"))))
88 (build-system python-build-system)
89 (inputs
90 `(("python2-chardet" ,python2-chardet)
91 ("python2-dateutil" ,python2-dateutil)
92 ("python2-pygtk" ,python2-pygtk)))
93 (arguments
94 `(#:python ,python-2))
95 (home-page "https://www.tryton.org/")
96 (synopsis "Client component of Tryton")
97 (description "This package is the client component of Tryton.")
98 (license license:gpl3+)))
99
100 (define-public python-trytond-country
101 (package
102 (name "python-trytond-country")
103 (version "4.6.0")
104 (source
105 (origin
106 (method url-fetch)
107 (uri (pypi-uri "trytond_country" version))
108 (sha256
109 (base32
110 "11c9mw2scbjn7c6yhlwh5ml266f0s31lh4jwj6gh7vl1shs3isr3"))))
111 (build-system python-build-system)
112 (arguments
113 `(#:phases
114 (modify-phases %standard-phases
115 (add-before 'check 'preparations
116 (lambda _
117 (setenv "DB_NAME" ":memory:")
118 #t)))))
119 (propagated-inputs
120 `(("python-trytond" ,python-trytond)
121 ("python-wrapt" ,python-wrapt)
122 ("python-werkzeug" ,python-werkzeug)
123 ("python-sql" ,python-sql)
124 ("python-polib" ,python-polib)
125 ("python-dateutil" ,python-dateutil)
126 ("python-genshi" ,python-genshi)
127 ("python-relatorio" ,python-relatorio)
128 ("python-magic" ,python-magic)))
129 (home-page "http://www.tryton.org/")
130 (synopsis "Tryton module with countries")
131 (description "This package provides a Tryton module with countries.")
132 (license license:gpl3+)))
133
134 (define-public python-trytond-party
135 (package
136 (name "python-trytond-party")
137 (version "4.6.0")
138 (source
139 (origin
140 (method url-fetch)
141 (uri (pypi-uri "trytond_party" version))
142 (sha256
143 (base32
144 "0fbf4kxywiglcdsx9ppjg7nxw87915mb6bpn1jn652gk949rdww5"))))
145 (build-system python-build-system)
146 ;; XXX The tests seem to require Proteus. But Proteus tests seem to
147 ;; require trytond-party.
148 (arguments
149 '(#:tests? #f))
150 (propagated-inputs
151 `(("python-trytond" ,python-trytond)
152 ("python-trytond-country" ,python-trytond-country)
153 ("python-stdnum" ,python-stdnum)
154 ("python-sql" ,python-sql)
155 ("python-wrapt" ,python-wrapt)
156 ("python-werkzeug" ,python-werkzeug)
157 ("python-polib" ,python-polib)
158 ("python-dateutil" ,python-dateutil)
159 ("python-genshi" ,python-genshi)
160 ("python-relatorio" ,python-relatorio)
161 ("python-magic" ,python-magic)
162 ("python-phonenumbers" ,python-phonenumbers)))
163 (home-page "http://www.tryton.org/")
164 (synopsis
165 "Tryton module for parties and addresses")
166 (description
167 "This package provides a Tryton module for (counter)parties and
168 addresses.")
169 (license license:gpl3+)))
170
171 (define-public python-proteus
172 (package
173 (name "python-proteus")
174 (version "4.6.0")
175 (source
176 (origin
177 (method url-fetch)
178 (uri (pypi-uri "proteus" version))
179 (sha256
180 (base32
181 "0flkf1vxbhz51b7bq31dn7q9mlkli3pmpbzfhsxfqpf6laghbkqg"))))
182 (build-system python-build-system)
183 (propagated-inputs
184 `(("python-dateutil" ,python-dateutil)
185 ("python-trytond-party" ,python-trytond-party)
186 ("python-trytond-country" ,python-trytond-country)
187 ("python-trytond" ,python-trytond)
188 ("python-stdnum" ,python-stdnum)
189 ("python-sql" ,python-sql)
190 ("python-wrapt" ,python-wrapt)
191 ("python-werkzeug" ,python-werkzeug)
192 ("python-polib" ,python-polib)
193 ("python-genshi" ,python-genshi)
194 ("python-relatorio" ,python-relatorio)
195 ("python-magic" ,python-magic)))
196 (home-page "http://www.tryton.org/")
197 (synopsis
198 "Library to access a Tryton server as a client")
199 (description
200 "This package provides a library to access Tryton server as a client.")
201 (license license:lgpl3+)))