gnu: sbcl-cl-cffi-gtk: Update to 20200417.
[jackhill/guix/guix.git] / gnu / packages / linphone.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;;
3 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
4 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages linphone)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages admin)
24 #:use-module (gnu packages audio)
25 #:use-module (gnu packages base)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages documentation)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages gl)
30 #:use-module (gnu packages glib)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages gnome-xyz)
33 #:use-module (gnu packages graphviz)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages linux)
37 #:use-module (gnu packages pulseaudio)
38 #:use-module (gnu packages python)
39 #:use-module (gnu packages python-xyz)
40 #:use-module (gnu packages java)
41 #:use-module (gnu packages sqlite)
42 #:use-module (gnu packages telephony)
43 #:use-module (gnu packages tls)
44 #:use-module (gnu packages video)
45 #:use-module (gnu packages xiph)
46 #:use-module (gnu packages xml)
47 #:use-module (gnu packages xorg)
48 #:use-module ((guix licenses) #:prefix license:)
49 #:use-module (guix packages)
50 #:use-module (guix download)
51 #:use-module (guix build-system cmake)
52 #:use-module (guix build-system glib-or-gtk)
53 #:use-module (guix build-system gnu))
54
55 (define-public bcunit
56 (package
57 (name "bcunit")
58 (version "3.0.2")
59 (source
60 (origin
61 (method url-fetch)
62 (uri
63 (string-append "https://www.linphone.org/releases/sources/" name
64 "/" name "-" version ".tar.gz"))
65 (sha256
66 (base32 "0ylchj8w98ic2fkqpxc6yk4s6s0h0ql2zsz5n49jd7126m4h8dqk"))))
67 (build-system cmake-build-system)
68 (arguments
69 '(#:tests? #f ; No test target
70 #:configure-flags
71 (list
72 "-DENABLE_STATIC=NO"))) ; Not required
73 (synopsis "Belledonne Communications Unit Testing Framework")
74 (description "BCUnit is a fork of the defunct project CUnit,
75 with several fixes and patches applied. It is an unit testing
76 framework for writing, administering, and running unit tests in C.")
77 (home-page "https://gitlab.linphone.org/BC/public/bcunit")
78 (license license:lgpl2.0+)))
79
80 (define-public bctoolbox
81 (package
82 (name "bctoolbox")
83 (version "0.6.0")
84 (source
85 (origin
86 (method url-fetch)
87 (uri
88 (string-append "https://www.linphone.org/releases/sources/" name
89 "/" name "-" version ".tar.gz"))
90 (sha256
91 (base32 "1a1i70pb4hhnykkwyhhc7fv67q556l8kprny8xzgfqpj1nby2ms6"))))
92 (build-system cmake-build-system)
93 (arguments
94 '(#:tests? #f ; No test target
95 #:configure-flags
96 (list
97 "-DENABLE_STATIC=OFF"))) ; Not required
98 (inputs
99 `(("bcunit" ,bcunit)
100 ("mbedtls" ,mbedtls-apache)))
101 (synopsis "Belledonne Communications Tool Box")
102 (description "BcToolBox is an utilities library used by Belledonne
103 Communications software like belle-sip, mediastreamer2 and linphone.")
104 (home-page "https://gitlab.linphone.org/BC/public/bctoolbox")
105 (license license:gpl2+)))
106
107 (define-public belr
108 (package
109 (name "belr")
110 (version "0.1.3")
111 (source
112 (origin
113 (method url-fetch)
114 (uri
115 (string-append "https://www.linphone.org/releases/sources/" name
116 "/" name "-" version ".tar.gz"))
117 (sha256
118 (base32 "1fwv2cg3qy9vdc7dimcda7nqcqc1h2cdd7ikhk7ng7q4ys8m96c1"))))
119 (build-system cmake-build-system)
120 (arguments
121 `(#:tests? #f ; No test target
122 #:configure-flags
123 (list
124 "-DENABLE_STATIC=OFF"))) ; Not required
125 (inputs
126 `(("bctoolbox" ,bctoolbox)))
127 (synopsis "Belledonne Communications Language Recognition Library")
128 (description "Belr is Belledonne Communications' language recognition library,
129 written in C++11. It parses text inputs formatted according to a language
130 defined by an ABNF grammar, such as the protocols standardized at IETF.")
131 (home-page "https://gitlab.linphone.org/BC/public/belr")
132 (license license:gpl3+)))
133
134 (define-public belcard
135 (package
136 (name "belcard")
137 (version "1.0.2")
138 (source
139 (origin
140 (method url-fetch)
141 (uri
142 (string-append "https://www.linphone.org/releases/sources/" name
143 "/" name "-" version ".tar.gz"))
144 (sha256
145 (base32 "0iiyrll1shnbb0561pkvdqcmx9b2cdr76xpsbaqdirc3s4xzcl0k"))))
146 (build-system cmake-build-system)
147 (arguments
148 `(#:tests? #f ; No test target
149 #:configure-flags
150 (list
151 "-DENABLE_STATIC=OFF"))) ; Not required
152 (inputs
153 `(("bctoolbox" ,bctoolbox)
154 ("belr" ,belr)))
155 (synopsis "Belledonne Communications VCard Library")
156 (description "Belcard is a C++ library to manipulate VCard standard format.")
157 (home-page "https://gitlab.linphone.org/BC/public/belcard")
158 (license license:gpl3+)))
159
160 (define-public bcmatroska2
161 (package
162 (name "bcmatroska2")
163 (version "0.23")
164 (source
165 (origin
166 (method url-fetch)
167 (uri
168 (string-append "https://www.linphone.org/releases/sources/" name
169 "/" name "-" version ".tar.gz"))
170 (sha256
171 (base32 "1a0vlk4fhh189pfzrwbc3xbc5vyx6cnxy642d1h40045jz9y4h15"))))
172 (build-system cmake-build-system)
173 (arguments
174 `(#:tests? #f ; No test target
175 #:configure-flags
176 (list
177 "-DENABLE_STATIC=NO"))) ; Not required
178 (synopsis "Belledonne Communications Media Container")
179 (description "BcMatroska is a free and open standard multi-media
180 container format. It can hold an unlimited number of video, audio,
181 picture, or subtitle tracks in one file. ")
182 (home-page "https://gitlab.linphone.org/BC/public/bcmatroska2")
183 (license
184 (list
185 ;; That license applies for Core C and LibEBML2.
186 ;; https://www.matroska.org/node/47
187 license:bsd-4
188 ;; That license applies for LibMatroska2.
189 ;; https://www.matroska.org/node/47
190 license:lgpl2.1+))))
191
192 (define-public bcg729
193 (package
194 (name "bcg729")
195 (version "1.0.4")
196 (source
197 (origin
198 (method url-fetch)
199 (uri
200 (string-append "https://www.linphone.org/releases/sources/" name
201 "/" name "-" version ".tar.gz"))
202 (sha256
203 (base32 "01y34ky7ykjgfnf8a9f59hg61fqfjiprfrzshdz06w0lz4gvy3qs"))))
204 (build-system cmake-build-system)
205 (arguments
206 `(#:tests? #f ; No test target
207 #:configure-flags
208 (list
209 "-DENABLE_STATIC=NO"))) ; Not required
210 (synopsis "Belledonne Communications G729 Codec")
211 (description "BcG729 is an implementation of both encoder and decoder of
212 the ITU G729 speech codec. The library written in C 99 is fully portable and
213 can be executed on many platforms including both ARM and x86 processors. It
214 supports concurrent channels encoding and decoding for multi call application
215 such as conferencing.")
216 (home-page "https://gitlab.linphone.org/BC/public/belcard")
217 (license license:gpl2+)))
218
219 (define-public ortp
220 (package
221 (name "ortp")
222 (version "1.0.2")
223 (source
224 (origin
225 (method url-fetch)
226 (uri
227 (string-append "https://www.linphone.org/releases/sources/" name
228 "/" name "-" version ".tar.gz"))
229 (sha256
230 (base32 "016qg0lmdgmqh2kv19w9qhi4kkiyi5h1xp35g2s65b1j8ccm25d5"))))
231 (build-system cmake-build-system)
232 (arguments
233 `(#:tests? #f ; No test target
234 #:configure-flags
235 (list
236 "-DENABLE_STATIC=NO"))) ; Not required
237 (native-inputs
238 `(("dot" ,graphviz)
239 ("doxygen" ,doxygen)))
240 (inputs
241 `(("bctoolbox" ,bctoolbox)))
242 (synopsis "Belledonne Communications RTP Library")
243 (description "oRTP is a C library implementing the RTP protocol. It
244 implements the RFC 3550 standard.")
245 (home-page "https://gitlab.linphone.org/BC/public/ortp")
246 (license license:gpl2+)))
247
248 (define-public bzrtp
249 (package
250 (name "bzrtp")
251 (version "1.0.6")
252 (source
253 (origin
254 (method url-fetch)
255 (uri
256 (string-append "https://www.linphone.org/releases/sources/" name
257 "/" name "-" version ".tar.gz"))
258 (sha256
259 (base32 "12y0kkh90pixaaxfyx26ca2brhy6nw57fsypp6vh8jk1illv0j5z"))))
260 (build-system cmake-build-system)
261 (arguments
262 `(#:tests? #f ; No test target
263 #:configure-flags
264 (list
265 "-DENABLE_STATIC=NO")))
266 (inputs
267 `(("bctoolbox" ,bctoolbox)
268 ("sqlite3" ,sqlite)
269 ("xml2" ,libxml2)))
270 (synopsis "Belledonne Communications ZRTP Library")
271 (description "BZRTP is an implementation of ZRTP keys exchange
272 protocol, written in C. It is fully portable and can be executed on many
273 platforms including both ARM and x86.")
274 (home-page "https://gitlab.linphone.org/BC/public/bzrtp")
275 (license license:gpl2+)))
276
277 (define-public belle-sip
278 (package
279 (name "belle-sip")
280 (version "1.6.3")
281 (source
282 (origin
283 (method url-fetch)
284 (uri
285 (string-append "https://www.linphone.org/releases/sources/" name
286 "/" name "-" version ".tar.gz"))
287 (sha256
288 (base32 "0s55kggmgxap54dkw5856bgk4xg7yvbzialpxnjm0zhpic3hff1z"))))
289 (build-system cmake-build-system)
290 (arguments
291 `(#:tests? #f ; Requires network access
292 #:configure-flags
293 (list
294 "-DENABLE_STATIC=NO")
295 #:phases
296 (modify-phases %standard-phases
297 (add-after 'unpack 'patch
298 (lambda _
299 (substitute* "src/CMakeLists.txt"
300 ;; ANTLR would use multithreaded DFA generation
301 ;; otherwise--which would not be reproducible.
302 (("-Xmultithreaded ") ""))
303 #t)))))
304 (inputs
305 `(("antlr3" ,antlr3-3.3)
306 ("antlr3c" ,libantlr3c)
307 ("bctoolbox" ,bctoolbox)
308 ("java" ,icedtea)
309 ("zlib" ,zlib)))
310 (synopsis "Belledonne Communications SIP Library")
311 (description "Belle-sip is a modern library implementing SIP transport,
312 transaction and dialog layers. It is written in C, with an object-oriented
313 API. It also comprises a simple HTTP/HTTPS client implementation.")
314 (home-page "https://gitlab.linphone.org/BC/public/belle-sip")
315 (license license:gpl2+)))
316
317 (define-public mediastreamer2
318 (package
319 (name "mediastreamer2")
320 (version "2.16.1")
321 (source
322 (origin
323 (method url-fetch)
324 (uri
325 (string-append "https://www.linphone.org/releases/sources/"
326 "mediastreamer/mediastreamer-" version ".tar.gz"))
327 (sha256
328 (base32 "0whpqr69wz0pnzvragkpfblxhd0rds8k06c3mw5a0ag216a1yd9k"))
329 (patches (search-patches "mediastreamer2-srtp2.patch"))))
330 (outputs '("out" "doc" "tester"))
331 (build-system cmake-build-system)
332 (arguments
333 `(#:tests? #f ; No test target
334 #:configure-flags
335 (list
336 "-DENABLE_STATIC=NO" ; Not required
337 "-DENABLE_STRICT=NO" ; Would otherwise treat warnings as err
338 "-DENABLE_BV16=NO" ; Not available
339 "-DCMAKE_C_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\""
340 "-DCMAKE_CXX_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\"")
341 #:phases
342 (modify-phases %standard-phases
343 (add-after 'install 'separate-outputs
344 (lambda* (#:key outputs #:allow-other-keys)
345 (let* ((out (assoc-ref outputs "out"))
346 (doc (assoc-ref outputs "doc"))
347 (tester (assoc-ref outputs "tester"))
348 (tester-name (string-append ,name "_tester")))
349 ;; Copy the tester executable.
350 (mkdir-p (string-append tester "/bin"))
351 (rename-file (string-append out "/bin/" tester-name)
352 (string-append tester "/bin/" tester-name))
353 ;; Copy the tester data files.
354 (copy-recursively (string-append out "/share/" tester-name)
355 (string-append tester "/share/" tester-name))
356 (delete-file-recursively (string-append out "/share/"
357 tester-name))
358 ;; Copy the HTML documentation.
359 (copy-recursively (string-append out "/share/doc/"
360 ,name "-" ,version "/html")
361 (string-append doc "/share/doc/"
362 ,name "-" ,version "/html"))
363 (delete-file-recursively (string-append out "/share/doc/"
364 ,name "-" ,version
365 "/html"))
366 #t))))))
367 (native-inputs
368 `(("dot" ,graphviz)
369 ("doxygen" ,doxygen)
370 ("python" ,python)))
371 (inputs
372 `(("alsa" ,alsa-lib)
373 ("bcg729" ,bcg729)
374 ("bcmatroska2" ,bcmatroska2)
375 ("bctoolbox" ,bctoolbox)
376 ("ffmpeg" ,ffmpeg)
377 ("glew" ,glew)
378 ("glu" ,glu)
379 ("glx" ,mesa-utils)
380 ("gsm" ,gsm)
381 ("opengl" ,mesa)
382 ("opus" ,opus)
383 ("ortp" ,ortp)
384 ("pcap" ,libpcap)
385 ("portaudio" ,portaudio)
386 ("pulseaudio" ,pulseaudio)
387 ("spandsp" ,spandsp)
388 ("speex" ,speex)
389 ("speexdsp" ,speexdsp)
390 ("srtp" ,libsrtp)
391 ("theora" ,libtheora)
392 ("turbojpeg" ,libjpeg-turbo)
393 ("v4l" ,v4l-utils)
394 ("vpx" ,libvpx)
395 ("x11" ,libx11)
396 ("xv" ,libxv)
397 ("zrtp", bzrtp)))
398 (synopsis "Belledonne Communications Streaming Engine")
399 (description "Mediastreamer2 is a powerful and lightweight
400 streaming engine for telephony applications. This media processing
401 and streaming toolkit is responsible for receiving and sending all
402 multimedia streams in Linphone, including media capture, encoding and
403 decoding, and rendering.")
404 (home-page "https://gitlab.linphone.org/BC/public/mediastreamer2")
405 (license license:gpl2+)))
406
407 (define-public liblinphone
408 (package
409 (name "liblinphone")
410 (version "3.12.0")
411 (source
412 (origin
413 (method url-fetch)
414 (uri
415 (string-append "https://www.linphone.org/releases/sources/linphone"
416 "/linphone-" version ".tar.gz"))
417 (sha256
418 (base32 "0phhkx55xdyg28d4wn8l8q4yvsmdgzmjiw584d4s190sq1azm91x"))))
419 (outputs '("out" "doc" "tester"))
420 (build-system cmake-build-system)
421 (arguments
422 `(#:tests? #f ; No test target
423 #:configure-flags
424 (list
425 (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
426 (string-append (assoc-ref %build-inputs "gtk2")
427 "/lib/gtk-2.0/include"))
428 (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
429 (string-append (assoc-ref %build-inputs "glib")
430 "/lib/glib-2.0/include"))
431 "-DENABLE_STATIC=NO" ; Not required
432 "-DENABLE_GTK_UI=YES") ; For Legacy UI
433 #:imported-modules (,@%cmake-build-system-modules
434 (guix build glib-or-gtk-build-system))
435 #:modules ((guix build cmake-build-system)
436 ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
437 (guix build utils))
438 #:phases
439 (modify-phases %standard-phases
440 (add-after 'unpack 'patch
441 (lambda _
442 (substitute* "gtk/main.c"
443 (("#include \"liblinphone_gitversion.h\"")
444 ""))
445 #t))
446 (add-after 'install 'separate-outputs
447 (lambda* (#:key outputs #:allow-other-keys)
448 (let* ((out (assoc-ref outputs "out"))
449 (doc (assoc-ref outputs "doc"))
450 (tester (assoc-ref outputs "tester"))
451 (tester-name (string-append ,name "_tester")))
452 ;; Copy the tester executable.
453 (mkdir-p (string-append tester "/bin"))
454 (rename-file (string-append out "/bin/" tester-name)
455 (string-append tester "/bin/" tester-name))
456 ;; Copy the tester data files.
457 (mkdir-p (string-append tester "/share/"))
458 (rename-file (string-append out "/share/" tester-name)
459 (string-append tester "/share/" tester-name))
460 ;; Copy the HTML and XML documentation.
461 (copy-recursively
462 (string-append out "/share/doc/linphone-" ,version)
463 (string-append doc "/share/doc/" ,name "-" ,version))
464 (delete-file-recursively
465 (string-append out "/share/doc/linphone-" ,version))
466 #t)))
467 (add-after 'separate-outputs 'glib-or-gtk-compile-schemas
468 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
469 (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
470 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
471 (native-inputs
472 `(("gettext" ,gettext-minimal)
473 ("udev" ,eudev) ;for libudev.h
474 ;; For generating the C++ wrappers.
475 ("dot" ,graphviz)
476 ("doxygen" ,doxygen)
477 ("python" ,python)
478 ("pystache" ,python-pystache)
479 ("six" ,python-six)))
480 (inputs
481 `(("bctoolbox" ,bctoolbox)
482 ("belcard" ,belcard)
483 ("bellesip" ,belle-sip)
484 ("bzrtp", bzrtp)
485 ("iconv" ,libiconv)
486 ("glib" ,glib)
487 ("gtk2" ,gtk+-2)
488 ("mediastreamer2" ,mediastreamer2)
489 ("notify" ,libnotify)
490 ("ortp" ,ortp)
491 ("sqlite" ,sqlite)
492 ("xml2" ,libxml2)
493 ("zlib" ,zlib)))
494 (synopsis "Belledonne Communications Softphone Library")
495 (description "Liblinphone is a high-level SIP library integrating
496 all calling and instant messaging features into an unified
497 easy-to-use API. It is the cross-platform VoIP library on which the
498 Linphone application is based on, and that anyone can use to add audio
499 and video calls or instant messaging capabilities to an application.")
500 (home-page "https://gitlab.linphone.org/BC/public/liblinphone")
501 (license license:gpl2+)))
502
503 (define-public msopenh264
504 (package
505 (name "msopenh264")
506 (version "1.2.1")
507 (source
508 (origin
509 (method url-fetch)
510 (uri
511 (string-append "https://www.linphone.org/releases/sources/plugins/"
512 name "/" name "-" version ".tar.gz"))
513 (sha256
514 (base32 "0rdxgazm52560g52pp6mp3mwx6j1z3h2zyizzfycp8y8zi92fqm8"))
515 (patches
516 (list
517 ;; For support for OpenH264 version >= 2.
518 (origin
519 (method url-fetch)
520 (uri
521 (string-append "https://gitlab.linphone.org/BC/public/msopenh264/commit/"
522 "493d147d28c9a0f788ba4e50b47a1ce7b18bf326.diff"))
523 (file-name "msopenh264-openh264.patch")
524 (sha256
525 (base32 "0mmd7nz5n9ian4rcwn200nldmy5j0dpdrna7r32rqnaw82bx3kdb")))))))
526 (build-system cmake-build-system)
527 (arguments
528 `(#:tests? #f ; No test target
529 #:configure-flags
530 (list
531 "-DENABLE_STATIC=NO"))) ; Not required
532 (inputs
533 `(("mediastreamer2" ,mediastreamer2)
534 ("openh264" ,openh264)
535 ("ortp" ,ortp)))
536 (synopsis "Media Streamer H.264 Codec")
537 (description "MsOpenH264 is an H.264 encoder/decoder plugin for
538 mediastreamer2 based on the openh264 library.")
539 (home-page "https://gitlab.linphone.org/BC/public/msopenh264")
540 (license license:gpl2+)))
541
542 (define-public mssilk
543 (package
544 (name "mssilk")
545 (version "1.1.1")
546 (source
547 (origin
548 (method url-fetch)
549 (uri
550 (string-append "https://www.linphone.org/releases/sources/plugins/"
551 name "/" name "-" version ".tar.gz"))
552 (sha256
553 (base32 "07ip0vd29d1n98lnqs5wpimcsmpm65yl7g5vk4hbqghcbsjw94lj"))))
554 (build-system cmake-build-system)
555 (arguments
556 `(#:tests? #f ; No test target
557 #:configure-flags
558 (list
559 "-DENABLE_STATIC=NO"))) ; Not required
560 (inputs
561 `(("mediastreamer2" ,mediastreamer2)
562 ("ortp" ,ortp)))
563 (synopsis "Media Streamer SILK Codec")
564 (description "MSSILK is a plugin of MediaStreamer, adding support for
565 AMR codec. It is based on the Skype's SILK implementation.")
566 (home-page "https://gitlab.linphone.org/BC/public/mssilk")
567 (license license:gpl2+)))
568
569 (define-public mswebrtc
570 (package
571 (name "mswebrtc")
572 (version "1.1.1")
573 (source
574 (origin
575 (method url-fetch)
576 (uri
577 (string-append "https://www.linphone.org/releases/sources/plugins/"
578 name "/" name "-" version ".tar.gz"))
579 (sha256
580 (base32 "1wj28hl9myhshqmn64xg0jf07aw75gmnilb5rff6rcbdxim87mqr"))))
581 (build-system cmake-build-system)
582 (arguments
583 `(#:tests? #f ; No test target
584 #:configure-flags
585 (list
586 "-DENABLE_STATIC=NO")))
587 (inputs
588 `(("bctoolbox" ,bctoolbox)
589 ("mediastreamer2" ,mediastreamer2)
590 ("ortp" ,ortp)))
591 (synopsis "Media Streamer WebRTC Codec")
592 (description "MSWebRTC is a plugin of MediaStreamer, adding support for
593 WebRTC codec. It includes features from WebRTC, such as, iSAC and AECM.")
594 (home-page "https://gitlab.linphone.org/BC/public/mswebrtc")
595 (license license:gpl2+)))
596
597 (define-public msamr
598 (package
599 (name "msamr")
600 (version "1.1.3")
601 (source
602 (origin
603 (method url-fetch)
604 (uri
605 (string-append "https://www.linphone.org/releases/sources/plugins/"
606 name "/" name "-" version ".tar.gz"))
607 (sha256
608 (base32 "16c9f3z4wnj73k7y8gb0fgpr4axsm7b5zrbjvy8vsgz9gyg3agm5"))))
609 (build-system cmake-build-system)
610 (arguments
611 `(#:tests? #f ; No test target
612 #:configure-flags
613 (list
614 "-DENABLE_STATIC=NO" ; Not required
615 "-DENABLE_WIDEBAND=YES")))
616 (inputs
617 `(("mediastreamer2" ,mediastreamer2)
618 ("opencoreamr" ,opencore-amr)
619 ("ortp" ,ortp)
620 ("voamrwbenc" ,vo-amrwbenc)))
621 (synopsis "Media Streamer AMR Codec")
622 (description "MSAMR is a plugin of MediaStreamer, adding support for
623 AMR codec. It is based on the opencore-amr implementation.")
624 (home-page "https://gitlab.linphone.org/BC/public/msamr")
625 (license license:gpl3+)))