gnu: sbcl-cl-cffi-gtk: Update to 20200417.
[jackhill/guix/guix.git] / gnu / packages / gnome-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
4 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
5 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
6 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
7 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
8 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages gnome-xyz)
26 #:use-module (guix build-system trivial)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system copy)
29 #:use-module (guix build-system meson)
30 #:use-module (guix git-download)
31 #:use-module (guix packages)
32 #:use-module ((guix licenses) #:prefix license:)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages bash)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages glib)
37 #:use-module (gnu packages gnome)
38 #:use-module (gnu packages gtk)
39 #:use-module (gnu packages pkg-config)
40 #:use-module (gnu packages python-xyz)
41 #:use-module (gnu packages ssh)
42 #:use-module (gnu packages tls)
43 #:use-module (gnu packages ruby)
44 #:use-module (gnu packages xml))
45
46 (define-public matcha-theme
47 (package
48 (name "matcha-theme")
49 (version "2019-11-02")
50 (source
51 (origin
52 (method git-fetch)
53 (uri
54 (git-reference
55 (url "https://github.com/vinceliuice/matcha")
56 (commit version)))
57 (file-name (git-file-name name version))
58 (sha256
59 (base32
60 "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
61 (build-system trivial-build-system)
62 (arguments
63 '(#:modules ((guix build utils))
64 #:builder
65 (begin
66 (use-modules (guix build utils))
67 (let* ((out (assoc-ref %outputs "out"))
68 (source (assoc-ref %build-inputs "source"))
69 (bash (assoc-ref %build-inputs "bash"))
70 (coreutils (assoc-ref %build-inputs "coreutils"))
71 (themesdir (string-append out "/share/themes")))
72 (setenv "PATH"
73 (string-append coreutils "/bin:"
74 (string-append bash "/bin:")))
75 (copy-recursively source (getcwd))
76 (patch-shebang "Install")
77 (mkdir-p themesdir)
78 (invoke "./Install" "-d" themesdir)
79 #t))))
80 (inputs
81 `(("gtk-engines" ,gtk-engines)))
82 (native-inputs
83 `(("bash" ,bash)
84 ("coreutils" ,coreutils)))
85 (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
86 (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
87 Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
88 like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
89 (home-page "https://github.com/vinceliuice/matcha")
90 (license license:gpl3+)))
91
92 (define-public delft-icon-theme
93 (package
94 (name "delft-icon-theme")
95 (version "1.11")
96 (source
97 (origin
98 (method git-fetch)
99 (uri (git-reference
100 (url "https://github.com/madmaxms/iconpack-delft.git")
101 (commit (string-append "v" version))))
102 (sha256
103 (base32
104 "1m3r4i4m3y3xsjb5f4bik0ylmi64amkfyr0y8pjbvv6gyj492mi6"))
105 (file-name (git-file-name name version))))
106 (build-system copy-build-system)
107 (arguments
108 `(#:install-plan
109 `(("." "share/icons" #:exclude ("README.md" "LICENSE" "logo.jpg")))
110 #:phases
111 (modify-phases %standard-phases
112 (add-after 'unpack 'patch-index.theme
113 (lambda _
114 (substitute* "Delft/index.theme"
115 (("gnome") "Adwaita"))
116 #t)))))
117 (home-page "https://www.gnome-look.org/p/1199881/")
118 (synopsis "Continuation of Faenza icon theme with up to date app icons")
119 (description "Delft is a fork of the popular icon theme Faenza with up to
120 date app icons. It will stay optically close to the original Faenza icons,
121 which haven't been updated for some years. The new app icons are ported from
122 the Obsidian icon theme.")
123 (license license:gpl3)))
124
125 (define-public gnome-shell-extension-appindicator
126 (package
127 (name "gnome-shell-extension-appindicator")
128 (version "33")
129 (source (origin
130 (method git-fetch)
131 (uri (git-reference
132 (url
133 "https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
134 (commit (string-append "v" version))))
135 (sha256
136 (base32
137 "0qm77s080nbf4gqnfzpwp8a7jf7lliz6fxbsd3lasvrr11pgsk87"))
138 (file-name (git-file-name name version))))
139 (build-system copy-build-system)
140 (arguments
141 `(#:install-plan
142 '(("." ,(string-append "share/gnome-shell/extensions/"
143 "appindicatorsupport@rgcjonas.gmail.com")))))
144 (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
145 (description "This extension integrates Ubuntu AppIndicators
146 and KStatusNotifierItems (KDE's successor of the systray) into
147 GNOME Shell.")
148 (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
149 (license license:gpl2+)))
150
151 (define-public gnome-shell-extension-topicons-redux
152 (package
153 (name "gnome-shell-extension-topicons-redux")
154 (version "6")
155 (source
156 (origin
157 (method git-fetch)
158 (uri (git-reference
159 (url "https://gitlab.com/pop-planet/TopIcons-Redux.git")
160 (commit version)))
161 (file-name (git-file-name name version))
162 (sha256
163 (base32 "1dli9xb545n3xlj6q4wl0y5gzkm903zs47p8fiq71pdvbr6v38rj"))))
164 (build-system gnu-build-system)
165 (native-inputs
166 `(("glib" ,glib "bin")))
167 (arguments
168 `(#:tests? #f ;no test defined in the project
169 #:phases
170 (modify-phases %standard-phases
171 (delete 'configure)
172 (delete 'build)
173 (replace 'install
174 (lambda* (#:key outputs #:allow-other-keys)
175 (let ((out (assoc-ref outputs "out")))
176 (invoke "make"
177 "install"
178 (string-append
179 "INSTALL_PATH="
180 out
181 "/share/gnome-shell/extensions"))))))))
182 (home-page "https://gitlab.com/pop-planet/TopIcons-Redux")
183 (synopsis "Display legacy tray icons in the GNOME Shell top panel")
184 (description "Many applications, such as chat clients, downloaders, and
185 some media players, are meant to run long-term in the background even after you
186 close their window. These applications remain accessible by adding an icon to
187 the GNOME Shell Legacy Tray. However, the Legacy Tray was removed in GNOME
188 3.26. TopIcons Redux brings those icons back into the top panel so that it's
189 easier to keep track of apps running in the backround.")
190 (license license:gpl2+)))
191
192 (define-public gnome-shell-extension-dash-to-dock
193 (package
194 (name "gnome-shell-extension-dash-to-dock")
195 (version "66")
196 (source (origin
197 (method git-fetch)
198 (uri (git-reference
199 (url "https://github.com/micheleg/dash-to-dock.git")
200 (commit (string-append "extensions.gnome.org-v"
201 version))))
202 (sha256
203 (base32
204 "04krl6rxlp1qc97psraf2kwin7h0mx4c7pnfpi7vhplmvasrwkfh"))
205 (file-name (git-file-name name version))))
206 (build-system gnu-build-system)
207 (arguments
208 '(#:tests? #f
209 #:make-flags (list (string-append "INSTALLBASE="
210 (assoc-ref %outputs "out")
211 "/share/gnome-shell/extensions"))
212 #:phases
213 (modify-phases %standard-phases
214 (delete 'bootstrap)
215 (delete 'configure))))
216 (native-inputs
217 `(("glib:bin" ,glib "bin")
218 ("intltool" ,intltool)
219 ("pkg-config" ,pkg-config)))
220 (propagated-inputs
221 `(("glib" ,glib)))
222 (synopsis "Transforms GNOME's dash into a dock")
223 (description "This extension moves the dash out of the
224 overview, transforming it into a dock for easier application launching and
225 faster window switching.")
226 (home-page "https://micheleg.github.io/dash-to-dock/")
227 (license license:gpl2+)))
228
229 (define-public gnome-shell-extension-gsconnect
230 (package
231 (name "gnome-shell-extension-gsconnect")
232 ;; v28 is the last version to support GNOME 3.32
233 (version "28")
234 (source (origin
235 (method git-fetch)
236 (uri (git-reference
237 (url (string-append "https://github.com/andyholmes"
238 "/gnome-shell-extension-gsconnect.git"))
239 (commit (string-append "v" version))))
240 (file-name (git-file-name name version))
241 (sha256
242 (base32
243 "0grqkzqm7mlkbzin4nx9w7bh5cgygph8pn0cvim4a4gg99nfcp5z"))))
244 (build-system meson-build-system)
245 (arguments
246 `(#:configure-flags
247 (let* ((out (assoc-ref %outputs "out"))
248 (name+version (strip-store-file-name out))
249 (gschema-dir (string-append out
250 "/share/gsettings-schemas/"
251 name+version
252 "/glib-2.0/schemas"))
253 (gnome-shell (assoc-ref %build-inputs "gnome-shell"))
254 (openssh (assoc-ref %build-inputs "openssh"))
255 (openssl (assoc-ref %build-inputs "openssl")))
256 (list
257 (string-append "-Dgnome_shell_libdir=" gnome-shell "/lib")
258 (string-append "-Dgsettings_schemadir=" gschema-dir)
259 (string-append "-Dopenssl_path=" openssl "/bin/openssl")
260 (string-append "-Dsshadd_path=" openssh "/bin/ssh-add")
261 (string-append "-Dsshkeygen_path=" openssh "/bin/ssh-keygen")
262 (string-append "-Dsession_bus_services_dir=" out "/share/dbus-1/services")
263 "-Dpost_install=true"))
264 #:phases
265 (modify-phases %standard-phases
266 (add-before 'configure 'fix-paths
267 (lambda* (#:key inputs #:allow-other-keys)
268 (let* ((glib (assoc-ref inputs "glib:bin"))
269 (gapplication (string-append glib "/bin/gapplication"))
270 (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
271 (substitute* "data/org.gnome.Shell.Extensions.GSConnect.desktop"
272 (("gapplication") gapplication))
273 (for-each
274 (lambda (file)
275 (substitute* file
276 (("'use strict';")
277 (string-append "'use strict';\n\n"
278 "'" gi-typelib-path "'.split(':').forEach("
279 "path => imports.gi.GIRepository.Repository."
280 "prepend_search_path(path));"))))
281 '("src/extension.js" "src/prefs.js"))
282 #t)))
283 (add-after 'install 'wrap-daemons
284 (lambda* (#:key inputs outputs #:allow-other-keys)
285 (let* ((out (assoc-ref outputs "out"))
286 (service-dir
287 (string-append out "/share/gnome-shell/extensions"
288 "/gsconnect@andyholmes.github.io/service"))
289 (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
290 (wrap-program (string-append service-dir "/daemon.js")
291 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
292 #t))))))
293 (inputs
294 `(("at-spi2-core" ,at-spi2-core)
295 ("caribou" ,caribou)
296 ("evolution-data-server" ,evolution-data-server)
297 ("folks" ,folks)
298 ("gjs" ,gjs)
299 ("glib" ,glib)
300 ("glib:bin" ,glib "bin")
301 ("gsound" ,gsound)
302 ("gnome-shell" ,gnome-shell)
303 ("gtk+" ,gtk+)
304 ("nautilus" ,nautilus)
305 ("openssh" ,openssh)
306 ("openssl" ,openssl)
307 ("python-nautilus" ,python-nautilus)
308 ("python-pygobject" ,python-pygobject)
309 ("upower" ,upower)))
310 (native-inputs
311 `(("gettext" ,gettext-minimal)
312 ("gobject-introspection" ,gobject-introspection)
313 ("libxml2" ,libxml2)
314 ("pkg-config" ,pkg-config)))
315 (home-page "https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki")
316 (synopsis "Connect GNOME Shell with your Android phone")
317 (description "GSConnect is a complete implementation of KDE Connect
318 especially for GNOME Shell, allowing devices to securely share content, like
319 notifications or files, and other features like SMS messaging and remote
320 control.")
321 (license license:gpl2)))
322
323 (define-public gnome-shell-extension-hide-app-icon
324 (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
325 (revision "0"))
326 (package
327 (name "gnome-shell-extension-hide-app-icon")
328 (version (git-version "2.7" revision commit))
329 (source
330 (origin
331 (method git-fetch)
332 (uri (git-reference
333 (url (string-append "https://github.com/michael-rapp"
334 "/gnome-shell-extension-hide-app-icon.git"))
335 (commit commit)))
336 (sha256
337 (base32
338 "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
339 (file-name (git-file-name name version))))
340 (build-system gnu-build-system)
341 (arguments
342 '(#:tests? #f ; no test target
343 #:make-flags (list (string-append "EXTENSIONS_DIR="
344 (assoc-ref %outputs "out")
345 "/share/gnome-shell/extensions"))
346 #:phases
347 (modify-phases %standard-phases
348 (delete 'configure) ; no configure script
349 (replace 'install
350 (lambda* (#:key outputs #:allow-other-keys)
351 (let ((out (assoc-ref outputs "out"))
352 (pre "/share/gnome-shell/extensions/")
353 (dir "hide-app-icon@mrapp.sourceforge.com"))
354 (copy-recursively dir (string-append out pre dir))
355 #t))))))
356 (native-inputs
357 `(("glib" ,glib "bin")
358 ("intltool" ,intltool)))
359 (propagated-inputs
360 `(("glib" ,glib)))
361 (synopsis "Hide app icon from GNOME's panel")
362 (description "This extension hides the icon and/or title of the
363 currently focused application in the top panel of the GNOME shell.")
364 (home-page
365 "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
366 (license
367 ;; README.md and LICENSE.txt disagree -- the former claims v3, the
368 ;; latter v2. No mention of "or later" in either place or in the code.
369 (list license:gpl2
370 license:gpl3)))))
371
372 (define-public gnome-shell-extension-dash-to-panel
373 (package
374 (name "gnome-shell-extension-dash-to-panel")
375 (version "26")
376 (source (origin
377 (method git-fetch)
378 (uri (git-reference
379 (url "https://github.com/home-sweet-gnome/dash-to-panel.git")
380 (commit (string-append "v" version))))
381 (sha256
382 (base32
383 "1phfx2pblygpcvsppsqqqflm7qnz46mqkw29hj0nv2dn69hf4xbc"))
384 (file-name (git-file-name name version))))
385 (build-system gnu-build-system)
386 (arguments
387 `(#:tests? #f
388 #:make-flags (list (string-append "INSTALLBASE="
389 (assoc-ref %outputs "out")
390 "/share/gnome-shell/extensions")
391 (string-append "VERSION="
392 ,(package-version
393 gnome-shell-extension-dash-to-panel)))
394 #:phases
395 (modify-phases %standard-phases
396 (delete 'bootstrap)
397 (delete 'configure))))
398 (native-inputs
399 `(("intltool" ,intltool)
400 ("pkg-config" ,pkg-config)))
401 (propagated-inputs
402 `(("glib" ,glib)
403 ("glib" ,glib "bin")))
404 (synopsis "Icon taskbar for GNOME Shell")
405 (description "This extension moves the dash into the gnome main
406 panel so that the application launchers and system tray are combined
407 into a single panel, similar to that found in KDE Plasma and Windows 7+.")
408 (home-page "https://github.com/home-sweet-gnome/dash-to-panel/")
409 (license license:gpl2+)))
410
411 (define-public gnome-shell-extension-noannoyance
412 (package
413 (name "gnome-shell-extension-noannoyance")
414 (version "5")
415 (source (origin
416 (method git-fetch)
417 (uri (git-reference
418 (url "https://github.com/BjoernDaase/noannoyance.git")
419 (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
420 (sha256
421 (base32
422 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
423 (file-name (git-file-name name version))))
424 (build-system copy-build-system)
425 (arguments
426 '(#:install-plan
427 '(("." "share/gnome-shell/extensions/noannoyance@daase.net"))))
428 (synopsis "Remove 'Window is ready' annotation")
429 (description "One of the many extensions that remove this message.
430 It uses ES6 syntax and claims to be more actively maintained than others.")
431 (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
432 (license license:gpl2)))
433
434 (define-public gnome-shell-extension-paperwm
435 (package
436 (name "gnome-shell-extension-paperwm")
437 (version "36.0")
438 (source (origin
439 (method git-fetch)
440 (uri (git-reference
441 (url "https://github.com/paperwm/PaperWM.git")
442 (commit version)))
443 (file-name (git-file-name name version))
444 (sha256
445 (base32
446 "1ssnabwxrns36c61ppspjkr9i3qifv08pf2jpwl7cjv3pvyn4kly"))
447 (snippet
448 '(begin (delete-file "schemas/gschemas.compiled")))))
449 (build-system copy-build-system)
450 (arguments
451 '(#:install-plan
452 '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
453 #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
454 "\\.xml$" "\\.compiled$")))
455 #:phases
456 (modify-phases %standard-phases
457 (add-before 'install 'compile-schemas
458 (lambda _
459 (with-directory-excursion "schemas"
460 (invoke "make"))
461 #t)))))
462 (native-inputs
463 `(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
464 (home-page "https://github.com/paperwm/PaperWM")
465 (synopsis "Tiled scrollable window management for GNOME Shell")
466 (description "PaperWM is an experimental GNOME Shell extension providing
467 scrollable tiling of windows and per monitor workspaces. It's inspired by paper
468 notebooks and tiling window managers.")
469 (license license:gpl3)))
470
471 (define-public numix-gtk-theme
472 (package
473 (name "numix-gtk-theme")
474 (version "2.6.7")
475 (source (origin
476 (method git-fetch)
477 (uri (git-reference
478 (url "https://github.com/numixproject/numix-gtk-theme.git")
479 (commit version)))
480 (file-name (git-file-name name version))
481 (sha256
482 (base32
483 "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
484 (build-system gnu-build-system)
485 (arguments
486 '(#:make-flags
487 (list (string-append "INSTALL_DIR="
488 (assoc-ref %outputs "out")
489 "/share/themes/Numix"))
490 #:tests? #f
491 #:phases
492 (modify-phases %standard-phases
493 (delete 'configure)))) ; no configure script
494 (native-inputs
495 `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
496 ("gnome-shell" ,gnome-shell)
497 ("gtk+" ,gtk+)
498 ("xmllint" ,libxml2)
499 ("ruby-sass" ,ruby-sass)))
500 (synopsis "Flat theme with light and dark elements")
501 (description "Numix is a modern flat theme with a combination of light and
502 dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
503 (home-page "https://numixproject.github.io")
504 (license license:gpl3+)))
505
506 (define-public numix-theme
507 (deprecated-package "numix-theme" numix-gtk-theme))
508
509 (define-public papirus-icon-theme
510 (let ((version "0.0.0") ;; The package does not use semver
511 (revision "0")
512 (tag "20191201"))
513 (package
514 (name "papirus-icon-theme")
515 (version (git-version version revision tag))
516 (source
517 (origin
518 (method git-fetch)
519 (uri (git-reference
520 (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git")
521 (commit tag)))
522 (sha256
523 (base32
524 "0lnz1kmz28xh1f4slbsx7ycji5hgszyiyprbf5w5fbjhvi5gzw1h"))
525 (file-name (git-file-name name version))))
526 (build-system gnu-build-system)
527 (arguments
528 '(#:tests? #f
529 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
530 #:phases
531 (modify-phases %standard-phases
532 (delete 'bootstrap)
533 (delete 'configure)
534 (delete 'build))))
535 (native-inputs
536 `(("gtk+:bin" ,gtk+ "bin")))
537 (home-page "https://git.io/papirus-icon-theme")
538 (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
539 (description "Papirus is a fork of the icon theme Paper with a lot of new icons
540 and a few extra features.")
541 (license license:gpl3))))