gnu: sbcl-cl-cffi-gtk: Update to 20200417.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 ng0 <ng0@n0.is>
6 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages enlightenment)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix utils)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system meson)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages avahi)
35 #:use-module (gnu packages bash)
36 #:use-module (gnu packages check)
37 #:use-module (gnu packages code)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages fontutils)
41 #:use-module (gnu packages freedesktop)
42 #:use-module (gnu packages fribidi)
43 #:use-module (gnu packages game-development)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages ghostscript)
46 #:use-module (gnu packages gl)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages gstreamer)
50 #:use-module (gnu packages gtk)
51 #:use-module (gnu packages ibus)
52 #:use-module (gnu packages image)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages lua)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages python-xyz)
63 #:use-module (gnu packages tls)
64 #:use-module (gnu packages video)
65 #:use-module (gnu packages xdisorg)
66 #:use-module (gnu packages xorg)
67 #:use-module (ice-9 match))
68
69 (define-public efl
70 (package
71 (name "efl")
72 (version "1.24.0")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append
76 "https://download.enlightenment.org/rel/libs/efl/efl-"
77 version ".tar.xz"))
78 (sha256
79 (base32
80 "1yhck2g4rwlzgnzqa4wjxw3lf6k6rd730hz4bwzajdjy7i26xfdk"))))
81 (build-system meson-build-system)
82 (native-inputs
83 `(("check" ,check)
84 ("gettext" ,gettext-minimal)
85 ("pkg-config" ,pkg-config)))
86 (inputs
87 `(("curl" ,curl)
88 ("giflib" ,giflib)
89 ("gstreamer" ,gstreamer)
90 ("gst-plugins-base" ,gst-plugins-base)
91 ("ibus" ,ibus)
92 ("mesa" ,mesa)
93 ("libraw" ,libraw)
94 ("librsvg" ,librsvg)
95 ("libspectre" ,libspectre)
96 ("libtiff" ,libtiff)
97 ("libxau" ,libxau)
98 ("libxcomposite" ,libxcomposite)
99 ("libxcursor" ,libxcursor)
100 ("libxdamage" ,libxdamage)
101 ("libxdmcp" ,libxdmcp)
102 ("libxext" ,libxext)
103 ("libxi" ,libxi)
104 ("libxfixes" ,libxfixes)
105 ("libxinerama" ,libxinerama)
106 ("libxrandr" ,libxrandr)
107 ("libxrender" ,libxrender)
108 ("libxss" ,libxscrnsaver)
109 ("libxtst" ,libxtst)
110 ("libwebp" ,libwebp)
111 ("openjpeg" ,openjpeg)
112 ("poppler" ,poppler)
113 ("wayland-protocols" ,wayland-protocols)))
114 (propagated-inputs
115 ;; All these inputs are in package config files in section
116 ;; Requires.private.
117 `(("avahi" ,avahi)
118 ("dbus" ,dbus)
119 ("elogind" ,elogind)
120 ("eudev" ,eudev)
121 ("fontconfig" ,fontconfig)
122 ("freetype" ,freetype)
123 ("fribidi" ,fribidi)
124 ("glib" ,glib)
125 ("harfbuzz" ,harfbuzz)
126 ("libinput" ,libinput-minimal)
127 ("libjpeg" ,libjpeg)
128 ("libsndfile" ,libsndfile)
129 ("libpng" ,libpng)
130 ("libx11" ,libx11)
131 ("libxkbcommon" ,libxkbcommon)
132 ("luajit" ,luajit)
133 ("lz4" ,lz4)
134 ("openssl" ,openssl)
135 ("pulseaudio" ,pulseaudio)
136 ("util-linux" ,util-linux)
137 ("wayland" ,wayland)
138 ("zlib" ,zlib)))
139 (arguments
140 `(#:configure-flags '("-Dsystemd=false"
141 "-Delogind=true"
142 "-Dembedded-lz4=false"
143 "-Devas-loaders-disabler=json"
144 "-Dbuild-examples=false"
145 "-Decore-imf-loaders-disabler=scim"
146 "-Davahi=true"
147 "-Dglib=true"
148 "-Dmount-path=/run/setuid-programs/mount"
149 "-Dunmount-path=/run/setuid-programs/umount"
150 ;(string-append "-Ddictionaries-hyphen-dir="
151 ; (assoc-ref %build-inputs "hyphen")
152 ; "/share/hyphen")
153 "-Dnetwork-backend=connman"
154 ,@(match (%current-system)
155 ("armhf-linux"
156 '("-opengl=es-egl"))
157 (_
158 '("-Dopengl=full")))
159 ;; for wayland
160 "-Dwl-deprecated=true" ; ecore_wayland
161 "-Ddrm-deprecated=true" ; ecore_drm
162 "-Dwl=true"
163 "-Ddrm=true")
164 #:tests? #f ; Many tests fail due to timeouts and network requests.
165 #:phases
166 (modify-phases %standard-phases
167 ;; If we don't hardcode the location of libcurl.so then we
168 ;; have to wrap the outputs of efl's dependencies in curl.
169 (add-after 'unpack 'hardcode-libcurl-location
170 (lambda* (#:key inputs #:allow-other-keys)
171 (let* ((curl (assoc-ref inputs "curl"))
172 (lib (string-append curl "/lib/")))
173 (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
174 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
175 (string-append lib libcurl)))
176 #t)))
177 (add-after 'unpack 'fix-install-paths
178 (lambda _
179 (substitute* "dbus-services/meson.build"
180 (("install_dir.*")
181 "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
182 (substitute* "src/tests/elementary/meson.build"
183 (("dir_data") "meson.source_root(), 'test-output'"))
184 #t))
185 (add-after 'unpack 'set-home-directory
186 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
187 (lambda _ (setenv "HOME" "/tmp") #t)))))
188 (home-page "https://www.enlightenment.org/about-efl")
189 (synopsis "Enlightenment Foundation Libraries")
190 (description
191 "Enlightenment Foundation Libraries is a set of libraries developed
192 for Enlightenment. Libraries covers data serialization, wide support for
193 graphics rendering, UI layout and themes, interaction with OS, access to
194 removable devices or support for multimedia.")
195 ;; Different parts are under different licenses.
196 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
197
198 (define-public terminology
199 (package
200 (name "terminology")
201 (version "1.6.0")
202 (source (origin
203 (method url-fetch)
204 (uri
205 (string-append "https://download.enlightenment.org/rel/apps/"
206 "terminology/terminology-" version ".tar.xz"))
207 (sha256
208 (base32
209 "0xxx4xyhis6fy3frgb34ip0aj0kc4zashf60gzbxmq5gadbb0p5r"))
210 (modules '((guix build utils)))
211 ;; Remove the bundled fonts.
212 (snippet
213 '(begin
214 (delete-file-recursively "data/fonts")
215 (substitute* "data/meson.build"
216 (("subdir\\('fonts'\\)") ""))
217 #t))))
218 (build-system meson-build-system)
219 (arguments
220 `(#:configure-flags (list "-Dtests=true"
221 (string-append "-Dedje-cc="
222 (assoc-ref %build-inputs "efl")
223 "/bin/edje_cc"))
224 #:phases
225 (modify-phases %standard-phases
226 (add-after 'unpack 'set-home-directory
227 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
228 (lambda _ (setenv "HOME" "/tmp") #t))
229 (replace 'check
230 (lambda _
231 (with-directory-excursion
232 (string-append "../" ,name "-" ,version "/tests")
233 (invoke "sh" "run_tests.sh" "--verbose"
234 "-t" "../../build/src/bin/tytest"))))
235 (add-after 'install 'remove-test-binary
236 (lambda* (#:key outputs #:allow-other-keys)
237 ;; This file is not meant to be installed.
238 (delete-file (string-append (assoc-ref outputs "out")
239 "/bin/tytest"))
240 #t)))))
241 (native-inputs
242 `(("gettext" ,gettext-minimal)
243 ("perl" ,perl)
244 ("pkg-config" ,pkg-config)))
245 (inputs
246 `(("efl" ,efl)))
247 (home-page "https://www.enlightenment.org/about-terminology")
248 (synopsis "Powerful terminal emulator based on EFL")
249 (description
250 "Terminology is fast and feature rich terminal emulator. It is solely
251 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
252 URL and local path detection, themes, popup based content viewer for non-text
253 contents and more.")
254 (license license:bsd-2)))
255
256 (define-public rage
257 (package
258 (name "rage")
259 (version "0.3.1")
260 (source (origin
261 (method url-fetch)
262 (uri
263 (string-append
264 "https://download.enlightenment.org/rel/apps/rage/rage-"
265 version ".tar.xz"))
266 (sha256
267 (base32
268 "04fdk23bbgvni212zrfy4ndg7vmshbsjgicrhckdvhay87pk9i75"))))
269 (build-system meson-build-system)
270 (arguments
271 '(#:phases
272 (modify-phases %standard-phases
273 (add-after 'unpack 'set-home-directory
274 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
275 (lambda _ (setenv "HOME" "/tmp") #t)))))
276 (native-inputs
277 `(("pkg-config" ,pkg-config)))
278 (inputs
279 `(("efl" ,efl)))
280 (home-page "https://www.enlightenment.org/about-rage")
281 (synopsis "Video and audio player based on EFL")
282 (description
283 "Rage is a video and audio player written with Enlightenment Foundation
284 Libraries with some extra bells and whistles.")
285 (license license:bsd-2)))
286
287 (define-public enlightenment
288 (package
289 (name "enlightenment")
290 (version "0.23.1")
291 (source (origin
292 (method url-fetch)
293 (uri
294 (string-append "https://download.enlightenment.org/rel/apps/"
295 "enlightenment/enlightenment-" version ".tar.xz"))
296 (sha256
297 (base32
298 "0d1cyl07w9pvi2pf029kablazks2q9aislzl46b6fq5m1465jc75"))
299 (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
300 (build-system meson-build-system)
301 (arguments
302 `(#:configure-flags '("-Dsystemd=false")
303 #:phases
304 (modify-phases %standard-phases
305 (delete 'bootstrap) ; We don't want to run the autogen script.
306 (add-after 'unpack 'fix-dot-desktop-creation
307 (lambda _
308 (substitute* "data/session/meson.build"
309 (("HAVE_WAYLAND'.*") "HAVE_WAYLAND') == true\n"))
310 #t))
311 (add-before 'configure 'set-system-actions
312 (lambda* (#:key inputs #:allow-other-keys)
313 (setenv "HOME" "/tmp")
314 (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
315 (setxkbmap (assoc-ref inputs "setxkbmap"))
316 (utils (assoc-ref inputs "util-linux"))
317 (libc (assoc-ref inputs "libc"))
318 (bluez (assoc-ref inputs "bluez"))
319 (bc (assoc-ref inputs "bc"))
320 (efl (assoc-ref inputs "efl")))
321 ;; We need to patch the path to 'base.lst' to be able
322 ;; to switch the keyboard layout in E.
323 (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
324 "src/modules/wizard/page_011.c")
325 (("/usr/share/X11/xkb/rules/xorg.lst")
326 (string-append xkeyboard
327 "/share/X11/xkb/rules/base.lst")))
328 (substitute* "src/bin/e_xkb.c"
329 (("\"setxkbmap \"")
330 (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
331 (substitute* (list "src/bin/e_intl.c"
332 "src/modules/conf_intl/e_int_config_intl.c"
333 "src/modules/wizard/page_010.c")
334 (("locale -a") (string-append libc "/bin/locale -a")))
335 (substitute* "src/bin/e_import_config_dialog.c"
336 (("%s/edje_cc -v %s %s %s\", e_prefix_bin_get\\(\\)")
337 (string-append efl "/bin/edje_cc -v %s %s %s\"")))
338 (substitute* "src/modules/everything/evry_plug_apps.c"
339 (("/usr/bin/") ""))
340 (substitute* "src/modules/everything/evry_plug_calc.c"
341 (("bc -l") (string-append bc "/bin/bc -l")))
342 (substitute* "data/etc/meson.build"
343 (("/bin/mount") "/run/setuid-programs/mount")
344 (("/bin/umount") "/run/setuid-programs/umount")
345 (("/usr/bin/eject") (string-append utils "/bin/eject"))
346 (("/usr/bin/l2ping") (string-append bluez "/bin/l2ling"))
347 (("/bin/rfkill") (string-append utils "/sbin/rfkill"))
348 (("SUSPEND = ''") "SUSPEND = '/run/current-system/profile/bin/loginctl suspend'")
349 (("HIBERNATE = ''") "HIBERNATE = '/run/current-system/profile/bin/loginctl hibernate'")
350 (("/sbin/shutdown -h now") "/run/current-system/profile/bin/loginctl poweroff now")
351 (("/sbin/shutdown -r now") "/run/current-system/profile/bin/loginctl reboot now"))
352 #t))))))
353 (native-inputs
354 `(("gettext" ,gettext-minimal)
355 ("pkg-config" ,pkg-config)
356 ("util-linux" ,util-linux)))
357 (inputs
358 `(("alsa-lib" ,alsa-lib)
359 ("bc" ,bc)
360 ("bluez" ,bluez)
361 ("dbus" ,dbus)
362 ("efl" ,efl)
363 ("freetype" ,freetype)
364 ("libxcb" ,libxcb)
365 ("libxext" ,libxext)
366 ("linux-pam" ,linux-pam)
367 ("puleseaudio" ,pulseaudio)
368 ("setxkbmap" ,setxkbmap)
369 ("xcb-util-keysyms" ,xcb-util-keysyms)
370 ("xkeyboard-config" ,xkeyboard-config)))
371 (home-page "https://www.enlightenment.org/about-enlightenment")
372 (synopsis "Lightweight desktop environment")
373 (description
374 "Enlightenment is resource friendly desktop environment with integrated
375 file manager, wide range of configuration options, plugin system allowing to
376 unload unused functionality, with support for touchscreen and suitable for
377 embedded systems.")
378 (license license:bsd-2)))
379
380 (define-public enlightenment-wayland
381 (package
382 (inherit enlightenment)
383 (name "enlightenment-wayland")
384 (arguments
385 (substitute-keyword-arguments (package-arguments enlightenment)
386 ((#:configure-flags flags)
387 `(cons* "-Dwl=true" ,flags))))
388 (inputs
389 `(("wayland-protocols" ,wayland-protocols)
390 ("xorg-server-xwayland" ,xorg-server-xwayland)
391 ,@(package-inputs enlightenment)))))
392
393 (define-public python-efl
394 (package
395 (name "python-efl")
396 (version "1.24.0")
397 (source
398 (origin
399 (method url-fetch)
400 (uri (string-append "https://download.enlightenment.org/rel/bindings/"
401 "python/python-efl-" version ".tar.xz"))
402 (sha256
403 (base32
404 "1vk1cdd959gia4a9qzyq56a9zw3lqf9ck66k8c9g3c631mp5cfpy"))
405 (modules '((guix build utils)))
406 ;; Remove files generated by Cython
407 (snippet
408 '(begin
409 (copy-file "efl/dbus_mainloop/e_dbus.c" "efl/dbus_mainloop/e_dbus.q")
410 (for-each delete-file (find-files "efl" ".*\\.c$"))
411 (delete-file "efl/eo/efl.eo_api.h")
412 (copy-file "efl/dbus_mainloop/e_dbus.q" "efl/dbus_mainloop/e_dbus.c")
413 (delete-file "efl/dbus_mainloop/e_dbus.q")
414 #t))))
415 (build-system python-build-system)
416 (arguments
417 '(#:phases
418 (modify-phases %standard-phases
419 (replace 'build
420 (lambda _
421 (setenv "ENABLE_CYTHON" "1")
422 (invoke "python" "setup.py" "build")))
423 (add-before 'build 'set-flags
424 (lambda _
425 (setenv "CFLAGS"
426 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
427 "/include/dbus-1.0"))
428 #t))
429 (add-before 'check 'set-environment
430 (lambda _
431 ;; Some tests require write access to HOME.
432 (setenv "HOME" "/tmp")
433 ;; These tests try to connect to the internet.
434 (delete-file "tests/ecore/test_09_file_download.py")
435 (delete-file "tests/ecore/test_11_con.py")
436 #t)))))
437 (native-inputs
438 `(("pkg-config" ,pkg-config)
439 ("python-cython" ,python-cython)))
440 (inputs
441 `(("efl" ,efl)
442 ("python-dbus" ,python-dbus)))
443 (home-page "https://www.enlightenment.org/")
444 (synopsis "Python bindings for EFL")
445 (description
446 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
447 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
448 (license license:lgpl3)))
449
450 (define-public python2-efl
451 (package-with-python2 python-efl))
452
453 (define-public edi
454 (package
455 (name "edi")
456 (version "0.8.0")
457 (source
458 (origin
459 (method url-fetch)
460 (uri (string-append "https://github.com/Enlightenment/edi/releases/"
461 "download/v" version "/edi-" version ".tar.xz"))
462 (sha256
463 (base32
464 "01k8gp8r2wa6pyg3dkbm35m6hdsbss06hybghg0qjmd4mzswcd3a"))))
465 (build-system meson-build-system)
466 (arguments
467 '(#:phases
468 (modify-phases %standard-phases
469 (add-after 'unpack 'fix-clang-header
470 (lambda _
471 (substitute* "scripts/clang_include_dir.sh"
472 (("grep clang") "grep clang | head -n1"))
473 #t))
474 (add-after 'unpack 'set-home-directory
475 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
476 (lambda _ (setenv "HOME" "/tmp") #t)))
477 #:tests? #f)) ; tests require running dbus service
478 (native-inputs
479 `(("check" ,check)
480 ("gettext" ,gettext-minimal)
481 ("pkg-config" ,pkg-config)))
482 (inputs
483 `(("clang" ,clang)
484 ("efl" ,efl)))
485 (home-page "https://www.enlightenment.org/about-edi")
486 (synopsis "Development environment for Enlightenment")
487 (description "EDI is a development environment designed for and built using
488 the EFL. It's aim is to create a new, native development environment for Linux
489 that tries to lower the barrier to getting involved in Enlightenment development
490 and in creating applications based on the Enlightenment Foundation Library suite.")
491 (license (list license:public-domain ; data/extra/skeleton
492 license:gpl2 ; edi
493 license:gpl3)))) ; data/extra/examples/images/mono-runtime.png
494
495 (define-public lekha
496 (package
497 (name "lekha")
498 (version "0.2.1")
499 (source (origin
500 (method url-fetch)
501 (uri (pypi-uri "Lekha" version))
502 (sha256
503 (base32
504 "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
505 (build-system python-build-system)
506 (arguments
507 `(#:tests? #f ; no test target
508 #:python ,python-2
509 #:phases
510 (modify-phases %standard-phases
511 (add-after 'unpack 'fix-data-location
512 (lambda _ (substitute* "setup.py"
513 (("'/usr/")"'"))
514 #t)))))
515 (propagated-inputs
516 `(("python2-efl" ,python2-efl)
517 ("python2-pypdf2" ,python2-pypdf2)
518 ("python2-pyxdg" ,python2-pyxdg)))
519 (synopsis "Simple PDF viewer")
520 (description
521 "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
522 (home-page "https://github.com/kaihu/lekha")
523 (license license:gpl3+)))
524
525 (define-public ephoto
526 (package
527 (name "ephoto")
528 (version "1.5")
529 (source
530 (origin
531 (method url-fetch)
532 (uri (string-append "https://download.enlightenment.org/rel/"
533 "apps/ephoto/ephoto-" version ".tar.xz"))
534 (sha256
535 (base32 "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
536 (build-system gnu-build-system)
537 (arguments
538 '(#:phases
539 (modify-phases %standard-phases
540 (add-after 'unpack 'set-home-directory
541 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
542 (lambda _ (setenv "HOME" "/tmp") #t)))))
543 (native-inputs
544 `(("check" ,check)
545 ("pkg-config" ,pkg-config)))
546 (inputs
547 `(("efl" ,efl)))
548 (home-page "https://smhouston.us/projects/ephoto/")
549 (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
550 (description "Ephoto is an image viewer and editor written using the
551 @dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and
552 ease of use, while taking advantage of the speed and small footprint the EFL
553 provide.
554
555 Ephoto’s features include:
556 @enumerate
557 @item Browsing the file system and displaying images in an easy-to-use grid view.
558 @item Browsing images in a single image view format.
559 @item Viewing images in a slideshow.
560 @item Editing your image with features such as cropping, auto enhance,
561 blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
562 adjustments, and color level adjustment.
563 @item Applying artistic filters to your image such as black and white and old
564 photo.
565 @item Drag And Drop along with file operations to easily maintain your photo
566 directories.
567 @end enumerate\n")
568 (license (list
569 license:bsd-2 ; Ephoto's thumbnailing code
570 license:bsd-3))))
571
572 (define-public evisum
573 (package
574 (name "evisum")
575 (version "0.4.0")
576 (source
577 (origin
578 (method url-fetch)
579 (uri (string-append "https://download.enlightenment.org/rel/apps/"
580 "evisum/evisum-" version ".tar.xz"))
581 (sha256
582 (base32
583 "0gh3y2348pgf683sljnfry9k545h42dx75idyigcspsjsk7khisz"))))
584 (build-system meson-build-system)
585 (arguments
586 '(#:tests? #f)) ; no tests
587 (native-inputs
588 `(("pkg-config" ,pkg-config)))
589 (inputs
590 `(("efl" ,efl)))
591 (home-page "https://www.enlightenment.org")
592 (synopsis "EFL process viewer")
593 (description
594 "This is a process monitor and system monitor using the
595 @dfn{Enlightenment Foundation Libraries} (EFL).")
596 (license license:bsd-2)))