gnu: ghc-aeson-qq: Update to 0.8.2.
[jackhill/guix/guix.git] / gnu / packages / haskell-web.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
3 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
5 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
6 ;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
7 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages haskell-web)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages haskell)
27 #:use-module (gnu packages haskell-check)
28 #:use-module (gnu packages haskell-crypto)
29 #:use-module (gnu packages tls)
30 #:use-module (guix build-system haskell)
31 #:use-module (guix download)
32 #:use-module ((guix licenses) #:prefix license:)
33 #:use-module (guix packages)
34 #:use-module (guix utils))
35
36 (define-public ghc-tagsoup
37 (package
38 (name "ghc-tagsoup")
39 (version "0.14")
40 (source
41 (origin
42 (method url-fetch)
43 (uri (string-append
44 "https://hackage.haskell.org/package/tagsoup/tagsoup-"
45 version
46 ".tar.gz"))
47 (sha256
48 (base32
49 "07pax7i0bl79dmqqz58zy09yrgpnyyr2ya0z183hv96kp65jv0lh"))))
50 (build-system haskell-build-system)
51 (inputs `(("ghc-text" ,ghc-text)))
52 (home-page
53 "http://community.haskell.org/~ndm/tagsoup/")
54 (synopsis
55 "Parsing and extracting information from (possibly malformed) HTML/XML
56 documents")
57 (description
58 "TagSoup is a library for parsing HTML/XML. It supports the HTML 5
59 specification, and can be used to parse either well-formed XML, or
60 unstructured and malformed HTML from the web. The library also provides
61 useful functions to extract information from an HTML document, making it ideal
62 for screen-scraping.")
63 (license license:bsd-3)))
64
65 (define-public ghc-cookie
66 (package
67 (name "ghc-cookie")
68 (version "0.4.1.6")
69 (source
70 (origin
71 (method url-fetch)
72 (uri (string-append
73 "https://hackage.haskell.org/package/cookie/cookie-"
74 version
75 ".tar.gz"))
76 (sha256
77 (base32
78 "0b6ym6fn29p5az4dwydy036lxj131kagrmgb93w4bbkqfkds8b9s"))))
79 (build-system haskell-build-system)
80 (inputs
81 `(("ghc-old-locale" ,ghc-old-locale)
82 ("ghc-blaze-builder" ,ghc-blaze-builder)
83 ("ghc-text" ,ghc-text)
84 ("ghc-data-default-class" ,ghc-data-default-class)
85 ("ghc-hunit" ,ghc-hunit)
86 ("ghc-quickcheck" ,ghc-quickcheck)
87 ("ghc-tasty" ,ghc-tasty)
88 ("ghc-tasty-hunit" ,ghc-tasty-hunit)
89 ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
90 (home-page "https://github.com/snoyberg/cookie")
91 (synopsis "HTTP cookie parsing and rendering")
92 (description "HTTP cookie parsing and rendering library for Haskell.")
93 (license license:bsd-3)))
94
95 (define-public ghc-http-types
96 (package
97 (name "ghc-http-types")
98 (version "0.9")
99 (source
100 (origin
101 (method url-fetch)
102 (uri (string-append
103 "https://hackage.haskell.org/package/http-types/http-types-"
104 version
105 ".tar.gz"))
106 (sha256
107 (base32
108 "0ny15jgm5skhs2yx6snr13lrnw19hwjgfygrpsmhib8wqa8cz8cc"))))
109 (build-system haskell-build-system)
110 (arguments `(#:tests? #f)) ; FIXME: Tests cannot find
111 ; Blaze.Bytestring.Builder, which should be
112 ; provided by ghc-blaze-builder.
113 (inputs
114 `(("ghc-case-insensitive" ,ghc-case-insensitive)
115 ("ghc-blaze-builder" ,ghc-blaze-builder)
116 ("ghc-text" ,ghc-text)))
117 (home-page "https://github.com/aristidb/http-types")
118 (synopsis "Generic HTTP types for Haskell")
119 (description "This package provides generic HTTP types for Haskell (for
120 both client and server code).")
121 (license license:bsd-3)))
122
123 (define-public ghc-http
124 (package
125 (name "ghc-http")
126 (version "4000.2.20")
127 (outputs '("out" "doc"))
128 (source
129 (origin
130 (method url-fetch)
131 (uri (string-append
132 "https://hackage.haskell.org/package/HTTP/HTTP-"
133 version
134 ".tar.gz"))
135 (sha256
136 (base32
137 "0nyqdxr5ls2dxkf4a1f3x15xzwdm46ppn99nkcbhswlr6s3cq1s4"))))
138 (build-system haskell-build-system)
139 (native-inputs
140 `(("ghc-hunit" ,ghc-hunit)))
141 (inputs
142 `(("ghc-old-time" ,ghc-old-time)
143 ("ghc-parsec" ,ghc-parsec)
144 ("ghc-mtl" ,ghc-mtl)
145 ("ghc-network" ,ghc-network)
146 ("ghc-network-uri" ,ghc-network-uri)))
147 (arguments
148 `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
149 (home-page "https://github.com/haskell/HTTP")
150 (synopsis "Library for client-side HTTP")
151 (description
152 "The HTTP package supports client-side web programming in Haskell. It
153 lets you set up HTTP connections, transmitting requests and processing the
154 responses coming back.")
155 (license license:bsd-3)))
156
157 (define-public ghc-http-client
158 (package
159 (name "ghc-http-client")
160 (version "0.5.6.1")
161 (source (origin
162 (method url-fetch)
163 (uri (string-append "https://hackage.haskell.org/package/"
164 "http-client/http-client-"
165 version ".tar.gz"))
166 (sha256
167 (base32
168 "1v9bdb8dkhb5g6jl9azk86ig7ia8xh9arr64n7s8r94fp0vl6c1c"))))
169 (build-system haskell-build-system)
170 ;; Tests require access to the web.
171 (arguments `(#:tests? #f))
172 (inputs
173 `(("ghc-text" ,ghc-text)
174 ("ghc-http-types" ,ghc-http-types)
175 ("ghc-blaze-builder" ,ghc-blaze-builder)
176 ("ghc-data-default-class" ,ghc-data-default-class)
177 ("ghc-network" ,ghc-network)
178 ("ghc-streaming-commons" ,ghc-streaming-commons)
179 ("ghc-case-insensitive" ,ghc-case-insensitive)
180 ("ghc-base64-bytestring" ,ghc-base64-bytestring)
181 ("ghc-cookie" ,ghc-cookie)
182 ("ghc-exceptions" ,ghc-exceptions)
183 ("ghc-random" ,ghc-random)
184 ("ghc-mime-types" ,ghc-mime-types)
185 ("ghc-network-uri" ,ghc-network-uri)
186 ("ghc-monad-control" ,ghc-monad-control)
187 ("ghc-zlib" ,ghc-zlib)
188 ("ghc-async" ,ghc-async)))
189 (native-inputs
190 `(("ghc-hspec" ,ghc-hspec)))
191 (home-page "https://github.com/snoyberg/http-client")
192 (synopsis "HTTP client engine")
193 (description
194 "This package provides an HTTP client engine, intended as a base layer
195 for more user-friendly packages.")
196 (license license:expat)))
197
198 (define-public ghc-http-client-tls
199 (package
200 (name "ghc-http-client-tls")
201 (version "0.3.4.1")
202 (source (origin
203 (method url-fetch)
204 (uri (string-append "https://hackage.haskell.org/package/"
205 "http-client-tls/http-client-tls-"
206 version ".tar.gz"))
207 (sha256
208 (base32
209 "1mbwdfn4hs8lcwml2l6xv4n068l9zlasyv6vwb2ylgm030pyv3xh"))))
210 (build-system haskell-build-system)
211 ;; Tests require Internet access
212 (arguments `(#:tests? #f))
213 (inputs
214 `(("ghc-data-default-class" ,ghc-data-default-class)
215 ("ghc-http-client" ,ghc-http-client)
216 ("ghc-connection" ,ghc-connection)
217 ("ghc-network" ,ghc-network)
218 ("ghc-tls" ,ghc-tls)
219 ("ghc-http-types" ,ghc-http-types)))
220 (native-inputs
221 `(("ghc-hspec" ,ghc-hspec)))
222 (home-page "https://github.com/snoyberg/http-client")
223 (synopsis "Backend for http-client using the TLS library")
224 (description
225 "This package provides a backend for the http-client package using the
226 connection and TLS libraries. It is intended for use by higher-level
227 libraries, such as http-conduit.")
228 (license license:expat)))
229
230 (define-public ghc-http-date
231 (package
232 (name "ghc-http-date")
233 (version "0.0.6.1")
234 (source
235 (origin
236 (method url-fetch)
237 (uri (string-append "https://hackage.haskell.org/package/"
238 "http-date-" version "/"
239 "http-date-" version ".tar.gz"))
240 (sha256
241 (base32
242 "0dknh28kyarnzqrsc80ssalxjrq0qbv7ir49247p2grb7rh0dqgj"))))
243 (build-system haskell-build-system)
244 (inputs
245 `(("ghc-attoparsec" ,ghc-attoparsec)))
246 (native-inputs
247 `(("ghc-doctest" ,ghc-doctest)
248 ("ghc-hspec" ,ghc-hspec)
249 ("hspec-discover" ,hspec-discover)
250 ("ghc-old-locale" ,ghc-old-locale)))
251 (home-page "https://github.com/kazu-yamamoto/http-date")
252 (synopsis "HTTP Date parser/formatter")
253 (description "Library for Parsing and formatting HTTP
254 Date in Haskell.")
255 (license license:bsd-3)))
256
257 (define-public ghc-http2
258 (package
259 (name "ghc-http2")
260 (version "1.6.3")
261 (source
262 (origin
263 (method url-fetch)
264 (uri (string-append "https://hackage.haskell.org/package/"
265 "http2-" version "/"
266 "http2-" version ".tar.gz"))
267 (sha256
268 (base32
269 "0hww0rfsv6lqx62qzycbcqy5q6rh9k09qkyjkdm5m1sp1z50wqk1"))))
270 (build-system haskell-build-system)
271 (inputs
272 `(("ghc-bytestring-builder" ,ghc-bytestring-builder)
273 ("ghc-case-insensitive" ,ghc-case-insensitive)
274 ("ghc-aeson" ,ghc-aeson)
275 ("ghc-aeson-pretty" ,ghc-aeson-pretty)
276 ("ghc-hex" ,ghc-hex)
277 ("ghc-unordered-containers" ,ghc-unordered-containers)
278 ("ghc-vector" ,ghc-vector)
279 ("ghc-word8" ,ghc-word8)
280 ("ghc-psqueues" ,ghc-psqueues)
281 ("ghc-stm" ,ghc-stm)))
282 (native-inputs
283 `(("ghc-glob" ,ghc-glob)
284 ("ghc-hspec" ,ghc-hspec)
285 ("ghc-doctest" ,ghc-doctest)
286 ("hspec-discover" ,hspec-discover)))
287 (home-page "https://github.com/kazu-yamamoto/http2")
288 (synopsis "HTTP/2 library including frames, priority queues and HPACK")
289 (description "This package provides a HTTP/2.0 library including frames
290 and HPACK. Currently HTTP/2 16 framing and HPACK 10 is supported.")
291 (license license:bsd-3)))
292
293 (define-public ghc-http-conduit
294 (package
295 (name "ghc-http-conduit")
296 (version "2.2.3.1")
297 (source
298 (origin
299 (method url-fetch)
300 (uri (string-append "https://hackage.haskell.org/package/"
301 "http-conduit-" version "/" "http-conduit-"
302 version ".tar.gz"))
303 (sha256 (base32
304 "03na2nbm9la0shlijvjyb5mpp1prfskk4jmjy8iz707r0731dbjk"))))
305 (build-system haskell-build-system)
306 ;; FIXME: `httpLbs TLS` in test-suite `test` fails with
307 ;; ConnectionFailure getProtocolByName: does not exist (no such protocol
308 ;; name: tcp)
309 (arguments `(#:tests? #f))
310 (inputs
311 `(("ghc-aeson" ,ghc-aeson)
312 ("ghc-resourcet" ,ghc-resourcet)
313 ("ghc-conduit" ,ghc-conduit)
314 ("ghc-conduit-extra" ,ghc-conduit-extra)
315 ("ghc-http-types" ,ghc-http-types)
316 ("ghc-lifted-base" ,ghc-lifted-base)
317 ("ghc-http-client" ,ghc-http-client)
318 ("ghc-http-client-tls" ,ghc-http-client-tls)
319 ("ghc-monad-control" ,ghc-monad-control)
320 ("ghc-mtl" ,ghc-mtl)
321 ("ghc-exceptions" ,ghc-exceptions)))
322 (native-inputs
323 `(("ghc-hunit" ,ghc-hunit)
324 ("ghc-hspec" ,ghc-hspec)
325 ("ghc-data-default-class" ,ghc-data-default-class)
326 ("ghc-connection" ,ghc-connection)
327 ("ghc-warp-tls" ,ghc-warp-tls)
328 ("ghc-blaze-builder" ,ghc-blaze-builder)
329 ("ghc-text" ,ghc-text)
330 ("ghc-conduit" ,ghc-conduit)
331 ("ghc-utf8-string" ,ghc-utf8-string)
332 ("ghc-case-insensitive" ,ghc-case-insensitive)
333 ("ghc-lifted-base" ,ghc-lifted-base)
334 ("ghc-network" ,ghc-network)
335 ("ghc-wai" ,ghc-wai)
336 ("ghc-warp" ,ghc-warp)
337 ("ghc-wai-conduit" ,ghc-wai-conduit)
338 ("ghc-http-types" ,ghc-http-types)
339 ("ghc-http-client" ,ghc-http-client)
340 ("ghc-cookie" ,ghc-cookie)
341 ("ghc-conduit-extra" ,ghc-conduit-extra)
342 ("ghc-streaming-commons" ,ghc-streaming-commons)
343 ("ghc-aeson" ,ghc-aeson)
344 ("ghc-temporary" ,ghc-temporary)
345 ("ghc-resourcet" ,ghc-resourcet)))
346 (home-page "https://hackage.haskell.org/package/http-conduit")
347 (synopsis "HTTP/HTTPS client with conduit interface")
348 (description "This library uses attoparsec for parsing the actual
349 contents of the HTTP connection. It also provides higher-level functions
350 which allow you to avoid direct usage of conduits.")
351 (license license:bsd-3)))
352
353 (define-public ghc-wai
354 (package
355 (name "ghc-wai")
356 (version "3.2.1.1")
357 (source
358 (origin
359 (method url-fetch)
360 (uri (string-append
361 "https://hackage.haskell.org/package/wai/wai-"
362 version
363 ".tar.gz"))
364 (sha256
365 (base32
366 "08afasnirja21vr0bmzcywz4w29x736dmdv7h8nnh1l8bn7sd02x"))))
367 (build-system haskell-build-system)
368 (inputs
369 `(("ghc-bytestring-builder" ,ghc-bytestring-builder)
370 ("ghc-unix-compat" ,ghc-unix-compat)
371 ("ghc-vault" ,ghc-vault)
372 ("ghc-blaze-builder" ,ghc-blaze-builder)
373 ("ghc-network" ,ghc-network)
374 ("ghc-text" ,ghc-text)
375 ("ghc-http-types" ,ghc-http-types)))
376 (native-inputs
377 `(("hspec-discover" ,hspec-discover)
378 ("ghc-quickcheck" ,ghc-quickcheck)
379 ("ghc-hunit" ,ghc-hunit)
380 ("ghc-hspec" ,ghc-hspec)))
381 (home-page "https://hackage.haskell.org/package/wai")
382 (synopsis "Web application interface for Haskell")
383 (description "This package provides a Web Application Interface (WAI)
384 library for the Haskell language. It defines a common protocol for
385 communication between web applications and web servers.")
386 (license license:bsd-3)))
387
388 (define-public ghc-wai-logger
389 (package
390 (name "ghc-wai-logger")
391 (version "2.2.4.1")
392 (source
393 (origin
394 (method url-fetch)
395 (uri (string-append
396 "https://hackage.haskell.org/package/wai-logger/wai-logger-"
397 version
398 ".tar.gz"))
399 (sha256
400 (base32
401 "1s6svvy3ci4j1dj1jaw8hg628miwj8f5gpy9n8d8hpsaxav6nzgk"))))
402 (build-system haskell-build-system)
403 (arguments `(#:tests? #f)) ; FIXME: Tests cannot find libraries exported
404 ; by propagated-inputs.
405 (inputs
406 `(("ghc-auto-update" ,ghc-auto-update)
407 ("ghc-byteorder" ,ghc-byteorder)
408 ("ghc-easy-file" ,ghc-easy-file)
409 ("ghc-unix-time" ,ghc-unix-time)
410 ("ghc-blaze-builder" ,ghc-blaze-builder)
411 ("ghc-case-insensitive" ,ghc-case-insensitive)
412 ("ghc-fast-logger" ,ghc-fast-logger)
413 ("ghc-http-types" ,ghc-http-types)
414 ("ghc-network" ,ghc-network)
415 ("ghc-wai" ,ghc-wai)))
416 (home-page "https://hackage.haskell.org/package/wai-logger")
417 (synopsis "Logging system for WAI")
418 (description "This package provides the logging system for WAI.")
419 (license license:bsd-3)))
420
421 (define-public ghc-wai-extra
422 (package
423 (name "ghc-wai-extra")
424 (version "3.0.13.1")
425 (source
426 (origin
427 (method url-fetch)
428 (uri (string-append
429 "https://hackage.haskell.org/package/wai-extra/wai-extra-"
430 version
431 ".tar.gz"))
432 (sha256
433 (base32
434 "0mh761a1bayr4ydwqmh3h8ndpi19zqw34mmy49lp2abr70r0nm1p"))))
435 (build-system haskell-build-system)
436 (inputs
437 `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
438 ("ghc-base64-bytestring" ,ghc-base64-bytestring)
439 ("ghc-cookie" ,ghc-cookie)
440 ("ghc-blaze-builder" ,ghc-blaze-builder)
441 ("ghc-network" ,ghc-network)
442 ("ghc-lifted-base" ,ghc-lifted-base)
443 ("ghc-streaming-commons" ,ghc-streaming-commons)
444 ("ghc-stringsearch" ,ghc-stringsearch)
445 ("ghc-resourcet" ,ghc-resourcet)
446 ("ghc-fast-logger" ,ghc-fast-logger)
447 ("ghc-wai-logger" ,ghc-wai-logger)
448 ("ghc-zlib" ,ghc-zlib)
449 ("ghc-word8" ,ghc-word8)
450 ("ghc-iproute" ,ghc-iproute)
451 ("ghc-void" ,ghc-void)
452 ("ghc-wai" ,ghc-wai)
453 ("ghc-http-types" ,ghc-http-types)
454 ("ghc-text" ,ghc-text)
455 ("ghc-case-insensitive" ,ghc-case-insensitive)
456 ("ghc-data-default-class" ,ghc-data-default-class)
457 ("ghc-unix-compat" ,ghc-unix-compat)
458 ("ghc-vault" ,ghc-vault)
459 ("ghc-aeson" ,ghc-aeson)))
460 (native-inputs
461 `(("hspec-discover" ,hspec-discover)
462 ("ghc-hspec" ,ghc-hspec)
463 ("ghc-hunit" ,ghc-hunit)))
464 (home-page "https://github.com/yesodweb/wai")
465 (synopsis "Some basic WAI handlers and middleware")
466 (description "This library provides basic WAI handlers and middleware
467 functionality.")
468 (license license:expat)))
469
470 (define-public ghc-wai-conduit
471 (package
472 (name "ghc-wai-conduit")
473 (version "3.0.0.3")
474 (source
475 (origin
476 (method url-fetch)
477 (uri (string-append "https://hackage.haskell.org/package/"
478 "wai-conduit-" version "/"
479 "wai-conduit-" version ".tar.gz"))
480 (sha256
481 (base32
482 "1zvsiwjq2mvkb9sjgp3ly9m968m7a2jjzr4id6jpi3mmqykj15z4"))))
483 (build-system haskell-build-system)
484 (inputs
485 `(("ghc-conduit" ,ghc-conduit)
486 ("ghc-http-types" ,ghc-http-types)
487 ("ghc-wai" ,ghc-wai)
488 ("ghc-blaze-builder" ,ghc-blaze-builder)))
489 (home-page "https://github.com/yesodweb/wai")
490 (synopsis "Conduit wrappers for Haskell's WAI")
491 (description "This package provides data streaming abstraction for
492 Haskell's Web Application Interface (WAI).")
493 (license license:expat)))
494
495 (define-public ghc-warp
496 (package
497 (name "ghc-warp")
498 (version "3.2.11.1")
499 (source
500 (origin
501 (method url-fetch)
502 (uri (string-append "https://hackage.haskell.org/package/"
503 "warp-" version "/" "warp-" version
504 ".tar.gz"))
505 (sha256
506 (base32
507 "1zp5cy0bbj508vdvms1n5z80z37m253kwsqc5a83cfc990n6fgw5"))))
508 (build-system haskell-build-system)
509 (arguments
510 `(#:tests? #f)) ; FIXME: Test-Suite `spec` fails.
511 (inputs
512 `(("ghc-async" ,ghc-async)
513 ("ghc-auto-update" ,ghc-auto-update)
514 ("ghc-blaze-builder" ,ghc-blaze-builder)
515 ("ghc-bytestring-builder" ,ghc-bytestring-builder)
516 ("ghc-case-insensitive" ,ghc-case-insensitive)
517 ("ghc-hashable" ,ghc-hashable)
518 ("ghc-http-types" ,ghc-http-types)
519 ("ghc-iproute" ,ghc-iproute)
520 ("ghc-network" ,ghc-network)
521 ("ghc-stm" ,ghc-stm)
522 ("ghc-streaming-commons" ,ghc-streaming-commons)
523 ("ghc-text" ,ghc-text)
524 ("ghc-unix-compat" ,ghc-unix-compat)
525 ("ghc-vault" ,ghc-vault)
526 ("ghc-wai" ,ghc-wai)
527 ("ghc-word8" ,ghc-word8)
528 ("ghc-lifted-base" ,ghc-lifted-base)
529 ("ghc-http-date" ,ghc-http-date)
530 ("ghc-simple-sendfile" ,ghc-simple-sendfile)
531 ("ghc-http2" ,ghc-http2)))
532 (native-inputs
533 `(("ghc-silently" ,ghc-silently)
534 ("ghc-hspec" ,ghc-hspec)
535 ("ghc-auto-update" ,ghc-auto-update)
536 ("ghc-doctest" ,ghc-doctest)
537 ("ghc-quickcheck" ,ghc-quickcheck)
538 ("ghc-hunit" ,ghc-hunit)
539 ("ghc-http" ,ghc-http)
540 ("hspec-discover" ,hspec-discover)))
541 (home-page "http://github.com/yesodweb/wai")
542 (synopsis "HTTP server library for Haskell's WAI")
543 (description "Warp is a server library for HTTP/1.x and HTTP/2
544 based WAI (Web Application Interface in Haskell).")
545 (license license:expat)))
546
547 (define-public ghc-warp-tls
548 (package
549 (name "ghc-warp-tls")
550 (version "3.2.3")
551 (source
552 (origin
553 (method url-fetch)
554 (uri (string-append "https://hackage.haskell.org/package/"
555 "warp-tls-" version "/"
556 "warp-tls-" version ".tar.gz"))
557 (sha256
558 (base32
559 "14m2bzk5ivz9gdpxlcj6qnh46f2lycm1ybdjnfkj2876zrqwii7m"))))
560 (build-system haskell-build-system)
561 (inputs
562 `(("ghc-cryptonite" ,ghc-cryptonite)
563 ("ghc-data-default-class" ,ghc-data-default-class)
564 ("ghc-network" ,ghc-network)
565 ("ghc-streaming-commons" ,ghc-streaming-commons)
566 ("ghc-tls" ,ghc-tls)
567 ("ghc-wai" ,ghc-wai)
568 ("ghc-warp" ,ghc-warp)))
569 (home-page "http://github.com/yesodweb/wai")
570 (synopsis "SSL/TLS support for Warp")
571 (description "This package provides SSL/TLS support for Warp,
572 a WAI handler, via the native Haskell TLS implementation.")
573 (license license:expat)))
574
575 (define-public ghc-xss-sanitize
576 (package
577 (name "ghc-xss-sanitize")
578 (version "0.3.5.6")
579 (source
580 (origin
581 (method url-fetch)
582 (uri (string-append
583 "https://hackage.haskell.org/package/xss-sanitize/xss-sanitize-"
584 version
585 ".tar.gz"))
586 (sha256
587 (base32
588 "1j2qrn2dbfx01m7zyk9ilgnp9zjwq9mk62b0rdal4zkg4vh212h0"))))
589 (build-system haskell-build-system)
590 (inputs
591 `(("ghc-tagsoup" ,ghc-tagsoup)
592 ("ghc-utf8-string" ,ghc-utf8-string)
593 ("ghc-css-text" ,ghc-css-text)
594 ("ghc-network-uri" ,ghc-network-uri)))
595 (native-inputs
596 `(("ghc-text" ,ghc-text)
597 ("ghc-attoparsec" ,ghc-attoparsec)
598 ("ghc-hspec" ,ghc-hspec)
599 ("ghc-hunit" ,ghc-hunit)))
600 (home-page "https://github.com/yesodweb/haskell-xss-sanitize")
601 (synopsis "Sanitize untrusted HTML to prevent XSS attacks")
602 (description "This library provides @code{sanitizeXSS}. Run untrusted
603 HTML through @code{Text.HTML.SanitizeXSS.sanitizeXSS} to prevent XSS
604 attacks.")
605 (license license:bsd-3)))
606
607 (define-public ghc-css-text
608 (package
609 (name "ghc-css-text")
610 (version "0.1.2.1")
611 (source
612 (origin
613 (method url-fetch)
614 (uri (string-append
615 "https://hackage.haskell.org/package/css-text/css-text-"
616 version
617 ".tar.gz"))
618 (sha256
619 (base32
620 "1xi1n2f0g8y43p95lynhcg50wxbq7hqfzbfzm7fy8mn7gvd920nw"))))
621 (build-system haskell-build-system)
622 (inputs
623 `(("ghc-text" ,ghc-text)
624 ("ghc-attoparsec" ,ghc-attoparsec)
625 ("ghc-hspec" ,ghc-hspec)
626 ("ghc-quickcheck" ,ghc-quickcheck)))
627 (home-page "http://www.yesodweb.com/")
628 (synopsis "CSS parser and renderer")
629 (description "This package provides a CSS parser and renderer for
630 Haskell.")
631 (license license:bsd-3)))
632
633 (define-public ghc-mime-types
634 (package
635 (name "ghc-mime-types")
636 (version "0.1.0.6")
637 (source (origin
638 (method url-fetch)
639 (uri (string-append "https://hackage.haskell.org/package/"
640 "mime-types/mime-types-"
641 version ".tar.gz"))
642 (sha256
643 (base32
644 "090z3dp928243amnc6s8g10rk2h2bprk9y138q6wj3cpflzr72pw"))))
645 (build-system haskell-build-system)
646 (inputs
647 `(("ghc-text" ,ghc-text)))
648 (home-page "https://github.com/yesodweb/wai")
649 (synopsis "Basic MIME type handling types and functions")
650 (description
651 "This library provides basic MIME type handling types and functions.")
652 (license license:expat)))
653
654 (define-public ghc-html
655 (package
656 (name "ghc-html")
657 (version "1.0.1.2")
658 (source
659 (origin
660 (method url-fetch)
661 (uri (string-append
662 "https://hackage.haskell.org/package/html/html-"
663 version
664 ".tar.gz"))
665 (sha256
666 (base32
667 "0q9hmfii62kc82ijlg238fxrzxhsivn42x5wd6ffcr9xldg4jd8c"))))
668 (build-system haskell-build-system)
669 (home-page
670 "https://hackage.haskell.org/package/html")
671 (synopsis "HTML combinator library")
672 (description
673 "This package contains a combinator library for constructing HTML
674 documents.")
675 (license license:bsd-3)))
676
677 (define-public ghc-xhtml
678 (package
679 (name "ghc-xhtml")
680 (version "3000.2.1")
681 (source
682 (origin
683 (method url-fetch)
684 (uri (string-append
685 "https://hackage.haskell.org/package/xhtml/xhtml-"
686 version
687 ".tar.gz"))
688 (sha256
689 (base32
690 "1n6wgzxbj8xf0wf1il827qidphnffb5vzhwzqlxhh70c2y10f0ik"))))
691 (build-system haskell-build-system)
692 (home-page "https://github.com/haskell/xhtml")
693 (synopsis "XHTML combinator library")
694 (description
695 "This package provides combinators for producing XHTML 1.0, including the
696 Strict, Transitional and Frameset variants.")
697 (license license:bsd-3)))
698
699 (define-public ghc-blaze-html
700 (package
701 (name "ghc-blaze-html")
702 (version "0.8.1.1")
703 (source
704 (origin
705 (method url-fetch)
706 (uri (string-append
707 "https://hackage.haskell.org/package/blaze-html/blaze-html-"
708 version
709 ".tar.gz"))
710 (sha256
711 (base32
712 "1dnw50kh0s405cg9i2y4a8awanhj3bqzk21jwgfza65kcjby7lpq"))))
713 (build-system haskell-build-system)
714 (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
715 (inputs
716 `(("ghc-blaze-builder" ,ghc-blaze-builder)
717 ("ghc-text" ,ghc-text)
718 ("ghc-blaze-markup" ,ghc-blaze-markup)))
719 (home-page "http://jaspervdj.be/blaze")
720 (synopsis "Fast HTML combinator library")
721 (description "This library provides HTML combinators for Haskell.")
722 (license license:bsd-3)))
723
724 (define-public ghc-aeson
725 (package
726 (name "ghc-aeson")
727 (version "0.10.0.0")
728 (source
729 (origin
730 (method url-fetch)
731 (uri (string-append
732 "https://hackage.haskell.org/package/aeson/aeson-"
733 version
734 ".tar.gz"))
735 (sha256
736 (base32
737 "19kp33rfivr4d3myyr8xn803wd7p8x5nc4wb3qvlgjwgyqjaxvrz"))))
738 (build-system haskell-build-system)
739 (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing.
740 (inputs
741 `(("ghc-attoparsec" ,ghc-attoparsec)
742 ("ghc-dlist" ,ghc-dlist)
743 ("ghc-mtl" ,ghc-mtl)
744 ("ghc-scientific" ,ghc-scientific)
745 ("ghc-syb" ,ghc-syb)
746 ("ghc-unordered-containers" ,ghc-unordered-containers)
747 ("ghc-vector" ,ghc-vector)
748 ("ghc-hashable" ,ghc-hashable)
749 ("ghc-text" ,ghc-text)
750 ("ghc-hunit" ,ghc-hunit)
751 ("ghc-quickcheck" ,ghc-quickcheck)))
752 (home-page "https://github.com/bos/aeson")
753 (synopsis "Fast JSON parsing and encoding")
754 (description "This package provides a JSON parsing and encoding library
755 for Haskell, optimized for ease of use and high performance. (A note on
756 naming: in Greek mythology, Aeson was the father of Jason.)")
757 (license license:bsd-3)))
758
759 (define-public ghc-aeson-pretty
760 (package
761 (name "ghc-aeson-pretty")
762 (version "0.7.2")
763 (source (origin
764 (method url-fetch)
765 (uri (string-append
766 "https://hackage.haskell.org/package/aeson-pretty/aeson-pretty-"
767 version ".tar.gz"))
768 (sha256
769 (base32
770 "03ap81853qi8yd9kdgczllrrni23a6glsfxrwj8zab6ipjrbh234"))))
771 (build-system haskell-build-system)
772 (inputs
773 `(("ghc-aeson" ,ghc-aeson)
774 ("ghc-vector" ,ghc-vector)
775 ("ghc-text" ,ghc-text)
776 ("ghc-unordered-containers"
777 ,ghc-unordered-containers)
778 ("ghc-attoparsec" ,ghc-attoparsec)
779 ("ghc-cmdargs" ,ghc-cmdargs)))
780 (home-page "https://github.com/informatikr/aeson-pretty")
781 (synopsis "JSON pretty-printing library and command-line tool")
782 (description
783 "This package provides a JSON pretty-printing library compatible with aeson
784 as well as a command-line tool to improve readabilty of streams of JSON data.
785 The library provides the function @code{encodePretty}. It is a drop-in
786 replacement for aeson's @code{encode} function, producing JSON-ByteStrings for
787 human readers. The command-line tool reads JSON from stdin and writes
788 prettified JSON to stdout. It also offers a complementary \"compact\"-mode,
789 essentially the opposite of pretty-printing.")
790 (license license:bsd-3)))
791
792 (define-public ghc-aeson-qq
793 (package
794 (name "ghc-aeson-qq")
795 (version "0.8.2")
796 (source (origin
797 (method url-fetch)
798 (uri (string-append "https://hackage.haskell.org/package/"
799 "aeson-qq/aeson-qq-" version ".tar.gz"))
800 (sha256
801 (base32
802 "0ln13jqyfh5726hdrk1rad9a6cgrrj201plmwcfcpvq18v4m5ckd"))))
803 (build-system haskell-build-system)
804 (inputs
805 `(("ghc-base-compat" ,ghc-base-compat)
806 ("ghc-text" ,ghc-text)
807 ("ghc-attoparsec" ,ghc-attoparsec)
808 ("ghc-scientific" ,ghc-scientific)
809 ("ghc-vector" ,ghc-vector)
810 ("ghc-aeson" ,ghc-aeson)
811 ("ghc-parsec" ,ghc-parsec)
812 ("ghc-haskell-src-meta" ,ghc-haskell-src-meta)))
813 (native-inputs
814 `(("ghc-hspec" ,ghc-hspec)
815 ("hspec-discover" ,hspec-discover)))
816 (home-page "https://github.com/zalora/aeson-qq")
817 (synopsis "JSON quasiquoter for Haskell")
818 (description
819 "aeson-qq provides a JSON quasiquoter for Haskell. This package exposes
820 the function @code{aesonQQ} that compile-time converts a string representation
821 of a JSON value into a @code{Data.Aeson.Value}.")
822 (license license:expat)))
823
824 (define-public ghc-multipart
825 (package
826 (name "ghc-multipart")
827 (version "0.1.2")
828 (source
829 (origin
830 (method url-fetch)
831 (uri (string-append
832 "https://hackage.haskell.org/package/multipart/multipart-"
833 version
834 ".tar.gz"))
835 (sha256
836 (base32
837 "0g04jhyw1ib1s7c9bcldyyn4n90qd9x7dmvic4vgq57bgcqgnhz5"))))
838 (build-system haskell-build-system)
839 (inputs `(("ghc-parsec" ,ghc-parsec)))
840 (home-page
841 "http://www.github.com/silkapp/multipart")
842 (synopsis
843 "HTTP multipart library")
844 (description
845 "HTTP multipart split out of the cgi package, for Haskell.")
846 (license license:bsd-3)))