gnu: r-org-dm-eg-db: Update to 3.5.0.
[jackhill/guix/guix.git] / gnu / packages / password-utils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
3 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
5 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
6 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
7 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
8 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
9 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
10 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
12 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
13 ;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
14 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
15 ;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages password-utils)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system gnu)
36 #:use-module (guix download)
37 #:use-module (guix packages)
38 #:use-module (gnu packages)
39 #:use-module (gnu packages admin)
40 #:use-module (gnu packages aidc)
41 #:use-module (gnu packages base)
42 #:use-module (gnu packages check)
43 #:use-module (gnu packages compression)
44 #:use-module (gnu packages freedesktop)
45 #:use-module (gnu packages glib)
46 #:use-module (gnu packages gnupg)
47 #:use-module (gnu packages gnuzilla)
48 #:use-module (gnu packages gtk)
49 #:use-module (gnu packages guile)
50 #:use-module (gnu packages kerberos)
51 #:use-module (gnu packages libffi)
52 #:use-module (gnu packages linux)
53 #:use-module (gnu packages man)
54 #:use-module (gnu packages multiprecision)
55 #:use-module (gnu packages ncurses)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages python)
58 #:use-module (gnu packages suckless)
59 #:use-module (gnu packages tls)
60 #:use-module (gnu packages qt)
61 #:use-module (gnu packages version-control)
62 #:use-module (gnu packages xdisorg)
63 #:use-module (gnu packages xorg)
64 #:use-module (guix build-system python))
65
66 (define-public pwgen
67 (package
68 (name "pwgen")
69 (version "2.07")
70 (source
71 (origin
72 (method url-fetch)
73 (uri (string-append "mirror://sourceforge/pwgen/pwgen/" version
74 "/pwgen-" version ".tar.gz"))
75 (sha256
76 (base32 "0mhmw700kkh238fzivcwnwi94bj9f3h36yfh3k3j2v19b0zmjx7b"))))
77 (build-system gnu-build-system)
78 (arguments
79 `(#:tests? #f)) ; no test suite
80 (home-page "http://pwgen.sourceforge.net/")
81 (synopsis "Password generator")
82 (description "Pwgen generates passwords which can be easily memorized by a
83 human.")
84 (license license:gpl2)))
85
86 (define-public keepassxc
87 (package
88 (name "keepassxc")
89 (version "2.2.1")
90 (source
91 (origin
92 (method url-fetch)
93 (uri (string-append "https://github.com/keepassxreboot/" name
94 "/releases/download/" version "/keepassxc-"
95 version "-src.tar.xz"))
96 (sha256
97 (base32
98 "1gkxsv3g4pkzbjkd1c27k15m2b5y2fqnnijphnaiv542yk7csqb7"))))
99 (build-system cmake-build-system)
100 (inputs
101 `(("libgcrypt" ,libgcrypt)
102 ("libxi" ,libxi)
103 ("libxtst" ,libxtst)
104 ("qtbase" ,qtbase)
105 ("qtx11extras" ,qtx11extras)
106 ("zlib" ,zlib)))
107 (native-inputs
108 `(("qttools" ,qttools)))
109 (home-page "https://www.keepassxc.org")
110 (synopsis "Password manager")
111 (description "KeePassXC is a password manager or safe which helps you to
112 manage your passwords in a secure way. You can put all your passwords in one
113 database, which is locked with one master key or a key-file which can be stored
114 on an external storage device. The databases are encrypted using the
115 algorithms AES or Twofish.")
116 ;; Non functional parts use various licences.
117 (license license:gpl3)))
118
119 (define-public keepassx
120 (package
121 (name "keepassx")
122 (version "2.0.3")
123 (source
124 (origin
125 (method url-fetch)
126 (uri (string-append "https://www.keepassx.org/releases/" version
127 "/keepassx-" version ".tar.gz"))
128 (sha256
129 (base32
130 "1ia7cqx9ias38mnffsl7da7g1f66bcbjsi23k49sln0c6spb9zr3"))))
131 (build-system cmake-build-system)
132 (inputs
133 `(("libgcrypt" ,libgcrypt)
134 ("libxi" ,libxi)
135 ("libxtst" ,libxtst)
136 ("qt" ,qt-4)))
137 (native-inputs
138 `(("zlib" ,zlib)))
139 (home-page "https://www.keepassx.org")
140 (synopsis "Password manager")
141 (description "KeePassX is a password manager or safe which helps you to
142 manage your passwords in a secure way. You can put all your passwords in one
143 database, which is locked with one master key or a key-file which can be stored
144 on an external storage device. The databases are encrypted using the
145 algorithms AES or Twofish.")
146 ;; Non functional parts use various licences.
147 (license license:gpl3)
148 (properties `((superseded . ,keepassxc)))))
149
150 (define-public shroud
151 (package
152 (name "shroud")
153 (version "0.1.1")
154 (source (origin
155 (method url-fetch)
156 (uri (string-append "https://files.dthompson.us/shroud/shroud-"
157 version ".tar.gz"))
158 (sha256
159 (base32
160 "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
161 (build-system gnu-build-system)
162 (arguments
163 '(#:phases
164 (modify-phases %standard-phases
165 (add-after 'install 'wrap-shroud
166 (lambda* (#:key outputs #:allow-other-keys)
167 (let* ((out (assoc-ref outputs "out"))
168 (ccachedir (string-append out "/lib/guile/2.0/ccache"))
169 (prog (string-append out "/bin/shroud")))
170 (wrap-program prog
171 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
172 #t))))))
173 (inputs
174 `(("guile" ,guile-2.0)
175 ("gnupg" ,gnupg)
176 ("xclip" ,xclip)))
177 (synopsis "GnuPG-based secret manager")
178 (description "Shroud is a simple secret manager with a command line
179 interface. The password database is stored as a Scheme s-expression and
180 encrypted with a GnuPG key. Secrets consist of an arbitrary number of
181 key/value pairs, making Shroud suitable for more than just password storage.
182 For copying and pasting secrets into web browsers and other graphical
183 applications, there is xclip integration." )
184 (home-page "https://dthompson.us/projects/shroud.html")
185 (license license:gpl3+)))
186
187 (define-public yapet
188 (package
189 (name "yapet")
190 (version "1.0")
191 (source (origin
192 (method url-fetch)
193 (uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
194 version
195 ".tar.bz2"))
196 (sha256
197 (base32
198 "0ydbnqw6icdh07pnv2w6dhvq501bdfvrklv4xmyr8znca9d753if"))))
199 (build-system gnu-build-system)
200 (inputs
201 `(("ncurses" ,ncurses)
202 ("openssl" ,openssl)))
203 (native-inputs
204 `(("pkg-config" ,pkg-config)))
205 (synopsis "Yet Another Password Encryption Tool")
206 (description "YAPET is a text based password manager using the Blowfish
207 encryption algorithm. Because of its small footprint and very few library
208 dependencies, it is suited for installing on desktop and server systems alike.
209 The text based user interface allows you to run YAPET easily in a Secure Shell
210 session. Two companion utilities enable users to convert CSV files to YAPET
211 and vice versa.")
212 (home-page "http://www.guengel.ch/myapps/yapet/")
213 (license license:gpl3+)))
214
215 (define-public cracklib
216 (package
217 (name "cracklib")
218 (version "2.9.6")
219 (source (origin
220 (method url-fetch)
221 (uri (string-append "https://github.com/cracklib/cracklib/"
222 "releases/download/" name "-" version "/"
223 name "-" version ".tar.gz"))
224 (patches (search-patches "cracklib-CVE-2016-6318.patch"
225 "cracklib-fix-buffer-overflow.patch"))
226 (sha256
227 (base32
228 "0hrkb0prf7n92w6rxgq0ilzkk6rkhpys2cfqkrbzswp27na7dkqp"))))
229 (build-system gnu-build-system)
230 (synopsis "Password checking library")
231 (home-page "https://github.com/cracklib/cracklib")
232 (description
233 "CrackLib is a library containing a C function which may be used in a
234 @command{passwd}-like program. The idea is simple: try to prevent users from
235 choosing passwords that could easily be guessed (or \"cracked\") by filtering
236 them out, at the source.")
237 (license license:lgpl2.1)))
238
239 (define-public libpwquality
240 (package
241 (name "libpwquality")
242 (version "1.4.0")
243 (source (origin
244 (method url-fetch)
245 (uri (list
246 (string-append "https://github.com/" name "/" name
247 "/releases/download/" name "-" version
248 "/" name "-" version ".tar.bz2")
249 (string-append "https://launchpad.net/libpwquality/trunk/"
250 version "/+download/"
251 name "-" version ".tar.bz2")))
252 (sha256
253 (base32
254 "0syyz8r54l8mqmbb0mw19qz4z2cx8gdgidicb8k2s5zjdh2gzrhx"))))
255 (build-system gnu-build-system)
256 (arguments
257 ;; XXX: have RUNPATH issue.
258 '(#:configure-flags '("--disable-python-bindings")))
259 (inputs
260 `(("cracklib" ,cracklib)))
261 (synopsis "Password quality checker")
262 (home-page "https://github.com/libpwquality/libpwquality")
263 (description
264 "Libpwquality is a library for password quality checking and generation of
265 random passwords that pass the checks.")
266 (license license:gpl2+)))
267
268 (define-public assword
269 (package
270 (name "assword")
271 (version "0.10")
272 (source (origin
273 (method url-fetch)
274 (uri (list
275 (string-append
276 "http://http.debian.net/debian/pool/main/a/assword/"
277 "assword_" version ".orig.tar.gz")))
278 (sha256
279 (base32
280 "0l6170y6my1gprqkazvzabgjkrkr9v2q7z48vjflna4r323yqira"))))
281 (arguments
282 `(;; irritatingly, tests do run but not there are two problems:
283 ;; - "import gtk" fails for unknown reasons here despite it the
284 ;; program working (indeed, I've found I have to do a logout and log
285 ;; back in in after an install order for some mumbo jumbo environment
286 ;; variable mess to work with pygtk and assword... what's up with
287 ;; that?)
288 ;; - even when the tests fail, they don't return a nonzero status,
289 ;; so I'm not sure how to programmatically get that information
290 #:tests? #f
291 #:phases
292 (modify-phases %standard-phases
293 (add-after 'install 'wrap-assword
294 (lambda* (#:key outputs #:allow-other-keys)
295 (let ((prog (string-append
296 (assoc-ref outputs "out")
297 "/bin/assword"))
298 (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
299 (wrap-program prog
300 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))
301 #t)))
302 (add-after 'install 'manpage
303 (lambda* (#:key outputs #:allow-other-keys)
304 (and
305 ;; Without this substitution, it fails with
306 ;; ImportError: No module named 'gpg'
307 (substitute* "Makefile"
308 (("PYTHONPATH=.") ""))
309 (zero? (system* "make" "assword.1"))
310 (install-file
311 "assword.1"
312 (string-append (assoc-ref outputs "out") "/share/man/man1"))))))))
313 (build-system python-build-system)
314 (native-inputs
315 `(("txt2man" ,txt2man)))
316 (inputs
317 `(("gtk+" ,gtk+)
318 ("python-xdo" ,python-xdo)
319 ("python-gpg" ,python-gpg)
320 ("python-pygobject" ,python-pygobject)))
321 (propagated-inputs
322 `(("xclip" ,xclip)))
323 (home-page "https://finestructure.net/assword/")
324 (synopsis "Password manager")
325 (description "assword is a simple password manager using GPG-wrapped
326 JSON files. It has a command line interface as well as a very simple
327 graphical interface, which can even \"type\" your passwords into
328 any X11 window.")
329 (license license:gpl3+)))
330
331 (define-public password-store
332 (package
333 (name "password-store")
334 (version "1.7.1")
335 (source (origin
336 (method url-fetch)
337 (uri
338 (string-append "https://git.zx2c4.com/password-store/snapshot/"
339 name "-" version ".tar.xz"))
340 (sha256
341 (base32
342 "0scqkpll2q8jhzcgcsh9kqz0gwdpvynivqjmmbzax2irjfaiklpn"))))
343 (build-system gnu-build-system)
344 (arguments
345 '(#:phases
346 (modify-phases %standard-phases
347 (delete 'configure)
348 (delete 'build)
349 (add-before 'install 'patch-passmenu-path
350 (lambda* (#:key inputs #:allow-other-keys)
351 (substitute* "contrib/dmenu/passmenu"
352 (("dmenu") (string-append (assoc-ref inputs "dmenu")
353 "/bin/dmenu"))
354 (("xdotool") (string-append (assoc-ref inputs "xdotool")
355 "/bin/xdotool")))
356 #t))
357 (add-after 'install 'install-passmenu
358 (lambda* (#:key outputs #:allow-other-keys)
359 (let ((out (assoc-ref outputs "out")))
360 (copy-file "contrib/dmenu/passmenu"
361 (string-append out "/bin/passmenu"))
362 #t)))
363 (add-after 'install 'wrap-path
364 (lambda* (#:key inputs outputs #:allow-other-keys)
365 (let ((out (assoc-ref outputs "out"))
366 (path (map (lambda (pkg)
367 (string-append (assoc-ref inputs pkg) "/bin"))
368 '("coreutils" "getopt" "git" "gnupg" "qrencode"
369 "sed" "tree" "which" "xclip"))))
370 (wrap-program (string-append out "/bin/pass")
371 `("PATH" ":" prefix (,(string-join path ":"))))
372 #t)))
373 (add-after 'wrap-path 'install-shell-completions
374 (lambda* (#:key outputs #:allow-other-keys)
375 (let* ((out (assoc-ref outputs "out"))
376 (bashcomp (string-append out "/etc/bash_completion.d")))
377 ;; TODO: install fish and zsh completions.
378 (mkdir-p bashcomp)
379 (copy-file "src/completion/pass.bash-completion"
380 (string-append bashcomp "/pass"))
381 #t))))
382 #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
383 ;; Parallel tests may cause a race condition leading to a
384 ;; timeout in some circumstances.
385 #:parallel-tests? #f
386 #:test-target "test"))
387 (inputs
388 `(("dmenu" ,dmenu)
389 ("getopt" ,util-linux)
390 ("git" ,git)
391 ("gnupg" ,gnupg)
392 ("qrencode" ,qrencode)
393 ("sed" ,sed)
394 ("tree" ,tree)
395 ("which" ,which)
396 ("xclip" ,xclip)
397 ("xdotool" ,xdotool)))
398 (home-page "http://www.passwordstore.org/")
399 (synopsis "Encrypted password manager")
400 (description "Password-store is a password manager which uses GnuPG to
401 store and retrieve passwords. The tool stores each password in its own
402 GnuPG-encrypted file, allowing the program to be simple yet secure.
403 Synchronization is possible using the integrated git support, which commits
404 changes to your password database to a git repository that can be managed
405 through the pass command.")
406 (license license:gpl2+)))
407
408 (define-public argon2
409 (package
410 (name "argon2")
411 (version "20161029")
412 (source
413 (origin
414 (method url-fetch)
415 (uri
416 (string-append "https://github.com/P-H-C/phc-winner-argon2/archive/"
417 version ".tar.gz"))
418 (file-name (string-append name "-" version ".tar.gz"))
419 (sha256
420 (base32
421 "1rymikbysasdadm325jx69i0q19d9srqkny69jwmhswlidr4j07y"))))
422 (build-system gnu-build-system)
423 (arguments
424 `(#:test-target "test"
425 #:make-flags '("CC=gcc")
426 #:phases
427 (modify-phases %standard-phases
428 (delete 'configure)
429 (replace 'install
430 (lambda _
431 (let ((out (assoc-ref %outputs "out")))
432 (install-file "argon2" (string-append out "/bin"))
433 (install-file "libargon2.a" (string-append out "/lib"))
434 (install-file "libargon2.so" (string-append out "/lib"))
435 (copy-recursively "include"
436 (string-append out "/include"))))))))
437 (home-page "https://www.argon2.com/")
438 (synopsis "Password hashing library")
439 (description "Argon2 provides a key derivation function that was declared
440 winner of the 2015 Password Hashing Competition.")
441 (license license:cc0)))
442
443 (define-public python-bcrypt
444 (package
445 (name "python-bcrypt")
446 (version "3.1.0")
447 (source
448 (origin
449 (method url-fetch)
450 (uri (pypi-uri "bcrypt" version))
451 (sha256
452 (base32
453 "1giy0dvd8gvq6flxh44np1v2nqwsji5qsnrz038mgwzgp7c20j75"))))
454 (build-system python-build-system)
455 (native-inputs
456 `(("python-pycparser" ,python-pycparser)
457 ("python-pytest" ,python-pytest)))
458 (propagated-inputs
459 `(("python-cffi" ,python-cffi)
460 ("python-six" ,python-six)))
461 (home-page "https://github.com/pyca/bcrypt/")
462 (synopsis
463 "Modern password hashing library")
464 (description
465 "Bcrypt is a Python module which provides a password hashing method based
466 on the Blowfish password hashing algorithm, as described in
467 @url{http://static.usenix.org/events/usenix99/provos.html,\"A Future-Adaptable
468 Password Scheme\"} by Niels Provos and David Mazieres.")
469 (license license:asl2.0)))
470
471 (define-public python2-bcrypt
472 (package-with-python2 python-bcrypt))
473
474 (define-public pass-git-helper
475 (package
476 (name "pass-git-helper")
477 (version "0.3.1")
478 (source
479 (origin
480 (method url-fetch)
481 (uri (string-append "https://github.com/languitar/pass-git-helper/archive/release-"
482 version ".tar.gz"))
483 (sha256
484 (base32
485 "0lz5ncy44pz7z1j2nnyildx8sq33zi3xvg5nkwg25n11nasqh2xn"))))
486 (build-system python-build-system)
487 (arguments
488 `(#:phases
489 (modify-phases %standard-phases
490 (add-before 'build 'patch-pass-path
491 (lambda* (#:key inputs #:allow-other-keys)
492 (let* ((password-store (assoc-ref inputs "password-store"))
493 (pass (string-append password-store "/bin/pass")))
494 (substitute* "pass-git-helper"
495 (("'pass'") (string-append "'" pass "'")))
496 #t))))))
497 (inputs
498 `(("python-pyxdg" ,python-pyxdg)
499 ("password-store" ,password-store)))
500 (home-page "https://github.com/languitar/pass-git-helper")
501 (synopsis "Git credential helper interfacing with pass")
502 (description "pass-git-helper is a git credential helper which allows to
503 use pass, the standard unix password manager, as the credential backend for
504 your git repositories. This is achieved by explicitly defining mappings
505 between hosts and entries in the password store.")
506 (license license:lgpl3+)))
507
508 (define-public john-the-ripper-jumbo
509 (let ((official-version "1.8.0")
510 (jumbo-version "1"))
511 (package
512 (name "john-the-ripper-jumbo")
513 (version (string-append official-version "-" jumbo-version))
514 (source
515 (origin
516 (method url-fetch)
517 (uri (string-append "http://www.openwall.com/john/j/john-"
518 official-version "-jumbo-" jumbo-version ".tar.xz"))
519 (sha256
520 (base32
521 "08q92sfdvkz47rx6qjn7qv57cmlpy7i7rgddapq5384mb413vjds"))
522 (patches
523 (list (origin
524 (method url-fetch)
525 (uri (string-append "https://github.com/magnumripper/"
526 "JohnTheRipper/commit/"
527 "e2e868db3e153b3f959e119a51703d4afb99c624.patch"))
528 (file-name "john-the-ripper-jumbo-gcc5-inline.patch")
529 (sha256
530 (base32
531 "1shvcf1y2097115mxhzdkm64dr106a8zr6pqjqyh171q5ng5vfra")))
532 (origin
533 (method url-fetch)
534 (uri (string-append "https://github.com/magnumripper/"
535 "JohnTheRipper/commit/"
536 "480e95b0e449863be3e1a5b0bc634a67df28b618.patch"))
537 (file-name "john-the-ripper-jumbo-non-x86.patch")
538 (sha256
539 (base32
540 "1ffd9dvhk0sb6ss8dv5yalh01lz30i7rilqilf2xv68gax2hyjqx")))))))
541 (build-system gnu-build-system)
542 (inputs
543 `(("gmp" ,gmp)
544 ("krb5" ,mit-krb5)
545 ("libpcap" ,libpcap)
546 ("nss" ,nss)
547 ("openssl" ,openssl)
548 ("zlib" ,zlib)))
549 (arguments
550 `(#:configure-flags
551 (list (string-append
552 "CFLAGS=-O2 -g "
553 "-DJOHN_SYSTEMWIDE=1 "
554 "-DJOHN_SYSTEMWIDE_EXEC='\"" %output "/libexec/john\"' "
555 "-DJOHN_SYSTEMWIDE_HOME='\"" %output "/share/john\"'")
556 ;; For now, do not test for instruction set in configure, and
557 ;; do not pass '-march=native' to gcc:
558 "--disable-native-tests"
559 "--disable-native-macro")
560 #:tests? #f ;tests try to create '.john' in the build user's $HOME
561 #:phases
562 (modify-phases %standard-phases
563 (add-before 'configure 'chdir-src
564 (lambda _ (chdir "src")))
565 (replace 'install
566 (lambda _
567 (let ((bindir (string-append %output "/bin"))
568 (docdir (string-append %output "/share/doc/john"))
569 (execdir (string-append %output "/libexec/john"))
570 (homedir (string-append %output "/share/john"))
571 (install-file-to (lambda (dir)
572 (lambda (f) (install-file f dir))))
573 (symlink? (lambda (_ s) (eq? (stat:type s) 'symlink))))
574 (with-directory-excursion "../run"
575 (for-each (install-file-to execdir)
576 (cons* "mailer" "benchmark-unify"
577 (find-files "." ".*\\.(py|rb|pl)")))
578 (for-each (install-file-to homedir)
579 (append (find-files "." "(stats|dictionary.*)")
580 (find-files "." "(.*\\.chr|.*\\.lst)")
581 (find-files "." ".*\\.conf")))
582 (for-each (install-file-to bindir)
583 '("tgtsnarf" "genmkvpwd" "mkvcalcproba"
584 "raw2dyna" "luks2john" "vncpcap2john"
585 "uaf2john" "calc_stat" "wpapcap2john"
586 "cprepair" "relbench" "SIPdump" "john"))
587 (for-each (lambda (f) ;install symlinked aliases
588 (symlink "john"
589 (string-append bindir "/" (basename f))))
590 (find-files "." symlink?)))
591 (copy-recursively "../doc" docdir)
592 #t))))))
593 (home-page "http://www.openwall.com/john/")
594 (synopsis "Password cracker")
595 (description "John the Ripper is a fast password cracker. Its primary
596 purpose is to detect weak Unix passwords. Besides several @code{crypt}
597 password hash types most commonly found on various Unix systems, supported out
598 of the box are Windows LM hashes, plus lots of other hashes and ciphers. This
599 is the community-enhanced, \"jumbo\" version of John the Ripper.")
600 (license license:gpl2+))))