gnu: bdb: Update to 6.2.23.
[jackhill/guix/guix.git] / gnu / packages / kde-frameworks.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde-frameworks)
21 #:use-module (guix build-system cmake)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages qt)
28 #:use-module (gnu packages xorg))
29
30 (define kde-frameworks-version "5.21.0")
31
32 (define-public extra-cmake-modules
33 (package
34 (name "extra-cmake-modules")
35 (version kde-frameworks-version)
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "http://download.kde.org/stable/frameworks/"
40 (version-major+minor version) "/"
41 name "-" version ".tar.xz"))
42 (sha256
43 (base32
44 "1kbc5fkcbz9vkg0jpz10vsfgwajlrsmbl0vrbls5qvrdgbgrwlm3"))))
45 ;; The package looks for Qt5LinguistTools provided by Qt, but apparently
46 ;; compiles without it; it might be needed for building the
47 ;; documentation, which requires the additional Sphinx package.
48 ;; To save space, we do not add these inputs.
49 (build-system cmake-build-system)
50 (home-page "https://community.kde.org/Frameworks")
51 (synopsis "CMake module files for common software used by KDE")
52 (description "The Extra CMake Modules package, or ECM, adds to the
53 modules provided by CMake to find common software. In addition, it provides
54 common build settings used in software produced by the KDE community.")
55 (license license:bsd-3)))
56
57 (define-public kwindowsystem
58 (package
59 (name "kwindowsystem")
60 (version kde-frameworks-version)
61 (source
62 (origin
63 (method url-fetch)
64 (uri (string-append "http://download.kde.org/stable/frameworks/"
65 (version-major+minor version) "/"
66 name "-" version ".tar.xz"))
67 (sha256
68 (base32
69 "13lfwpw5a4in0mp5y8d15jg6xhhrka2qmw73wrdzcvj22n6ldzzi"))))
70 (build-system cmake-build-system)
71 (native-inputs
72 `(("pkg-config" ,pkg-config)
73 ("xorg-server" ,xorg-server))) ; for the tests
74 (inputs
75 `(("extra-cmake-modules" ,extra-cmake-modules)
76 ("libxrender" ,libxrender)
77 ("qt" ,qt)
78 ("xcb-utils-keysyms" ,xcb-util-keysyms)))
79 (arguments
80 `(#:tests? #f)) ; FIXME: The first seven tests fail with "Exception".
81 (home-page "https://community.kde.org/Frameworks")
82 (synopsis "KDE access to the windowing system")
83 (description "KWindowSystem provides information about and allows
84 interaction with the windowing system. It provides a high level API, which
85 is windowing system independent and has platform specific
86 implementations. This API is inspired by X11 and thus not all functionality
87 is available on all windowing systems.
88
89 In addition to the high level API, this framework also provides several
90 lower level classes for interaction with the X Windowing System.")
91 ;; Some source files mention lgpl2.0+, but the included license is
92 ;; the lgpl2.1. Some source files are under non-copyleft licenses.
93 (license license:lgpl2.1+)))
94
95 (define-public oxygen-icons
96 (package
97 (name "oxygen-icons")
98 (version kde-frameworks-version)
99 (source
100 (origin
101 (method url-fetch)
102 (uri (string-append "http://download.kde.org/stable/frameworks/"
103 (version-major+minor version) "/"
104 name "5-"version ".tar.xz"))
105 (sha256
106 (base32
107 "00qh1h3xx392hh73zdlknc1j9i2sck9ys74a9ffkf6an4rl0hws5"))))
108 (build-system cmake-build-system)
109 (native-inputs
110 `(("pkg-config" ,pkg-config)))
111 (inputs
112 `(("extra-cmake-modules" ,extra-cmake-modules)
113 ("qt" ,qt)))
114 (home-page "https://community.kde.org/Frameworks")
115 (synopsis "Oxygen provides the standard icon theme for the KDE desktop.")
116 (description "Oxygen icon theme for the KDE desktop")
117 (license license:lgpl3+)))