gnu: Add r-regioner.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages bioconductor)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system r)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages statistics)
27 #:use-module (gnu packages bioinformatics))
28
29 (define-public r-hpar
30 (package
31 (name "r-hpar")
32 (version "1.20.0")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (bioconductor-uri "hpar" version))
37 (sha256
38 (base32
39 "0s5v79mgxdx862v1jrdf5pdap81nz5vjx25ni8s3sl97ldckf6j8"))))
40 (build-system r-build-system)
41 (home-page "https://bioconductor.org/packages/hpar/")
42 (synopsis "Human Protein Atlas in R")
43 (description "This package provides a simple interface to and data from
44 the Human Protein Atlas project.")
45 (license license:artistic2.0)))
46
47 (define-public r-regioner
48 (package
49 (name "r-regioner")
50 (version "1.10.0")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (bioconductor-uri "regioneR" version))
55 (sha256
56 (base32
57 "1vprp3l929hwzmvgskbhawfgnrymwc9n2rxd16rgagnv1dxnjxfp"))))
58 (properties `((upstream-name . "regioneR")))
59 (build-system r-build-system)
60 (propagated-inputs
61 `(("r-memoise" ,r-memoise)
62 ("r-genomicranges" ,r-genomicranges)
63 ("r-bsgenome" ,r-bsgenome)
64 ("r-rtracklayer" ,r-rtracklayer)
65 ("r-genomeinfodb" ,r-genomeinfodb)
66 ("r-iranges" ,r-iranges)))
67 (home-page "https://bioconductor.org/packages/regioneR/")
68 (synopsis "Association analysis of genomic regions")
69 (description "This package offers a statistical framework based on
70 customizable permutation tests to assess the association between genomic
71 region sets and other genomic features.")
72 (license license:artistic2.0)))