gnu: gsl: Fix poly test on i686.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages enlightenment)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bash)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages curl)
28 #:use-module (gnu packages fontutils)
29 #:use-module (gnu packages fribidi)
30 #:use-module (gnu packages game-development)
31 #:use-module (gnu packages gettext)
32 #:use-module (gnu packages ghostscript)
33 #:use-module (gnu packages gl)
34 #:use-module (gnu packages glib)
35 #:use-module (gnu packages gnome)
36 #:use-module (gnu packages gstreamer)
37 #:use-module (gnu packages gtk)
38 #:use-module (gnu packages image)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages lua)
41 #:use-module (gnu packages openssl)
42 #:use-module (gnu packages pdf)
43 #:use-module (gnu packages pulseaudio)
44 #:use-module (gnu packages photo)
45 #:use-module (gnu packages pkg-config)
46 #:use-module (gnu packages valgrind)
47 #:use-module (gnu packages video)
48 #:use-module (gnu packages xorg))
49
50 (define-public efl
51 (package
52 (name "efl")
53 (version "1.13.0")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append
57 "http://download.enlightenment.org/rel/libs/efl/efl-"
58 version ".tar.gz"))
59 (sha256
60 (base32 "0mwkxsfi5masiy6qfmdqy1j15cfz7nz8g8jq2bf3w501rpa9gxvz"))))
61 (build-system gnu-build-system)
62 (native-inputs
63 `(("pkg-config" ,pkg-config)))
64 (inputs
65 `(("alsa-lib" ,alsa-lib)
66 ("compositeproto" ,compositeproto)
67 ("curl" ,curl)
68 ("giflib" ,giflib)
69 ("gstreamer" ,gstreamer)
70 ("gst-plugins-base" ,gst-plugins-base)
71 ("harfbuzz" ,harfbuzz)
72 ("libexif" ,libexif)
73 ("libjpeg" ,libjpeg)
74 ("librsvg" ,librsvg)
75 ("libtiff" ,libtiff)
76 ("libx11" ,libx11)
77 ("libxcomposite" ,libxcomposite)
78 ("libxcursor" ,libxcursor)
79 ("libxdmcp" ,libxdmcp)
80 ("libxext" ,libxext)
81 ("libxi" ,libxi)
82 ("libxkbfile" ,libxkbfile)
83 ("libxinerama" ,libxinerama)
84 ("libxp" ,libxp)
85 ("libxrandr" ,libxrandr)
86 ("libxscrnsaver" ,libxscrnsaver)
87 ("libxtst" ,libxtst)
88 ("mesa" ,mesa)
89 ("printproto" ,printproto)
90 ("scrnsaverproto" ,scrnsaverproto)
91 ("valgrind" ,valgrind)
92 ("xextproto" ,xextproto)
93 ("xinput" ,xinput)
94 ("xpr" ,xpr)
95 ("xproto" ,xproto)))
96 (propagated-inputs
97 ;; All these inputs are in package config files in section
98 ;; Require.private.
99 `(("bullet" ,bullet) ; ephysics.pc
100 ("dbus" ,dbus) ; eldbus.pc
101 ("eudev" ,eudev) ; eeze.pc
102 ("fontconfig" ,fontconfig) ; evas.pc
103 ("freetype" ,freetype) ; evas.pc
104 ("fribidi" ,fribidi) ; evas.pc
105 ("glib" ,glib) ; ecore.pc
106 ("libpng" ,libpng) ; evas.pc, evas-cxx.pc
107 ("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
108 ("luajit" ,luajit) ; evas.pc, edje.pc
109 ("openssl" ,openssl) ; eet.pc, ecore-con.pc
110 ("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
111 ("util-linux" ,util-linux) ; eeze.pc
112 ("zlib" ,zlib))) ; eet.pc
113 (arguments
114 `(#:configure-flags '("--disable-silent-rules")
115 #:phases
116 (alist-cons-before
117 'configure 'patch-config-files
118 (lambda _
119 (substitute* "po/Makefile.in.in"
120 (("/bin/sh") (which "bash"))))
121 %standard-phases)))
122 (home-page "http://www.enlightenment.org")
123 (synopsis "Enlightenment Foundation Libraries")
124 (description
125 "Enlightenment Foundation Libraries is a set of libraries developed
126 for Enlightenment. Libraries covers data serialization, wide support for
127 graphics rendering, UI layout and themes, interaction with OS, access to
128 removable devices or support for multimedia.")
129 (license (list license:bsd-2 license:lgpl2.1 license:zlib)))) ; different parts under different licenses
130
131 (define-public elementary
132 (package
133 (name "elementary")
134 (version "1.13.0")
135 (source (origin
136 (method url-fetch)
137 (uri
138 (string-append
139 "http://download.enlightenment.org/rel/libs/elementary/elementary-"
140 version ".tar.gz"))
141 (sha256
142 (base32 "133p4yaynmy37yhk2gxwlc8a2n2wy7cbh4rd7nsnl5929wqb9waj"))))
143 (build-system gnu-build-system)
144 (native-inputs
145 `(("pkg-config" ,pkg-config)))
146 (propagated-inputs
147 `(("efl" ,efl))) ; elementary.pc, elementary-cxx.pc
148 (home-page "http://www.enlightenment.org")
149 (synopsis "Widget library of Enlightenment world")
150 (description
151 "Elementary is a widget library/toolkit, part of the Enlightenment
152 Foundation Libraries. It is build upon Edje and Evas libraries and uses
153 full capabilities of EFL.")
154 (license license:lgpl2.1)))
155
156 (define-public evas-generic-loaders
157 (package
158 (name "evas-generic-loaders")
159 (version "1.13.2")
160 (source (origin
161 (method url-fetch)
162 (uri
163 (string-append
164 "https://download.enlightenment.org/rel/libs/"
165 "evas_generic_loaders/evas_generic_loaders-"
166 version ".tar.xz"))
167 (sha256
168 (base32 "1z5vjabs3psvqs3251mpyl1wgbdv1grn30yf682vamdqc5ckfa69"))))
169 (build-system gnu-build-system)
170 (native-inputs
171 `(("pkg-config" ,pkg-config)))
172 (inputs
173 `(("efl" ,efl)
174 ("gstreamer" ,gstreamer)
175 ("gst-plugins-base" ,gst-plugins-base)
176 ("librsvg" ,librsvg)
177 ("libspectre" ,libspectre)
178 ("poppler" ,poppler)))
179 (home-page "http://www.enlightenment.org")
180 (synopsis "Plugins for integration of various file types into Evas")
181 (description
182 "Evas-generic-loaders is a collection of interfaces to outside libraries
183 and applications allowing to natively open pictures, documents and media
184 files in Evas (EFL canvas library).")
185 (license license:gpl2+)))
186
187 (define-public emotion-generic-players
188 (package
189 (name "emotion-generic-players")
190 (version "1.13.0")
191 (source (origin
192 (method url-fetch)
193 (uri
194 (string-append
195 "http://download.enlightenment.org/rel/libs/emotion_generic_players/emotion_generic_players-"
196 version ".tar.gz"))
197 (sha256
198 (base32 "0gin3cjhfj75v0gjsvv7harbj4fs4r7r1sfi74ncxzna71nrd8r3"))))
199 (build-system gnu-build-system)
200 (native-inputs
201 `(("pkg-config" ,pkg-config)))
202 (inputs
203 `(("efl" ,efl)
204 ("vlc" ,vlc)))
205 (home-page "http://www.enlightenment.org")
206 (synopsis "Plugins for integrating media players in EFL based applications")
207 (description
208 "Emotion-generic-players is a collection of interfaces to outside libraries
209 and applications allowing to natively play video files through Emotion.
210 The only supported now is VLC.")
211 (license license:bsd-2)))
212
213 (define-public terminology
214 (package
215 (name "terminology")
216 (version "0.8.0")
217 (source (origin
218 (method url-fetch)
219 (uri
220 (string-append
221 "http://download.enlightenment.org/rel/apps/terminology/terminology-"
222 version ".tar.gz"))
223 (sha256
224 (base32 "0a767ixackzmhb2awrhjy7q6vsivsd54wc434i617xiw095x843s"))))
225 (build-system gnu-build-system)
226 (native-inputs
227 `(("pkg-config" ,pkg-config)))
228 (inputs
229 `(("efl" ,efl)
230 ("elementary" ,elementary)))
231 (home-page "http://www.enlightenment.org")
232 (synopsis "Powerful terminal emulator based on EFL")
233 (description
234 "Terminology is fast and feature rich terminal emulator. It is solely
235 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
236 URL and local path detection, themes, popup based content viewer for non-text
237 contents and more.")
238 (license license:bsd-2)))
239
240 (define-public enlightenment
241 (package
242 (name "enlightenment")
243 (version "0.19.4")
244 (source (origin
245 (method url-fetch)
246 (uri
247 (string-append
248 "http://download.enlightenment.org/rel/apps/enlightenment/enlightenment-"
249 version ".tar.gz"))
250 (sha256
251 (base32 "01pg3ng4m3vmwzzivlssdmvhf72bsvcmm3xwf45849cibllaib8v"))))
252 (build-system gnu-build-system)
253 (native-inputs
254 `(("pkg-config" ,pkg-config)))
255 (inputs
256 `(("alsa-lib" ,alsa-lib)
257 ("dbus" ,dbus)
258 ("freetype" ,freetype)
259 ("gettext" ,gnu-gettext)
260 ("libxcb" ,libxcb)
261 ("libxext" ,libxext)
262 ("linux-pam" ,linux-pam)
263 ("xcb-util-keysyms" ,xcb-util-keysyms)))
264 (propagated-inputs
265 ;; both these inputs are present in pkgconfig file in Require section
266 `(("efl" ,efl) ; enlightenment.pc
267 ("elementary" ,elementary))) ; enlightenment.pc
268 (home-page "http://www.enlightenment.org")
269 (synopsis "Lightweight desktop environment")
270 (description
271 "Enlightenment is resource friendly desktop environment with integrated
272 file manager, wide range of configuration options, plugin system allowing to
273 unload unused functionality, with support for touchscreen and suitable for
274 embedded systems.")
275 (license license:bsd-2)))