gnu: Add Rust 1.45.
[jackhill/guix/guix.git] / gnu / packages / patches / rust-1.45-linker-locale.patch
1 Patch will be included upstream in 1.47: https://github.com/rust-lang/rust/pull/74416
2 diff --git a/src/librustc_codegen_ssa/back/linker.rs b/src/librustc_codegen_ssa/back/linker.rs
3 index e64aafa599f..12575ac4358 100644
4 --- a/src/librustc_codegen_ssa/back/linker.rs
5 +++ b/src/librustc_codegen_ssa/back/linker.rs
6 @@ -28,7 +28,7 @@ use rustc_target::spec::{LinkOutputKind, LinkerFlavor, LldFlavor};
7 pub fn disable_localization(linker: &mut Command) {
8 // No harm in setting both env vars simultaneously.
9 // Unix-style linkers.
10 - linker.env("LC_ALL", "C");
11 + linker.env("LC_ALL", "en_US.UTF-8");
12 // MSVC's `link.exe`.
13 linker.env("VSLANG", "1033");
14 }