gnu: Update packages to use 'non-copyleft' instead of 'bsd-style'.
[jackhill/guix/guix.git] / gnu / packages / xiph.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
4 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
5 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
6 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages xiph)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages curl)
28 #:use-module (gnu packages doxygen)
29 #:use-module (gnu packages image)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages python)
32 #:use-module (gnu packages linux)
33 #:use-module (gnu packages pulseaudio)
34 #:use-module ((guix licenses) #:prefix license:)
35 #:use-module (guix packages)
36 #:use-module (guix download)
37 #:use-module (guix build-system gnu)
38 #:export (libogg
39 libvorbis
40 libtheora
41 speex
42 ao
43 flac
44 libkate
45 vorbis-tools
46 opus
47 opus-tools))
48
49 (define libogg
50 (package
51 (name "libogg")
52 (version "1.3.2")
53 (source (origin
54 (method url-fetch)
55 (uri (string-append "http://downloads.xiph.org/releases/ogg/libogg-"
56 version ".tar.xz"))
57 (sha256
58 (base32
59 "16z74q422jmprhyvy7c9x909li8cqzmvzyr8cgbm52xcsp6pqs1z"))))
60 (build-system gnu-build-system)
61 (synopsis "Library for manipulating the ogg multimedia format")
62 (description
63 "The libogg library allows to manipulate the ogg multimedia container
64 format, which encapsulates raw compressed data and allows the interleaving of
65 audio and video data. In addition to encapsulation and interleaving of
66 multiple data streams, ogg provides packet framing, error detection, and
67 periodic timestamps for seeking.")
68 (license (license:non-copyleft "file://COPYING"
69 "See COPYING in the distribution."))
70 (home-page "http://xiph.org/ogg/")))
71
72 (define libvorbis
73 (package
74 (name "libvorbis")
75 (version "1.3.5")
76 (source (origin
77 (method url-fetch)
78 (uri (string-append "http://downloads.xiph.org/releases/vorbis/"
79 "libvorbis-" version ".tar.xz"))
80 (sha256
81 (base32
82 "1lg1n3a6r41492r7in0fpvzc7909mc5ir9z0gd3qh2pz4yalmyal"))))
83 (build-system gnu-build-system)
84 (propagated-inputs `(("libogg" ,libogg)))
85 (arguments `(#:configure-flags '("LDFLAGS=-lm")
86 #:parallel-tests? #f))
87 (synopsis "Library implementing the vorbis audio format")
88 (description
89 "The libvorbis library implements the ogg vorbis audio format,
90 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
91 compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit,
92 polyphonic) audio and music at fixed and variable bitrates from 16 to
93 128 kbps/channel.")
94 (license (license:non-copyleft "file://COPYING"
95 "See COPYING in the distribution."))
96 (home-page "http://xiph.org/vorbis/")))
97
98 (define libtheora
99 (package
100 (name "libtheora")
101 (version "1.1.1")
102 (source (origin
103 (method url-fetch)
104 (uri (string-append "http://downloads.xiph.org/releases/theora/"
105 "libtheora-" version ".tar.xz"))
106 (sha256
107 (base32
108 "0q8wark9ribij57dciym5vdikg2464p8q2mgqvfb78ksjh4s8vgk"))
109 (patches (list (search-patch "libtheora-config-guess.patch")))))
110 (build-system gnu-build-system)
111 (inputs `(("libvorbis" ,libvorbis)))
112 ;; The .pc files refer to libogg.
113 (propagated-inputs `(("libogg" ,libogg)))
114 (synopsis "Library implementing the Theora video format")
115 (description
116 "The libtheora library implements the ogg theora video format,
117 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
118 compressed video format.")
119 (license license:bsd-3)
120 (home-page "http://xiph.org/theora/")))
121
122 (define speex
123 (package
124 (name "speex")
125 (version "1.2rc1")
126 (source
127 (origin
128 (method url-fetch)
129 (uri (string-append "http://downloads.xiph.org/releases/speex/speex-"
130 version ".tar.gz"))
131 (sha256
132 (base32
133 "19mpkhbz3s08snvndn0h1dk2j139max6b0rr86nnsjmxazf30brl"))))
134 (build-system gnu-build-system)
135 (inputs `(("libogg" ,libogg)))
136 (home-page "https://gnu.org/software/speex")
137 (synopsis "Library for patent-free audio compression format")
138 (description
139 "GNU Speex is a patent-free audio compression codec specially designed
140 for speech. It is well-adapted to internet applications, such as VoIP. It
141 features compression of different bands in the same bitstream, intensity
142 stereo encoding, and voice activity detection.")
143 ;; 'src/getopt.c' is under LGPLv2+
144 (license (license:non-copyleft "file://COPYING"
145 "See COPYING in the distribution."))))
146
147 (define ao
148 (package
149 (name "ao")
150 (version "1.1.0")
151 (source
152 (origin
153 (method url-fetch)
154 (uri (string-append "http://downloads.xiph.org/releases/ao/libao-"
155 version ".tar.gz"))
156 (sha256
157 (base32
158 "1m0v2y6bhr4iwsgdkc7b3y0qgpvpv1ifbxsy8n8ahsvjn6wmppi9"))))
159 (build-system gnu-build-system)
160 ;; FIXME: Add further backends, see the summary printed after configure.
161 ;; XXX: Should back-ends be pushed to different outputs? For instance,
162 ;; "out" would include only the ALSA back-end, while "pulse" would
163 ;; contain 'lib/ao/plugins-4/libpulse.*'.
164 (inputs `(("pkg-config" ,pkg-config)
165 ("alsa-lib" ,alsa-lib)
166 ("pulseaudio" ,pulseaudio)))
167 (synopsis "Cross platform audio library")
168 (description
169 "Libao is a cross-platform audio library that allows programs to
170 output audio using a simple API on a wide variety of platforms.
171 It currently supports:
172 Null output (handy for testing without a sound device),
173 WAV files,
174 AU files,
175 RAW files,
176 OSS (Open Sound System, used on Linux and FreeBSD),
177 ALSA (Advanced Linux Sound Architecture),
178 aRts (Analog RealTime Synth, used by KDE),
179 PulseAudio (next generation GNOME sound server),
180 esd (EsounD or Enlightened Sound Daemon),
181 Mac OS X,
182 Windows (98 and later),
183 AIX,
184 Sun/NetBSD/OpenBSD,
185 IRIX,
186 NAS (Network Audio Server),
187 RoarAudio (Modern, multi-OS, networked Sound System),
188 OpenBSD's sndio.")
189 (license license:gpl2+)
190 (home-page "http://www.xiph.org/ao/")))
191
192 (define flac
193 (package
194 (name "flac")
195 (version "1.3.1")
196 (source (origin
197 (method url-fetch)
198 (uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
199 version ".tar.xz"))
200 (sha256
201 (base32
202 "0v65w7ph6ldwp5a8fbhp0a3w8f737ck468fr7yb7sxmskl4w0ws7"))))
203 (build-system gnu-build-system)
204 (arguments
205 `(#:parallel-tests? #f))
206 ;; FIXME: configure also looks for xmms, input could be added once it exists
207 (propagated-inputs `(("libogg" ,libogg))) ; required by flac.pc
208 (synopsis "Free lossless audio codec")
209 (description
210 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
211 meaning that audio is compressed in FLAC without any loss in quality.")
212 (license (license:non-copyleft "file://COPYING"
213 "See COPYING in the distribution.")) ; and LGPL and GPL
214 (home-page "http://xiph.org/flac/")))
215
216 (define libkate
217 (package
218 (name "libkate")
219 (version "0.4.1")
220 (source (origin
221 (method url-fetch)
222 (uri (string-append "http://libkate.googlecode.com/files/libkate-"
223 version ".tar.gz"))
224 (sha256
225 (base32
226 "0s3vr2nxfxlf1k75iqpp4l78yf4gil3f0v778kvlngbchvaq23n4"))))
227 (build-system gnu-build-system)
228 (native-inputs `(("doxygen" ,doxygen)
229 ("pkg-config" ,pkg-config)))
230 ;; FIXME: Add optional input liboggz
231 (inputs `(("bison" ,bison)
232 ("libogg" ,libogg)
233 ("libpng" ,libpng)
234 ("python" ,python-wrapper)
235 ("zlib" ,zlib)))
236 (synopsis "Karaoke and text codec for embedding in ogg")
237 (description
238 "Kate is an overlay codec, originally designed for karaoke and text,
239 that can be multiplixed in Ogg. Text and images can be carried by a Kate
240 stream, and animated. Most of the time, this would be multiplexed with
241 audio/video to carry subtitles, song lyrics (with or without karaoke data),
242 etc., but doesn't have to be.
243
244 Series of curves (splines, segments, etc.) may be attached to various
245 properties (text position, font size, etc.) to create animated overlays.
246 This allows scrolling or fading text to be defined. This can even be used
247 to draw arbitrary shapes, so hand drawing can also be represented by a
248 Kate stream.")
249 (license license:bsd-3)
250 (home-page "http://code.google.com/p/libkate/")))
251
252 (define vorbis-tools
253 (package
254 (name "vorbis-tools")
255 (version "1.4.0")
256 (source (origin
257 (method url-fetch)
258 (uri (string-append "http://downloads.xiph.org/releases/vorbis/"
259 "vorbis-tools-" version ".tar.gz"))
260 (sha256
261 (base32
262 "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))))
263 (build-system gnu-build-system)
264 (inputs `(("ao" ,ao)
265 ("curl" ,curl)
266 ("flac" ,flac)
267 ("libkate" ,libkate)
268 ("libogg" ,libogg)
269 ("libvorbis" ,libvorbis)
270 ("speex" ,speex)))
271 (native-inputs `(("pkg-config" ,pkg-config)))
272 (synopsis "Ogg vorbis tools")
273 (description
274 "Ogg vorbis is a non-proprietary, patent-and-royalty-free,
275 general-purpose compressed audio format.
276
277 The package vorbis-tools contains
278 ogg123, an ogg vorbis command line audio player;
279 oggenc, the ogg vorbis encoder;
280 oggdec, a simple, portable command line decoder (to wav and raw);
281 ogginfo, to obtain information (tags, bitrate, length, etc.) about
282 an ogg vorbis file.")
283 (license license:gpl2)
284 (home-page "http://xiph.org/vorbis/")))
285
286 (define opus
287 (package
288 (name "opus")
289 (version "1.1")
290 (source (origin
291 (method url-fetch)
292 (uri (string-append
293 "http://downloads.xiph.org/releases/opus/opus-" version
294 ".tar.gz"))
295 (sha256
296 (base32
297 "158xprn2086arvdib3vbbygz7z6jqkw2nci7nlywzzwallap0wmr"))))
298 (build-system gnu-build-system)
299 (synopsis "Versatile audio codec")
300 (description
301 "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
302 is unmatched for interactive speech and music transmission over the Internet,
303 but is also intended for storage and streaming applications. It is
304 standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
305 incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
306 (license license:bsd-3)
307 (home-page "http://www.opus-codec.org")))
308
309 (define opus-tools
310 (package
311 (name "opus-tools")
312 (version "0.1.9")
313 (source (origin
314 (method url-fetch)
315 (uri (string-append
316 "ftp://ftp.mozilla.org/pub/mozilla.org/opus/opus-tools-"
317 version ".tar.gz"))
318 (sha256
319 (base32
320 "0fk4nknvl111k89j5yckmyrh6b2wvgyhrqfncp7rig3zikbkv1xi"))))
321 (build-system gnu-build-system)
322 (arguments
323 ;; The package developers misuse pkg-config such that it doesn't work
324 ;; when cross compiling. Therefore we avoid it completly and set the
325 ;; necessary flags ourselves.
326 `(#:configure-flags (list (string-append "CFLAGS=-I"
327 (assoc-ref %build-inputs "libogg")
328 "/include -I"
329 (assoc-ref %build-inputs "opus")
330 "/include/opus"))))
331 (inputs `(("libogg" ,libogg)
332 ("opus" ,opus)
333 ("flac" ,flac)))
334 (synopsis "Command line utilities to encode, inspect, and decode .opus
335 files")
336 (description "Opus is a royalty-free, highly versatile audio codec.
337 Opus-tools provide command line utilities for creating, inspecting and
338 decoding .opus files")
339 (license license:bsd-3)
340 (home-page "http://www.opus-codec.org")))