gnu: nnn: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / speech.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
4 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages speech)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages audio)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages gcc)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages pulseaudio)
34 #:use-module (gnu packages python)
35 #:use-module (gnu packages textutils))
36
37 (define-public mitlm
38 (package
39 (name "mitlm")
40 (version "0.4.2")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "https://github.com/mitlm/mitlm/releases/"
44 "download/v" version "/"
45 name "-" version ".tar.xz"))
46 (sha256
47 (base32
48 "09fv4fcpmw9g1j0zml0k5kk1lgjw2spr8gn51llbkaaph6v8d62a"))))
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("gfortran" ,gfortran)))
52 (synopsis "The MIT Language Modeling toolkit")
53 (description "The MIT Language Modeling (MITLM) toolkit is a set of
54 tools designed for the efficient estimation of statistical n-gram language
55 models involving iterative parameter estimation. It achieves much of its
56 efficiency through the use of a compact vector representation of n-grams.")
57 (home-page "https://github.com/mitlm/mitlm")
58 (license license:expat)))
59
60 (define-public speech-dispatcher
61 (package
62 (name "speech-dispatcher")
63 (version "0.8.5")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append "https://devel.freebsoft.org/pub/"
67 "projects/speechd/speech-dispatcher-"
68 version ".tar.gz"))
69 (sha256
70 (base32
71 "18jlxnhlahyi6njc6l6576hfvmzivjjgfjyd2n7vvrvx9inphjrb"))))
72 (build-system gnu-build-system)
73 (native-inputs
74 `(("intltool" ,intltool)
75 ("pkg-config" ,pkg-config)))
76 (inputs
77 `(("dotconf" ,dotconf)
78 ("espeak" ,espeak)
79 ("glib" ,glib)
80 ("libltdl" ,libltdl)
81 ("libsndfile" ,libsndfile)
82 ("pulseaudio" ,pulseaudio)
83 ("python" ,python)))
84 (synopsis "Common interface to speech synthesizers")
85 (description "The Speech Dispatcher project provides a high-level
86 device independent layer for access to speech synthesis through a simple,
87 stable and well documented interface.")
88 (home-page "https://devel.freebsoft.org/speechd")
89 ;; The software is distributed under GPL2+, but includes a number
90 ;; of files covered by other licenses.
91 (license (list license:gpl2+
92 license:fdl1.2+ ; Most files in doc/ are dual gpl2+/fdl1.2+.
93 license:lgpl2.1+
94 license:gpl2
95 (license:non-copyleft
96 ;; festival_client.{c,h} carries an expat-style license.
97 "See src/modules/festival_client.c in the distribution.")
98 license:gpl3+)))) ; doc/texinfo.tex -- with TeX exception.
99
100 (define-public sonic
101 (package
102 (name "sonic")
103 (version "0.2.0")
104 (source (origin
105 (method url-fetch)
106 (uri (string-append "https://github.com/waywardgeek/sonic/archive/"
107 "release-" version ".tar.gz"))
108 (file-name (string-append name "-" version ".tar.gz"))
109 (sha256
110 (base32
111 "11a0q9wkgbb9ymf52v7dvybfhj8hprgr67zs1xcng143fvjpr0n7"))))
112 (build-system gnu-build-system)
113 (arguments
114 `(#:tests? #f ; No test suite.
115 #:make-flags
116 (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
117 #:phases
118 (modify-phases %standard-phases
119 (delete 'configure)))) ; No ./configure script.
120 (synopsis "Speed up or slow down speech")
121 (description "Sonic implements a simple algorithm for speeding up or slowing
122 down speech. However, it's optimized for speed ups of over 2X, unlike previous
123 algorithms for changing speech rate. Sonic is a C library designed to be easily
124 integrated into streaming voice applications such as text-to-speech (TTS) back
125 ends.
126
127 The primary motivation behind Sonic is to enable the blind and visually impaired
128 to improve their productivity with speech engines, like eSpeak. Sonic can also
129 be used by the sighted.")
130 (home-page "https://github.com/waywardgeek/sonic")
131 (license license:asl2.0)))