gnu: nnn: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / hexedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
3 ;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages hexedit)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages ncurses)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module (guix build-system gnu))
31
32 (define-public hexedit
33 (package
34 (name "hexedit")
35 (version "1.4.2")
36 (source (origin
37 (method git-fetch)
38 (uri (git-reference
39 (url "https://github.com/pixel/hexedit.git")
40 (commit version)))
41 (file-name (git-file-name name version))
42 (sha256
43 (base32
44 "1xsxa5mip892jkvz9jshj73y6c7j3mgp8y393ciihqlyf2nmfs67"))))
45 (build-system gnu-build-system)
46 (arguments '(#:tests? #f)) ; no check target
47 (native-inputs
48 `(("autoconf" ,autoconf)
49 ("automake" ,automake)))
50 (inputs
51 `(("ncurses" ,ncurses)))
52 (synopsis "View and edit files or devices in hexadecimal or ASCII")
53 (description "hexedit shows a file both in ASCII and in hexadecimal. The
54 file can be a device as the file is read a piece at a time. You can modify
55 the file and search through it.")
56 (home-page "http://rigaux.org/hexedit.html")
57 (license license:gpl2+)))
58
59 (define-public ht
60 (package
61 (name "ht")
62 (version "2.1.0")
63 (source (origin
64 (method url-fetch)
65 (uri (string-append
66 "https://sourceforge.net/projects/hte/files/ht-source/"
67 name "-" version ".tar.bz2"))
68 (sha256
69 (base32
70 "0w2xnw3z9ws9qrdpb80q55h6ynhh3aziixcfn45x91bzrbifix9i"))))
71 (build-system gnu-build-system)
72 (inputs
73 `(("lzo" ,lzo)
74 ("ncurses" ,ncurses)))
75 (synopsis "Viewer, editor, and analyzer for executable binaries")
76 (description
77 "ht is a terminal-based program to view, edit, and analyze any file, but
78 with a special focus on executable binaries. Its goal is to combine the
79 low-level functionality of a debugger with the usability of an @dfn{Integrated
80 Development Environment} (IDE).")
81 (home-page "http://hte.sourceforge.net/")
82 (license license:gpl2)))