gnu: nnn: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / calcurse.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages calcurse)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages ncurses))
29
30 (define-public calcurse
31 (package
32 (name "calcurse")
33 (version "4.3.0")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "https://calcurse.org/files/calcurse-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "16jzg0nasnxdlz23i121x41pq5kbxmjzk52c5d863rg117fc7v1i"))))
42 (build-system gnu-build-system)
43 (inputs `(("ncurses" ,ncurses)))
44 (native-inputs `(("tzdata" ,tzdata-for-tests)))
45 (arguments
46 ;; The ical tests all want to create a ".calcurse" directory, and may
47 ;; fail with "cannot create directory '.calcurse': File exists" if run
48 ;; concurently.
49 `(#:parallel-tests? #f
50 ;; Since this tzdata is only used for tests and not referenced by the
51 ;; built package, used the "fixed" obsolete version of tzdata and ensure
52 ;; it does not sneak in to the closure.
53 #:disallowed-references (,tzdata-for-tests)
54 #:phases (modify-phases %standard-phases
55 (add-before 'check 'check-setup
56 (lambda* (#:key inputs #:allow-other-keys)
57 (setenv "TZDIR" ;for test/ical-007.sh
58 (string-append (assoc-ref inputs "tzdata")
59 "/share/zoneinfo")))))))
60 (home-page "https://www.calcurse.org")
61 (synopsis "Text-based calendar and scheduling")
62 (description
63 "Calcurse is a text-based calendar and scheduling application. It helps
64 keep track of events, appointments and everyday tasks. A configurable
65 notification system reminds user of upcoming deadlines, and the curses based
66 interface can be customized to suit user needs. All of the commands are
67 documented within an online help system.")
68 (license bsd-2)))