gnu: Add lftp.
[jackhill/guix/guix.git] / gnu / packages / ftp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ftp)
20 #:use-module ((guix licenses) #:select (gpl3+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages ncurses)
25 #:use-module (gnu packages readline)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages gnutls)
28 #:use-module (gnu packages compression))
29
30 (define-public lftp
31 (package
32 (name "lftp")
33 (version "4.4.15")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "http://lftp.yar.ru/ftp/lftp-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "0s38vc2ij869dwx3i1c7sk96mqv0hknf3cqf86av59rqnix0px3m"))))
41 (build-system gnu-build-system)
42 (native-inputs
43 `(("pkg-config" ,pkg-config)))
44 (inputs
45 `(("zlib" ,zlib)
46 ("readline" ,readline)
47 ("gnutls" ,gnutls)))
48 (home-page "http://lftp.yar.ru/")
49 (synopsis "Command-line file transfer program")
50 (description
51 "LFTP is a sophisticated FTP/HTTP client, and a file transfer program
52 supporting a number of network protocols. Like Bash, it has job control and
53 uses the Readline library for input. It has bookmarks, a built-in mirror
54 command, and can transfer several files in parallel. It was designed with
55 reliability in mind.")
56 (license gpl3+)))