gnu: Add baloo-widgets.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages kde)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system qt)
30 #:use-module (guix deprecation)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix utils)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages algebra)
38 #:use-module (gnu packages apr)
39 #:use-module (gnu packages audio)
40 #:use-module (gnu packages boost)
41 #:use-module (gnu packages code)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages curl)
44 #:use-module (gnu packages documentation)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages ghostscript)
47 #:use-module (gnu packages gl)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages graphics)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages kde-frameworks)
52 #:use-module (gnu packages kde-plasma)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages maths)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages qt)
64 #:use-module (gnu packages version-control)
65 #:use-module (gnu packages video)
66 #:use-module (gnu packages xdisorg)
67 #:use-module (gnu packages xml)
68 #:use-module (gnu packages xorg))
69
70 (define-public baloo-widgets
71 (package
72 (name "baloo-widgets")
73 (version "19.08.3")
74 (source
75 (origin
76 (method url-fetch)
77 (uri (string-append "mirror://kde/stable/applications/" version
78 "/src/baloo-widgets-" version ".tar.xz"))
79 (sha256
80 (base32 "0bba8dgxd7rcjji809kwnw78hl1nb5ssh2ir4k4b0wvx395jifgd"))))
81 (build-system qt-build-system)
82 (native-inputs
83 `(("extra-cmake-modules" ,extra-cmake-modules)))
84 (inputs
85 `(("baloo" ,baloo)
86 ("kconfig" ,kconfig)
87 ("ki18n" ,ki18n)
88 ("kio" ,kio)
89 ("qtbase" ,qtbase)))
90 (arguments
91 `(#:phases
92 (modify-phases %standard-phases
93 (add-before 'check 'check-setup
94 (lambda _
95 (setenv "QT_QPA_PLATFORM" "offscreen")
96 #t)))))
97 (home-page "https://community.kde.org/Baloo")
98 (synopsis "Wigets for use with Baloo")
99 (description "Baloo is a framework for searching and managing metadata.
100 This package contains GUI widgets for baloo.")
101 (license license:lgpl2.0+)))
102
103 (define-public grantleetheme
104 (package
105 (name "grantleetheme")
106 (version "19.08.3")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append "mirror://kde/stable/applications/" version
111 "/src/grantleetheme-" version ".tar.xz"))
112 (sha256
113 (base32 "0j77q1yyfmggzgkqgcw2xr0v9xg3h5cdhh8jry8h2llw75ahy6xb"))
114 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
115 (build-system qt-build-system)
116 (native-inputs
117 `(("extra-cmake-modules" ,extra-cmake-modules)
118 ("libxml2" ,libxml2))) ;; xmllint required for tests
119 (inputs
120 `(("grantlee" ,grantlee)
121 ("ki18n" ,ki18n)
122 ("kiconthemes" ,kiconthemes)
123 ("knewstuff" ,knewstuff)
124 ("qtbase" ,qtbase)))
125 (home-page "https://cgit.kde.org/grantleetheme.git")
126 (synopsis "Library providing Grantlee theme support")
127 (description "This library provides Grantlee theme support.")
128 (license ;; LGPL for libraries, FDL for documentation
129 (list license:lgpl2.0+ license:fdl1.2+))))
130
131 (define-public kdenlive
132 (let ((version "18.08.1"))
133 (package
134 (name "kdenlive")
135 (version version)
136 (source
137 (origin
138 (method git-fetch)
139 (uri (git-reference
140 (url "git://anongit.kde.org/kdenlive.git")
141 (commit (string-append "v" version))))
142 (file-name (string-append name "-" version "-checkout"))
143 (sha256
144 (base32
145 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
146 (build-system cmake-build-system)
147 (native-inputs
148 `(("extra-cmake-modules" ,extra-cmake-modules)
149 ("qttools" ,qttools)))
150 (propagated-inputs
151 `(("mlt" ,mlt)))
152 (inputs
153 `(("shared-mime-info" ,shared-mime-info)
154 ("frei0r-plugins" ,frei0r-plugins)
155 ("qtbase" ,qtbase)
156 ("qtscript" ,qtscript)
157 ("qtsvg" ,qtsvg)
158 ("kparts" ,kparts)
159 ("knotifications" ,knotifications)
160 ("karchive" ,karchive)
161 ("kdbusaddons" ,kdbusaddons)
162 ("kcrash" ,kcrash)
163 ("kguiaddons" ,kguiaddons)
164 ("knewstuff" ,knewstuff)
165 ("knotifyconfig" ,knotifyconfig)
166 ("kfilemetadata" ,kfilemetadata)
167 ("kdoctools" ,kdoctools)
168 ("kdeclarative" ,kdeclarative)
169 ("qtdeclarative" ,qtdeclarative)
170 ("qtquickcontrols" ,qtquickcontrols)
171 ("kiconthemes" ,kiconthemes)
172 ("qtgraphicaleffects" ,qtgraphicaleffects)
173 ("kplotting" ,kplotting)))
174 (arguments
175 `(#:phases
176 (modify-phases %standard-phases
177 (add-after 'install 'wrap-executable
178 (lambda* (#:key inputs outputs #:allow-other-keys)
179 (let* ((out (assoc-ref outputs "out"))
180 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
181 (qtbase (assoc-ref inputs "qtbase"))
182 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
183 (frei0r (assoc-ref inputs "frei0r-plugins"))
184 (qml "/lib/qt5/qml"))
185 (wrap-program (string-append out "/bin/kdenlive")
186 `("QT_PLUGIN_PATH" ":" prefix
187 ,(map (lambda (label)
188 (string-append (assoc-ref inputs label)
189 "/lib/qt5/plugins/"))
190 '("qtbase" "qtsvg")))
191 `("FREI0R_PATH" ":" =
192 (,(string-append frei0r "/lib/frei0r-1/")))
193 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
194 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
195 `("QML2_IMPORT_PATH" ":" prefix
196 (,(string-append qtquickcontrols qml)
197 ,(string-append qtdeclarative qml)))))
198 #t)))))
199 (home-page "https://kdenlive.org")
200 (synopsis "Non-linear video editor")
201 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
202
203 Non-linear video editing is much more powerful than beginner's (linear)
204 editors, hence it requires a bit more organization before starting. However,
205 it is not reserved to specialists and can be used for small personal
206 projects.")
207 (license license:gpl2+))))
208
209 (define-public kdevelop
210 (package
211 (name "kdevelop")
212 (version "5.4.6")
213 (source
214 (origin
215 (method url-fetch)
216 (uri (string-append "mirror://kde/stable/kdevelop"
217 "/" version "/src/kdevelop-"
218 version ".tar.xz"))
219 (sha256
220 (base32 "01jmrmwbc1hrvq7jdfcc7mxl03q2l6kz57yca2j26xwyvfcfv5sz"))))
221 (build-system qt-build-system)
222 (native-inputs
223 `(("extra-cmake-modules" ,extra-cmake-modules)
224 ("pkg-config" ,pkg-config)
225 ("shared-mime-info" ,shared-mime-info)
226 ("qttools" ,qttools)))
227 (inputs
228 `(("boost" ,boost)
229 ("clang" ,clang)
230 ("grantlee" ,grantlee)
231 ("karchive" ,karchive)
232 ("kcmutils" ,kcmutils)
233 ("kcrash" ,kcrash)
234 ("kdeclarative" ,kdeclarative)
235 ("kdoctools" ,kdoctools)
236 ("kguiaddons" ,kguiaddons)
237 ("ki18n" ,ki18n)
238 ("kiconthemes" ,kiconthemes)
239 ("kio" ,kio) ;; not checked as requirement
240 ("kitemmodels" ,kitemmodels)
241 ("kitemviews" ,kitemviews)
242 ("kjobwidgets" ,kjobwidgets)
243 ("knotifications" ,knotifications)
244 ("knotifyconfig" ,knotifyconfig)
245 ("kparts" ,kparts)
246 ("kservice" ,kservice)
247 ("ktexteditor" ,ktexteditor)
248 ("kwindowsystem" ,kwindowsystem)
249 ("kxmlgui" ,kxmlgui)
250 ("libkomparediff2" ,libkomparediff2)
251 ("oxygen-icons" ,oxygen-icons)
252 ("qtbase" ,qtbase)
253 ("qtdeclarative" ,qtdeclarative)
254 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
255 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
256 ("qtwebkit" ,qtwebkit)
257 ("threadweaver" ,threadweaver)
258
259 ;; recommendes
260 ("astyle" ,astyle)
261 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
262 ("libksysguard" ,libksysguard)
263
264 ;; optional
265 ("apr" ,apr) ; required for subversion support
266 ("apr-util" ,apr-util) ; required for subversion support
267 ("attica" ,attica)
268 ("kconfigwidgets" ,kconfigwidgets)
269 ("knewstuff" ,knewstuff)
270 ("krunner" ,krunner)
271 ;; TODO: OktetaGui, OktetaKastenControllers
272 ("plasma" ,plasma-framework)
273 ;; TODO: purpose
274 ("sonnet" ,sonnet)
275 ("subversion" ,subversion)))
276
277 ;; run-time packages - TODO
278 ;; ClazyStandalone
279 ;; Cppcheck
280 ;; heaptrack
281 ;; heaptrack_gui
282 ;; meson
283 (arguments
284 `(#:tests? #f ;; there are some issues with the test suite
285 #:phases
286 (modify-phases %standard-phases
287 (add-before 'configure 'add-include-path
288 (lambda* (#:key inputs #:allow-other-keys)
289 (substitute* "cmake/modules/FindClang.cmake"
290 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
291 (string-append line " " (assoc-ref inputs "clang") "/lib")))
292 #t)))))
293 (home-page "https://kdevelop.org")
294 (synopsis "IDE for C, C++, Python, Javascript and PHP")
295 (description "The KDevelop IDE provides semantic syntax highlighting, as
296 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
297 JavaScript, Python and PHP. It also integrates with a debugger, different
298 build systems (CMake, QMake, custom Makefiles) and version control
299 software (Git, Subversion, Mercurial, CVS and Bazaar).")
300 (license license:lgpl2.1+)))
301
302 (define-public kdevelop-pg-qt
303 (package
304 (name "kdevelop-pg-qt")
305 (version "2.2.0")
306 (source
307 (origin
308 (method url-fetch)
309 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
310 version ".tar.gz"))
311 (file-name (string-append name "-" version ".tar.gz"))
312 (sha256
313 (base32 "15ja19gg6x7gww4ch12hy585x55ghbkpsiyr8fqiyjk0j6v07hh5"))))
314 (native-inputs
315 `(("extra-cmake-modules" ,extra-cmake-modules)))
316 (inputs
317 `(("qtbase" ,qtbase)))
318 (build-system cmake-build-system)
319 (home-page "https://kde.org")
320 (synopsis "Parser generator library for KDevplatform")
321 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
322 for some KDevelop language plugins (Ruby, PHP, CSS...).")
323 (license license:lgpl2.0+)))
324
325 ;; kdevplatform was merged into kdevelop as of 5.2.x
326 (define-deprecated kdevplatform kdevelop)
327
328 (define-public krita
329 (package
330 (name "krita")
331 (version "4.2.7.1")
332 (source (origin
333 (method url-fetch)
334 (uri (string-append
335 "mirror://kde/stable/krita/" version
336 "/krita-" version ".tar.gz"))
337 (sha256
338 (base32
339 "0gcwq1w09gmx53i2fir73l222p41299wagvhbvsxwrz0v3crzliy"))))
340 (build-system cmake-build-system)
341 (arguments
342 `(#:tests? #f
343 #:configure-flags
344 (list "-DBUILD_TESTING=OFF"
345 (string-append "-DCMAKE_CXX_FLAGS=-I"
346 (assoc-ref %build-inputs "ilmbase")
347 "/include/OpenEXR"))
348 #:phases
349 (modify-phases %standard-phases
350 ;; Ensure that icons are found at runtime.
351 ;; This works around <https://bugs.gnu.org/22138>.
352 (add-after 'install 'wrap-executable
353 (lambda* (#:key inputs outputs #:allow-other-keys)
354 (let ((out (assoc-ref outputs "out"))
355 (qt '("qtbase" "qtsvg")))
356 (wrap-program (string-append out "/bin/krita")
357 `("QT_PLUGIN_PATH" ":" prefix
358 ,(map (lambda (label)
359 (string-append (assoc-ref inputs label)
360 "/lib/qt5/plugins/"))
361 qt)))
362 #t))))))
363 (native-inputs
364 `(("curl" ,curl)
365 ("eigen" ,eigen)
366 ("extra-cmake-modules" ,extra-cmake-modules)
367 ("gettext-minimal" ,gettext-minimal)
368 ("kitemmodels" ,kitemmodels)
369 ("pkg-config" ,pkg-config)
370 ("qwt" ,qwt)
371 ("vc" ,vc)))
372 (inputs
373 `(("boost" ,boost)
374 ("exiv2" ,exiv2)
375 ("fftw" ,fftw)
376 ("gsl" ,gsl)
377 ("ilmbase" ,ilmbase)
378 ("karchive" ,karchive)
379 ("kcompletion" ,kcompletion)
380 ("kconfig" ,kconfig)
381 ("kcoreaddons" ,kcoreaddons)
382 ("kcrash" ,kcrash)
383 ("kguiaddons" ,kguiaddons)
384 ("ki18n" ,ki18n)
385 ("kiconthemes" ,kiconthemes)
386 ("kio" ,kio)
387 ("kitemviews" ,kitemviews)
388 ("kwidgetsaddons" ,kwidgetsaddons)
389 ("kwindowsystem" ,kwindowsystem)
390 ("kxmlgui" ,kxmlgui)
391 ("lcms" ,lcms)
392 ("libjpeg-turbo" ,libjpeg-turbo)
393 ("libpng" ,libpng)
394 ("libraw" ,libraw-0.18)
395 ("libtiff" ,libtiff)
396 ("libx11" ,libx11)
397 ("libxcb" ,libxcb)
398 ("libxi" ,libxi)
399 ("openexr" ,openexr)
400 ("perl" ,perl)
401 ("poppler-qt5" ,poppler-qt5)
402 ("qtbase" ,qtbase)
403 ("qtdeclarative" ,qtdeclarative)
404 ("qtmultimedia" ,qtmultimedia)
405 ("qtsvg" ,qtsvg)
406 ("qtx11extras" ,qtx11extras)
407 ("quazip" ,quazip)
408 ("zlib" ,zlib)))
409 (home-page "https://krita.org")
410 (synopsis "Digital painting application")
411 (description
412 "Krita is a professional painting tool designed for concept artists,
413 illustrators, matte and texture artists, and the VFX industry. Notable
414 features include brush stabilizers, brush engines and wrap-around mode.")
415 (license license:gpl2+)))
416
417 (define-public libkomparediff2
418 (package
419 (name "libkomparediff2")
420 (version "19.08.2")
421 (source
422 (origin
423 (method url-fetch)
424 (uri (string-append "mirror://kde/stable/applications/" version
425 "/src/libkomparediff2-" version ".tar.xz"))
426 (sha256
427 (base32 "1mvihd0xpkl8kryf5dvsfgpbgs9af8c9bzq8mmr74gfsvfb8ywy5"))))
428 (native-inputs
429 `(("extra-cmake-modules" ,extra-cmake-modules)
430 ("pkg-config" ,pkg-config)))
431 (inputs
432 `(("kcodecs" ,kcodecs)
433 ("kconfig" ,kconfig)
434 ("kcoreaddons" ,kcoreaddons)
435 ("ki18n" ,ki18n)
436 ("kio" ,kio)
437 ("kxmlgui" ,kxmlgui)
438 ("qtbase" ,qtbase)))
439 (build-system cmake-build-system)
440 (home-page "https://kde.org")
441 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
442 (description "Libkomparediff2 is a library to work with diffs and patches,
443 used in KDE development tools Kompare and KDevelop.")
444
445 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
446 ;; source archive
447 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
448
449 (define-public qca
450 (package
451 (name "qca")
452 (version "2.2.1")
453 (source
454 (origin
455 (method url-fetch)
456 (uri (string-append "mirror://kde/stable/qca/" version
457 "/qca-" version ".tar.xz"))
458 (sha256
459 (base32
460 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
461 (build-system cmake-build-system)
462 (native-inputs
463 `(("pkg-config" ,pkg-config)))
464 (inputs
465 `(("openssl" ,openssl)
466 ("qtbase" ,qtbase)))
467 (home-page "https://userbase.kde.org/QCA")
468 (synopsis "Libraries for the Qt Cryptographic Architecture")
469 (description "The Qt Cryptographic Architecture (QCA) provides a
470 straightforward and cross-platform API for a range of cryptographic features,
471 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
472 cards.")
473 (license license:lgpl2.1)))
474
475 (define-public kpmcore
476 (package
477 (name "kpmcore")
478 (version "4.0.1")
479 (source (origin
480 (method url-fetch)
481 (uri (string-append
482 "mirror://kde/stable/kpmcore"
483 "/" version "/src/"
484 name "-" version ".tar.xz"))
485 (sha256
486 (base32
487 "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))
488 (patches (search-patches "kpmcore-fix-tests.patch"
489 "kpmcore-remove-broken-test.patch"))))
490 (build-system cmake-build-system)
491 (native-inputs
492 `(("extra-cmake-modules" ,extra-cmake-modules)
493 ("pkg-config" ,pkg-config)))
494 (inputs
495 `(("kauth" ,kauth)
496 ("kcoreaddons" ,kcoreaddons)
497 ("ki18n" ,ki18n)
498 ("kwidgetsaddons" ,kwidgetsaddons)
499 ("qtbase" ,qtbase)
500 ("qca" ,qca)
501 ("util-linux" ,util-linux)))
502 (home-page "https://community.kde.org/Frameworks")
503 (synopsis "Library for managing partitions")
504 (description "Library for managing partitions.")
505 (license license:gpl3+)))
506
507 (define-public snorenotify
508 (package
509 (name "snorenotify")
510 (version "0.7.0")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (string-append "mirror://kde/stable/snorenotify/"
515 version "/src/snorenotify-" version ".tar.xz"))
516 (sha256
517 (base32
518 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
519 (build-system cmake-build-system)
520 (arguments
521 `(#:tests? #f)) ; both tests fail, require display
522 (inputs
523 `(("qtbase" ,qtbase)))
524 (native-inputs
525 `(("extra-cmake-modules" ,extra-cmake-modules)
526 ("qttools" ,qttools)))
527 (home-page "https://techbase.kde.org/Projects/Snorenotify")
528 (synopsis "Qt notification framework")
529 (description "Snorenotify is a multi platform Qt notification framework.
530 Using a plugin system it is possible to create notifications with many
531 different notification systems.")
532 (license license:lgpl3)))
533
534 (define-public kdeconnect
535 (package
536 (name "kdeconnect")
537 (version "1.3.5")
538 (source
539 (origin
540 (method url-fetch)
541 (uri (string-append "mirror://kde/stable/kdeconnect/"
542 version "/kdeconnect-kde-"
543 version ".tar.xz"))
544 (sha256
545 (base32
546 "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
547 (build-system qt-build-system)
548 (arguments
549 `(#:configure-flags '("-DBUILD_TESTING=ON")
550 #:tests? #f)) ; tests fail hard in our build environment
551 (native-inputs
552 `(("extra-cmake-modules" ,extra-cmake-modules)
553 ("kdoctools" ,kdoctools)
554 ("libxtst" ,libxtst)
555 ("pkg-config" ,pkg-config)
556 ("python" ,python-wrapper)))
557 (inputs
558 `(("kcmutils" ,kcmutils)
559 ("kconfigwidgets" ,kconfigwidgets)
560 ("kdbusaddons" ,kdbusaddons)
561 ("ki18n" ,ki18n)
562 ("kiconthemes" ,kiconthemes)
563 ("kio" ,kio)
564 ("knotifications" ,knotifications)
565 ("kwayland" ,kwayland)
566 ("libfakekey" ,libfakekey)
567 ("qca" ,qca)
568 ("qtbase" ,qtbase)
569 ("qtdeclarative" ,qtdeclarative)
570 ("qtx11extras" ,qtx11extras)))
571 (home-page "https://community.kde.org/KDEConnect")
572 (synopsis "Enable your devices to communicate with each other")
573 (description "KDE Connect is a project that enables all your devices to
574 communicate with each other. Here's a few things KDE Connect can do:
575 @enumerate
576 @item Receive your phone notifications on your desktop computer and reply to messages
577 @item Control music playing on your desktop from your phone
578 @item Use your phone as a remote control for your desktop
579 @item Run predefined commands on your PC from connected devices
580 @item Check your phones battery level from the desktop
581 @item Ring your phone to help finding it
582 @item Share files and links between devices
583 @item Browse your phone from the desktop
584 @item Control the desktop's volume from the phone
585 @end enumerate")
586 (properties `((upstream-name . "kdeconnect-kde")))
587 (license (list license:gpl2 license:gpl3)))) ; dual licensed
588
589 (define-public kqtquickcharts
590 (package
591 (name "kqtquickcharts")
592 (version "19.08.2")
593 (source
594 (origin
595 (method url-fetch)
596 (uri (string-append "mirror://kde/stable/applications/"
597 version "/src/kqtquickcharts-" version ".tar.xz"))
598 (sha256
599 (base32
600 "1yy9fyd8y4g25ljdsbil19qdf4j3mzmzl489sx7rqpm3lfdzjh9k"))))
601 (build-system cmake-build-system)
602 (native-inputs
603 `(("extra-cmake-modules" ,extra-cmake-modules)))
604 (inputs
605 `(("qtbase" ,qtbase)
606 ("qtdeclarative" ,qtdeclarative)))
607 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
608 (synopsis "Interactive charts for Qt Quick")
609 (description
610 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
611 charts.")
612 (license license:lgpl2.1+)))
613
614 (define-public kcachegrind
615 (package
616 (name "kcachegrind")
617 (version "19.04.1")
618 (source (origin
619 (method url-fetch)
620 (uri (string-append "mirror://kde/stable/applications/" version
621 "/src/kcachegrind-" version ".tar.xz"))
622 (sha256
623 (base32
624 "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
625 (build-system cmake-build-system)
626 (native-inputs
627 `(("extra-cmake-modules" ,extra-cmake-modules)
628 ("perl" ,perl)
629 ("python" ,python)
630 ("qttools" ,qttools)
631 ("kdoctools" ,kdoctools)))
632 (inputs
633 `(("qtbase" ,qtbase)
634 ("karchive" ,karchive)
635 ("ki18n" ,ki18n)
636 ("kio" ,kio)
637 ("kdbusaddons" ,kdbusaddons)))
638 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
639 ;; Python and PHP, respectively. These are optional and we ignore them
640 ;; for now.
641 (home-page "https://kcachegrind.github.io/html/Home.html")
642 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
643 (description
644 "The data files generated by the Callgrind of Valgrind, an application
645 profiler, can be loaded into KCachegrind for browsing the performance results.
646 There is also a command-line tool to get ASCII reports from data files without
647 the need to use KCachegrind.
648
649 The format of Callgrind output is documented. With conversion scripts,
650 KCachegrind is able to visualize output of other profilers like OProfile, a
651 system-wide profiler for Linux using statistical sampling with hardware
652 performance counters. There also exist converters for profiling output of
653 Python, PHP, and Perl.")
654 (license license:gpl2)))
655
656 (define-public libkdegames
657 (package
658 (name "libkdegames")
659 (version "19.08.3")
660 (source
661 (origin
662 (method url-fetch)
663 (uri (string-append "mirror://kde/stable/applications/" version
664 "/src/libkdegames-" version ".tar.xz"))
665 (sha256
666 (base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
667 (build-system qt-build-system)
668 (native-inputs
669 `(("extra-cmake-modules" ,extra-cmake-modules)))
670 (inputs
671 `(("karchive" ,karchive)
672 ("kbookmarks" ,kbookmarks)
673 ("kcodecs" ,kcodecs)
674 ("kcompletion" ,kcompletion)
675 ("kconfigwidgets" ,kconfigwidgets)
676 ("kcrash" ,kcrash)
677 ("kdbusaddons" ,kdbusaddons)
678 ("kdeclarative" ,kdeclarative)
679 ("kdnssd" ,kdnssd)
680 ("kglobalaccel" ,kglobalaccel)
681 ("kguiaddons" ,kguiaddons)
682 ("ki18n" ,ki18n)
683 ("kiconthemes" ,kiconthemes)
684 ;("kio" ,kio)
685 ("kitemviews" ,kitemviews)
686 ("kjobwidgets" ,kjobwidgets)
687 ("knewstuff" ,knewstuff)
688 ("kservice" ,kservice)
689 ("ktextwidgets" ,ktextwidgets)
690 ("kwidgetsaddons" ,kwidgetsaddons)
691 ("kxmlgui" ,kxmlgui)
692 ("libsndfile" ,libsndfile)
693 ("openal" ,openal)
694 ("qtbase" ,qtbase)
695 ("qtdeclarative" ,qtdeclarative)
696 ("qtsvg" ,qtsvg)))
697 (home-page "https://games.kde.org/")
698 (synopsis "Runtime library for kdegames")
699 (description "Runtime library for kdegames")
700 (license (list license:gpl2+ license:fdl1.2+))))
701
702 (define-public zeroconf-ioslave
703 (package
704 (name "zeroconf-ioslave")
705 (version "19.08.3")
706 (source
707 (origin
708 (method url-fetch)
709 (uri (string-append "mirror://kde/stable/applications/" version
710 "/src/zeroconf-ioslave-" version ".tar.xz"))
711 (sha256
712 (base32 "1vbi4kpyrk530q2dj8ql2i0gxjybdbmkqpl8vkhrihl7r7f0xc5p"))))
713 (build-system qt-build-system)
714 (native-inputs
715 `(("extra-cmake-modules" ,extra-cmake-modules)))
716 (inputs
717 `(("kdbusaddons" ,kdbusaddons)
718 ("kdnssd" ,kdnssd)
719 ("ki18n" ,ki18n)
720 ("kio" ,kio)
721 ("qtbase" ,qtbase)))
722 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
723 (synopsis "DNS-SD Service Discovery Monitor")
724 (description "Adds an entry to Dolphin's Network page to show local
725 services such as printers which advertise themselves with DNSSD (called Avahi
726 or Bonjour by other projects).")
727 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
728 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))