Merge remote-tracking branch master into core-updates
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013, 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
6 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
10 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
11 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
12 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages vpn)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system gnu)
36 #:use-module (guix build-system python)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages admin)
39 #:use-module (gnu packages base)
40 #:use-module (gnu packages check)
41 #:use-module (gnu packages autotools)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages gettext)
44 #:use-module (gnu packages gnupg)
45 #:use-module (gnu packages libevent)
46 #:use-module (gnu packages linux)
47 #:use-module (gnu packages nss)
48 #:use-module (gnu packages perl)
49 #:use-module (gnu packages pkg-config)
50 #:use-module (gnu packages python)
51 #:use-module (gnu packages python-xyz)
52 #:use-module (gnu packages tls)
53 #:use-module (gnu packages xml))
54
55 (define-public gvpe
56 (package
57 (name "gvpe")
58 (version "3.1")
59 (source (origin
60 (method url-fetch)
61 (uri (string-append "mirror://gnu/gvpe/gvpe-"
62 version ".tar.gz"))
63 (sha256
64 (base32
65 "1cz8n75ksl0l908zc5l3rnfm1hv7130s2w8710799fr5sxrdbszi"))))
66 (build-system gnu-build-system)
67 (home-page "http://software.schmorp.de/pkg/gvpe.html")
68 (native-inputs `(("pkg-config" ,pkg-config)))
69 (inputs `(("openssl" ,openssl)
70 ("zlib" ,zlib)))
71 (synopsis "Secure VPN among multiple nodes over an untrusted network")
72 (description
73 "The GNU Virtual Private Ethernet creates a virtual network
74 with multiple nodes using a variety of transport protocols. It works
75 by creating encrypted host-to-host tunnels between multiple
76 endpoints.")
77 (license license:gpl3+)))
78
79 (define-public vpnc
80 (package
81 (name "vpnc")
82 (version "0.5.3")
83 (source (origin
84 (method url-fetch)
85 (uri (string-append "https://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
86 version ".tar.gz"))
87 (sha256 (base32
88 "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))))
89 (build-system gnu-build-system)
90 (inputs `(("libgcrypt" ,libgcrypt)
91 ("perl" ,perl)
92 ("vpnc-scripts" ,vpnc-scripts)))
93 (arguments
94 `(#:tests? #f ; there is no check target
95 #:phases
96 (modify-phases %standard-phases
97 (add-after 'unpack 'use-store-paths
98 (lambda* (#:key inputs outputs #:allow-other-keys)
99 (let ((out (assoc-ref outputs "out"))
100 (vpnc-scripts (assoc-ref inputs "vpnc-scripts")))
101 (substitute* "config.c"
102 (("/etc/vpnc/vpnc-script")
103 (string-append vpnc-scripts "/etc/vpnc/vpnc-script")))
104 (substitute* "Makefile"
105 (("ETCDIR=.*")
106 (string-append "ETCDIR=" out "/etc/vpnc\n"))
107 (("PREFIX=.*")
108 (string-append "PREFIX=" out "\n")))
109 #t)))
110 (delete 'configure)))) ; no configure script
111 (synopsis "Client for Cisco VPN concentrators")
112 (description
113 "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
114 It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
115 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
116 1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
117 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
118 (license license:gpl2+) ; some file are bsd-2, see COPYING
119 (home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
120
121 (define-public vpnc-scripts
122 (let ((commit "1000e0f6dd7d6bff163169a46359211c1fc3a6d2"))
123 (package
124 (name "vpnc-scripts")
125 (version (string-append "20190116." (string-take commit 7)))
126 (source (origin
127 (method git-fetch)
128 (uri
129 (git-reference
130 (url "git://git.infradead.org/users/dwmw2/vpnc-scripts.git")
131 (commit commit)))
132 (file-name (git-file-name name version))
133 (sha256
134 (base32
135 "1g41yarz2bl0f73kbjqnywr485ghanbp7nmspklfb0n07yp0z6ak"))))
136 (build-system gnu-build-system)
137 (inputs `(("coreutils" ,coreutils)
138 ("grep" ,grep)
139 ("iproute2" ,iproute) ; for ‘ip’
140 ("net-tools" ,net-tools) ; for ‘ifconfig’, ‘route’
141 ("sed" ,sed)
142 ("which" ,which)))
143 (arguments
144 `(#:phases
145 (modify-phases %standard-phases
146 (add-after 'unpack 'use-relative-paths
147 ;; Patch the scripts to work with and use relative paths.
148 (lambda* _
149 (for-each (lambda (script)
150 (substitute* script
151 (("^PATH=.*") "")
152 (("(/usr|)/s?bin/") "")
153 (("\\[ +-x +([^]]+) +\\]" _ command)
154 (string-append "command -v >/dev/null 2>&1 "
155 command))))
156 (find-files "." "^vpnc-script"))
157 #t))
158 (delete 'configure) ; no configure script
159 (replace 'build
160 (lambda _
161 (invoke "gcc" "-o" "netunshare" "netunshare.c")))
162 (replace 'install
163 ;; There is no Makefile; manually install the relevant files.
164 (lambda* (#:key outputs #:allow-other-keys)
165 (let* ((out (assoc-ref outputs "out"))
166 (etc (string-append out "/etc/vpnc")))
167 (for-each (lambda (file)
168 (install-file file etc))
169 (append (find-files "." "^vpnc-script")
170 (list "netunshare"
171 "xinetd.netns.conf")))
172 #t)))
173 (add-after 'install 'wrap-scripts
174 ;; Wrap scripts with paths to their common hard dependencies.
175 ;; Optional dependencies will need to be installed by the user.
176 (lambda* (#:key inputs outputs #:allow-other-keys)
177 (let ((out (assoc-ref outputs "out")))
178 (for-each
179 (lambda (script)
180 (wrap-program script
181 `("PATH" ":" prefix
182 ,(map (lambda (name)
183 (let ((input (assoc-ref inputs name)))
184 (string-append input "/bin:"
185 input "/sbin")))
186 (list "coreutils"
187 "grep"
188 "iproute2"
189 "net-tools"
190 "sed"
191 "which")))))
192 (find-files (string-append out "/etc/vpnc/vpnc-script")
193 "^vpnc-script"))
194 #t))))
195 #:tests? #f)) ; no tests
196 (home-page "http://git.infradead.org/users/dwmw2/vpnc-scripts.git")
197 (synopsis "Network configuration scripts for Cisco VPN clients")
198 (description
199 "This set of scripts configures routing and name services when invoked
200 by the VPNC or OpenConnect Cisco @dfn{Virtual Private Network} (VPN) clients.
201
202 The default @command{vpnc-script} automatically configures most common
203 connections, and provides hooks for performing custom actions at various stages
204 of the connection or disconnection process.
205
206 Alternative scripts are provided for more complicated set-ups, or to serve as an
207 example for writing your own. For example, @command{vpnc-script-sshd} contains
208 the entire VPN in a network namespace accessible only through SSH.")
209 (license license:gpl2+))))
210
211 (define-public ocproxy
212 (package
213 (name "ocproxy")
214 (version "1.60")
215 (source (origin
216 (method git-fetch)
217 (uri (git-reference
218 (url "https://github.com/cernekee/ocproxy.git")
219 (commit (string-append "v" version))))
220 (file-name (git-file-name name version))
221 (sha256
222 (base32
223 "03323nnhb4y9nzwva04mq7xg03dvdrgp689g89f69jqc261skcqx"))))
224 (build-system gnu-build-system)
225 (native-inputs
226 `(("autoconf" ,autoconf)
227 ("automake" ,automake)))
228 (inputs
229 `(("libevent" ,libevent)))
230 (home-page "https://github.com/cernekee/ocproxy")
231 (synopsis "OpenConnect proxy")
232 (description
233 "User-level @dfn{SOCKS} and port forwarding proxy for OpenConnect based
234 on LwIP. When using ocproxy, OpenConnect only handles network activity that
235 the user specifically asks to proxy, so the @dfn{VPN} interface no longer
236 \"hijacks\" all network traffic on the host.")
237 (license license:bsd-3)))
238
239 (define-public openconnect
240 (package
241 (name "openconnect")
242 (version "8.05")
243 (source (origin
244 (method url-fetch)
245 (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
246 "openconnect-" version ".tar.gz"))
247 (sha256
248 (base32 "14i9q727c2zc9xhzp1a9hz3gzb5lwgsslbhircm84dnbs192jp1k"))))
249 (build-system gnu-build-system)
250 (propagated-inputs
251 `(("libxml2" ,libxml2)
252 ("gnutls" ,gnutls)
253 ("zlib" ,zlib)))
254 (inputs
255 `(("vpnc-scripts" ,vpnc-scripts)))
256 (native-inputs
257 `(("gettext" ,gettext-minimal)
258 ("pkg-config" ,pkg-config)))
259 (arguments
260 `(#:configure-flags
261 `(,(string-append "--with-vpnc-script="
262 (assoc-ref %build-inputs "vpnc-scripts")
263 "/etc/vpnc/vpnc-script"))))
264 (synopsis "Client for Cisco VPN")
265 (description
266 "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
267 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
268 870, 880, 1800, 2800, 3800, 7200 Series and Cisco 7301 Routers,
269 and probably others.")
270 (license license:lgpl2.1)
271 (home-page "https://www.infradead.org/openconnect/")))
272
273 (define-public openvpn
274 (package
275 (name "openvpn")
276 (version "2.4.8")
277 (source (origin
278 (method url-fetch)
279 (uri (string-append
280 "https://swupdate.openvpn.org/community/releases/openvpn-"
281 version ".tar.xz"))
282 (sha256
283 (base32
284 "149z3agjy03i66mcj5bplim2mh45s2ps1wmxbxczyzw0nxmsd37v"))))
285 (build-system gnu-build-system)
286 (arguments
287 '(#:configure-flags '("--enable-iproute2=yes")))
288 (native-inputs
289 `(("iproute2" ,iproute)))
290 (inputs
291 `(("lz4" ,lz4)
292 ("lzo" ,lzo)
293 ("openssl" ,openssl)
294 ("linux-pam" ,linux-pam)))
295 (home-page "https://openvpn.net/")
296 (synopsis "Virtual private network daemon")
297 (description
298 "OpenVPN implements virtual private network (@dfn{VPN}) techniques
299 for creating secure point-to-point or site-to-site connections in routed or
300 bridged configurations and remote access facilities. It uses a custom
301 security protocol that utilizes SSL/TLS for key exchange. It is capable of
302 traversing network address translators (@dfn{NAT}s) and firewalls.")
303 (license license:gpl2)))
304
305 (define-public tinc
306 (package
307 (name "tinc")
308 (version "1.0.36")
309 (source (origin
310 (method url-fetch)
311 (uri (string-append "https://tinc-vpn.org/packages/"
312 "tinc-" version ".tar.gz"))
313 (sha256
314 (base32
315 "021i2sl2mjscbm8g59d7vs74iw3gf0m48wg7w3zhwj6czarkpxs0"))))
316 (build-system gnu-build-system)
317 (arguments
318 '(#:configure-flags
319 '("--sysconfdir=/etc"
320 "--localstatedir=/var")))
321 (inputs `(("zlib" ,zlib)
322 ("lzo" ,lzo)
323 ("openssl" ,openssl)))
324 (home-page "https://tinc-vpn.org")
325 (synopsis "Virtual Private Network (VPN) daemon")
326 (description
327 "Tinc is a VPN that uses tunnelling and encryption to create a secure
328 private network between hosts on the internet.")
329 (license license:gpl2+)))
330
331 (define-public sshuttle
332 (package
333 (name "sshuttle")
334 (version "0.78.5")
335 (source
336 (origin
337 (method url-fetch)
338 (uri (pypi-uri name version))
339 (sha256
340 (base32
341 "0vp13xwrhx4m6zgsyzvai84lkq9mzkaw47j58dk0ll95kaymk2x8"))))
342 (build-system python-build-system)
343 (arguments
344 `(#:phases
345 (modify-phases %standard-phases
346 (add-after 'unpack 'patch-FHS-file-names
347 (lambda _
348 (substitute* "sshuttle/client.py"
349 (("/usr/bin/env") (which "env")))
350 (substitute* "sshuttle/ssh.py"
351 (("/bin/sh") "sh"))
352 #t)))))
353 (native-inputs
354 `(("python-setuptools-scm" ,python-setuptools-scm)
355 ;; For tests only.
356 ("python-flake8", python-flake8)
357 ("python-mock" ,python-mock)
358 ("python-pytest-cov" ,python-pytest-cov)
359 ("python-pytest-runner" ,python-pytest-runner)))
360 (home-page "https://github.com/sshuttle/sshuttle")
361 (synopsis "VPN that transparently forwards connections over SSH")
362 (description "sshuttle creates an encrypted virtual private network (VPN)
363 connection to any remote server to which you have secure shell (SSH) access.
364 The only requirement is a suitable version of Python on the server;
365 administrative privileges are required only on the client. Unlike most VPNs,
366 sshuttle forwards entire sessions, not packets, using kernel transparent
367 proxying. This makes it faster and more reliable than SSH's own tunneling and
368 port forwarding features. It can forward both TCP and UDP traffic, including
369 DNS domain name queries.")
370 (license license:lgpl2.0))) ; incorrectly identified as GPL in ‘setup.py’
371
372 (define-public sshoot
373 (package
374 (name "sshoot")
375 (version "1.2.6")
376 (source
377 (origin
378 (method url-fetch)
379 (uri (pypi-uri name version))
380 (sha256
381 (base32
382 "1ccgh0hjyxrwkgy3hnxz3hgbjbs0lmfs25d5l5jam0xbpcpj63h0"))))
383 (build-system python-build-system)
384 (arguments
385 '(#:phases
386 (modify-phases %standard-phases
387 (add-after 'unpack 'patch-paths
388 (lambda _
389 (substitute* "sshoot/tests/test_manager.py"
390 (("/bin/sh") (which "sh")))
391 #t)))))
392 (inputs
393 `(("python-argcomplete" ,python-argcomplete)
394 ("python-prettytable" ,python-prettytable)
395 ("python-pyyaml" ,python-pyyaml)))
396 ;; For tests only.
397 (native-inputs
398 `(("python-fixtures" ,python-fixtures)
399 ("python-pbr" ,python-pbr)
400 ("python-testtools" ,python-testtools)))
401 (home-page "https://github.com/albertodonato/sshoot")
402 (synopsis "sshuttle VPN session manager")
403 (description "sshoot provides a command-line interface to manage multiple
404 @command{sshuttle} virtual private networks. It supports flexible profiles
405 with configuration options for most of @command{sshuttle}’s features.")
406 (license license:gpl3+)))
407
408 (define-public badvpn
409 (package
410 (name "badvpn")
411 (version "1.999.130")
412 (source
413 (origin
414 (method git-fetch)
415 (uri (git-reference
416 (url "https://github.com/ambrop72/badvpn.git")
417 (commit version)))
418 (file-name (git-file-name name version))
419 (sha256
420 (base32 "0rm67xhi7bh3yph1vh07imv5y1pwyldvw3wa5bz471g8mnkc7d3c"))))
421 (build-system cmake-build-system)
422 (arguments
423 '(#:tests? #f)) ; no tests
424 (inputs
425 `(("nspr" ,nspr)
426 ("nss" ,nss)
427 ("openssl" ,openssl)))
428 (native-inputs
429 `(("pkg-config" ,pkg-config)))
430 (home-page "https://github.com/ambrop72/badvpn")
431 (synopsis "Peer-to-peer virtual private network (VPN)")
432 (description "@code{BadVPN} is a collection of virtual private
433 network (VPN) tools. It includes:
434
435 @enumerate
436 @item NCD programming language.\n
437 NCD (Network Configuration Daemon) is a daemon and programming/scripting
438 language for configuration of network interfaces and other aspects of the
439 operating system.
440 @item Tun2socks network-layer proxifier.\n
441 The tun2socks program socksifes TCP connections at the network layer. It
442 implements a TUN device which accepts all incoming TCP connections (regardless
443 of destination IP), and forwards the connections through a SOCKS server.
444 @item Peer-to-peer VPN.\n
445 The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
446 (VPN nodes).
447 @end enumerate")
448 ;; This project contains a bundled lwIP. lwIP is also released under the
449 ;; 3-clause BSD license.
450 (license license:bsd-3)))
451
452 (define-public wireguard
453 (package
454 (name "wireguard")
455 (version "0.0.20191012")
456 (source (origin
457 (method url-fetch)
458 (uri (string-append "https://git.zx2c4.com/WireGuard/snapshot/"
459 "WireGuard-" version ".tar.xz"))
460 (sha256
461 (base32
462 "13psxk61d60sas0ksfk0gakrv8wc8anjj5zb67g2zhn1r69k2mwk"))))
463 (build-system gnu-build-system)
464 (outputs '("out" ; The WireGuard userspace tools
465 "kernel-patch")) ; A patch to build Linux with WireGuard support
466 (arguments
467 `(#:tests? #f ; No tests available.
468 #:make-flags
469 (list "CC=gcc"
470 "WITH_BASHCOMPLETION=yes"
471 ;; Build and install the helper script wg-quick(8).
472 "WITH_WGQUICK=yes"
473 (string-append "PREFIX=" (assoc-ref %outputs "out"))
474 (string-append "SYSCONFDIR=" (assoc-ref %outputs "out") "/etc"))
475 #:modules ((guix build gnu-build-system)
476 (guix build utils)
477 (ice-9 popen)
478 (ice-9 textual-ports))
479 #:phases
480 (modify-phases %standard-phases
481 ;; There is no ./configure script.
482 (delete 'configure)
483 ;; Until WireGuard is added to the upstream Linux kernel, it is
484 ;; distributed as a kernel patch generated by this script.
485 (add-after 'patch-source-shebangs 'make-patch
486 (lambda* (#:key outputs #:allow-other-keys)
487 (let* ((output (string-append (assoc-ref outputs "kernel-patch")
488 "/wireguard.patch"))
489 (patch-builder "./contrib/kernel-tree/create-patch.sh")
490 (port (open-input-pipe patch-builder))
491 (str (get-string-all port)))
492 (close-pipe port)
493 (mkdir-p (dirname output))
494 (call-with-output-file output
495 (lambda (port)
496 (format port "~a" str))))
497 #t))
498 (add-after 'make-patch 'chdir
499 (lambda _
500 (chdir "src/tools")
501 #t))
502 ;; Otherwise the 'install-license-file' phase installs nothing.
503 ;; <https://bugs.gnu.org/34703>
504 (add-after 'install 'reset-cwd
505 (lambda _
506 (chdir "../..")
507 #t)))))
508 (inputs
509 `(("libmnl" ,libmnl)))
510 (home-page "https://www.wireguard.com/")
511 (synopsis "Tools for configuring WireGuard")
512 (description "This package provides the userspace tools for setting and
513 retrieving configuration of WireGuard network tunnel interfaces, and a patch
514 that can be applied to a Linux kernel source tree in order to build it with
515 WireGuard support.")
516 (license license:gpl2)))
517
518 (define-public xl2tpd
519 (package
520 (name "xl2tpd")
521 (version "1.3.15")
522 (source (origin
523 (method git-fetch)
524 (uri (git-reference
525 (url "https://github.com/xelerance/xl2tpd")
526 (commit (string-append "v" version))))
527 (file-name (git-file-name name version))
528 (sha256
529 (base32
530 "0ppwza8nwm1av1vldw40gin9wrjrs4l9si50jad414js3k8ycaag"))))
531 (build-system gnu-build-system)
532 (arguments
533 `(#:make-flags (list (string-append "PREFIX=" %output)
534 "CC=gcc")
535 #:phases (modify-phases %standard-phases
536 (delete 'configure)) ; no configure script
537 #:tests? #f)) ; no tests provided
538 (inputs `(("libpcap" ,libpcap)))
539 (home-page "https://www.xelerance.com/software/xl2tpd/")
540 (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
541 (description
542 "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
543 L2TP allows you to tunnel PPP over UDP.")
544 (license license:gpl2)))