Merge remote-tracking branch master into core-updates
[jackhill/guix/guix.git] / gnu / packages / ghostscript.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2013, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
6 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
7 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
8 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
9 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
11 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages ghostscript)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages cups)
33 #:use-module (gnu packages fontutils)
34 #:use-module (gnu packages image)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages python)
38 #:use-module (gnu packages tcl)
39 #:use-module (gnu packages xorg)
40 #:use-module ((guix licenses) #:prefix license:)
41 #:use-module (guix packages)
42 #:use-module (guix download)
43 #:use-module (guix utils)
44 #:use-module (guix build-system gnu)
45 #:use-module (guix build-system trivial)
46 #:use-module (srfi srfi-1))
47
48 (define-public lcms
49 (package
50 (name "lcms")
51 (version "2.9")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "mirror://sourceforge/lcms/lcms/" version
55 "/lcms2-" version ".tar.gz"))
56
57 (patches (search-patches "lcms-CVE-2018-16435.patch"))
58 (sha256 (base32
59 "083xisy6z01zhm7p7rgk4bx9d6zlr8l20qkfv1g29ylnhgwzvij8"))))
60 (build-system gnu-build-system)
61 (inputs `(("libjpeg" ,libjpeg)
62 ("libtiff" ,libtiff)
63 ("zlib" ,zlib)))
64 (synopsis "Little CMS, a small-footprint colour management engine")
65 (description
66 "Little CMS is a small-footprint colour management engine, with special
67 focus on accuracy and performance. It uses the International Color
68 Consortium standard (ICC), approved as ISO 15076-1.")
69 (license license:x11)
70 (home-page "http://www.littlecms.com/")
71 (properties '((cpe-name . "little_cms_color_engine")))))
72
73 (define-public libpaper
74 (package
75 (name "libpaper")
76 (version "1.1.24")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append
80 ;; Debian moved their libpaper-1.1.24 to archive.debian.net
81 ;; but in the move the hash of their tarball changed.
82 "http://pkgs.fedoraproject.org/repo/pkgs/libpaper/libpaper_"
83 version ".tar.gz/5bc87d494ba470aba54f6d2d51471834/libpaper_"
84 version ".tar.gz"))
85 (sha256 (base32
86 "0zhcx67afb6b5r936w5jmaydj3ks8zh83n9rm5sv3m3k8q8jib1q"))))
87 (build-system gnu-build-system)
88 (native-inputs
89 `(("automake" ,automake))) ; For up to date 'config.guess' and 'config.sub'.
90 (arguments
91 `(#:phases
92 (modify-phases %standard-phases
93 (add-after 'unpack 'fix-configure
94 (lambda* (#:key inputs native-inputs #:allow-other-keys)
95 ;; Replace outdated config.sub and config.guess:
96 (for-each (lambda (file)
97 (install-file
98 (string-append (assoc-ref
99 (or native-inputs inputs) "automake")
100 "/share/automake-"
101 ,(version-major+minor
102 (package-version automake))
103 "/" file) "."))
104 '("config.sub" "config.guess"))
105 #t)))))
106 (synopsis "Library for handling paper sizes")
107 (description
108 "The paper library and accompanying files are intended to provide a simple
109 way for applications to take actions based on a system- or user-specified
110 paper size.")
111 (license license:gpl2)
112 (home-page "https://packages.qa.debian.org/libp/libpaper.html")))
113
114 (define-public psutils
115 (package
116 (name "psutils")
117 (version "17")
118 (source (origin
119 (method url-fetch)
120 (uri "ftp://ftp.knackered.org/pub/psutils/psutils.tar.gz")
121 (sha256 (base32
122 "1r4ab1fvgganm02kmm70b2r1azwzbav2am41gbigpa2bb1wynlrq"))))
123 (build-system gnu-build-system)
124 (inputs `(("perl" ,perl)))
125 (arguments
126 `(#:tests? #f ; none provided
127 #:phases
128 (modify-phases %standard-phases
129 (replace 'configure
130 (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
131 (let ((perl (assoc-ref inputs "perl"))
132 (out (assoc-ref outputs "out")))
133 (copy-file "Makefile.unix" "Makefile")
134 (substitute* "Makefile"
135 (("/usr/local/bin/perl") (string-append perl "/bin/perl")))
136 (substitute* "Makefile"
137 (("/usr/local") out))
138 ;; for the install phase
139 (substitute* "Makefile"
140 (("-mkdir") "mkdir -p"))
141 ;; drop installation of non-free files
142 (substitute* "Makefile"
143 ((" install.include") "")))
144 #t)))))
145 (synopsis "Collection of utilities for manipulating PostScript documents")
146 (description
147 "PSUtils is a collection of utilities for manipulating PostScript
148 documents. Programs included are psnup, for placing out several logical pages
149 on a single sheet of paper, psselect, for selecting pages from a document,
150 pstops, for general imposition, psbook, for signature generation for booklet
151 printing, and psresize, for adjusting page sizes.")
152 (license (license:non-copyleft "file://LICENSE"
153 "See LICENSE in the distribution."))
154 (home-page "http://knackered.org/angus/psutils/")))
155
156 (define-public ghostscript
157 (package
158 (name "ghostscript")
159 (version "9.27")
160
161 ;; The problems addressed by GHOSTSCRIPT/FIXED are not security-related,
162 ;; but they have a significant impact on usability, hence this graft.
163 ;; TODO: Ungraft on next update cycle.
164 (replacement ghostscript/fixed)
165
166 (source
167 (origin
168 (method url-fetch)
169 (uri (string-append "https://github.com/ArtifexSoftware/"
170 "ghostpdl-downloads/releases/download/gs"
171 (string-delete #\. version)
172 "/ghostscript-" version ".tar.xz"))
173 (sha256
174 (base32
175 "06dnj0mxyaryfbwlsjwaqf847w91w2h8f108kxxcc41nrnx1y3zw"))
176 (patches (search-patches "ghostscript-no-header-creationdate.patch"
177 "ghostscript-no-header-id.patch"
178 "ghostscript-no-header-uuid.patch"))
179 (modules '((guix build utils)))
180 (snippet
181 ;; Remove bundled libraries. The bundled OpenJPEG is a patched fork so
182 ;; we leave it, at least for now.
183 ;; TODO Try unbundling ijs, which is developed alongside Ghostscript.
184 ;; Likewise for the thread-safe lcms2 fork called "lcms2art".
185 '(begin
186 (for-each delete-file-recursively '("freetype" "jbig2dec" "jpeg"
187 "libpng" "tiff" "zlib"))
188 #t))))
189 (build-system gnu-build-system)
190 (outputs '("out" "doc")) ;19 MiB of HTML/PS doc + examples
191 (arguments
192 `(#:disallowed-references ("doc")
193 ;; XXX: Starting with version 9.27, building the tests in parallel
194 ;; occasionally fails like this:
195 ;; In file included from ./base/memory_.h:23:0,
196 ;; from ./obj/gsmd5.h:1,
197 ;; from ./obj/gsmd5.c:56:
198 ;; ./base/std.h:25:10: fatal error: arch.h: No such file or directory
199 #:parallel-tests? #f
200 #:configure-flags
201 (list (string-append "LDFLAGS=-Wl,-rpath="
202 (assoc-ref %outputs "out") "/lib")
203 "--with-system-libtiff"
204 "LIBS=-lz"
205 (string-append "ZLIBDIR="
206 (assoc-ref %build-inputs "zlib") "/include")
207 "--enable-dynamic"
208
209 ,@(if (%current-target-system)
210 '(;; Specify the native compiler, which is used to build 'echogs'
211 ;; and other intermediary tools when cross-compiling; see
212 ;; <https://ghostscript.com/FAQ.html>.
213 "CCAUX=gcc"
214
215 ;; Save 'config.log' etc. of the native build under
216 ;; auxtmp/, useful for debugging.
217 "--enable-save_confaux")
218 '()))
219 #:phases
220 (modify-phases %standard-phases
221 (add-before 'configure 'create-output-directory
222 (lambda* (#:key outputs #:allow-other-keys)
223 ;; The configure script refuses to function if the directory
224 ;; specified as -rpath does not already exist.
225 (mkdir-p (string-append (assoc-ref outputs "out") "/lib"))
226 #t))
227 (add-after 'configure 'remove-doc-reference
228 (lambda _
229 ;; Don't retain a reference to the 'doc' output in 'gs'.
230 ;; The only use of this definition is in the output of
231 ;; 'gs --help', so this change is fine.
232 (substitute* "base/gscdef.c"
233 (("GS_DOCDIR")
234 "\"~/.guix-profile/share/doc/ghostscript\""))
235 ;; The docdir default changed in 9.23 and a compatibility
236 ;; symlink was added from datadir->docdir. Remove it.
237 (substitute* "base/unixinst.mak"
238 (("ln -s \\$\\(DESTDIR\\)\\$\\(docdir\\).*") ""))
239 #t))
240 (add-after 'configure 'patch-config-files
241 (lambda _
242 (substitute* "base/unixhead.mak"
243 (("/bin/sh") (which "sh")))
244 #t))
245 ,@(if (%current-target-system)
246 `((add-after 'configure 'add-native-lz
247 (lambda _
248 ;; Add missing '-lz' for native tools such as 'mkromfs'.
249 (substitute* "Makefile"
250 (("^AUXEXTRALIBS=(.*)$" _ value)
251 (string-append "AUXEXTRALIBS = -lz " value "\n")))
252 #t)))
253 '())
254 (replace 'build
255 (lambda _
256 ;; Build 'libgs.so', but don't build the statically-linked 'gs'
257 ;; binary (saves 22 MiB).
258 (invoke "make" "so" "-j"
259 (number->string (parallel-job-count)))))
260 (replace 'install
261 (lambda _
262 (invoke "make" "soinstall")))
263 (add-after 'install 'create-gs-symlink
264 (lambda* (#:key outputs #:allow-other-keys)
265 (let ((out (assoc-ref outputs "out")))
266 ;; Some programs depend on having a 'gs' binary available.
267 (symlink "gsc" (string-append out "/bin/gs"))
268 #t))))))
269 (native-inputs
270 `(("perl" ,perl)
271 ("python" ,python-wrapper)
272 ("tcl" ,tcl)
273
274 ;; When cross-compiling, some of the natively-built tools require all
275 ;; these libraries.
276 ,@(if (%current-target-system)
277 `(("zlib/native" ,zlib)
278 ("libjpeg/native" ,libjpeg))
279 '())))
280 (inputs
281 `(("freetype" ,freetype)
282 ("jbig2dec" ,jbig2dec)
283 ("libjpeg" ,libjpeg)
284 ("libpaper" ,libpaper)
285 ("libpng" ,libpng)
286 ("libtiff" ,libtiff)
287 ("zlib" ,zlib)))
288 (synopsis "PostScript and PDF interpreter")
289 (description
290 "Ghostscript is an interpreter for the PostScript language and the PDF
291 file format. It also includes a C library that implements the graphics
292 capabilities of the PostScript language. It supports a wide variety of
293 output file formats and printers.")
294 (home-page "https://www.ghostscript.com/")
295 (license license:agpl3+)))
296
297 (define ghostscript/fixed
298 ;; This adds the Freetype dependency (among other things), which fixes the
299 ;; rendering issues described in <https://issues.guix.gnu.org/issue/34877>.
300 (package/inherit
301 ghostscript
302 (arguments
303 (substitute-keyword-arguments (package-arguments ghostscript)
304 ((#:configure-flags flags ''())
305 `(append (list "--disable-compile-inits"
306 (string-append "--with-fontpath="
307 (assoc-ref %build-inputs "gs-fonts")
308 "/share/fonts/type1/ghostscript"))
309 ,flags))))
310 (native-inputs `(("pkg-config" ,pkg-config) ;needed for freetype
311 ,@(package-native-inputs ghostscript)))
312 (inputs `(("gs-fonts" ,gs-fonts)
313 ("fontconfig" ,fontconfig)
314 ,@(package-inputs ghostscript)))))
315
316 (define-public ghostscript/x
317 (package/inherit ghostscript
318 (name (string-append (package-name ghostscript) "-with-x"))
319 (inputs `(("libxext" ,libxext)
320 ("libxt" ,libxt)
321 ,@(package-inputs ghostscript)))))
322
323 (define-public ghostscript/cups
324 (package/inherit ghostscript
325 (name "ghostscript-with-cups")
326 (inputs `(("cups" ,cups-minimal)
327 ,@(package-inputs ghostscript)))))
328
329 (define-public ijs
330 (package
331 (name "ijs")
332 (version (package-version ghostscript))
333 (source (package-source ghostscript))
334 (build-system gnu-build-system)
335 (native-inputs
336 `(("libtool" ,libtool)
337 ("automake" ,automake)
338 ("autoconf" ,autoconf)))
339 (arguments
340 `(#:phases
341 (modify-phases %standard-phases
342 (add-after 'unpack 'autogen
343 (lambda _
344 ;; need to regenerate macros
345 (system* "autoreconf" "-if")
346 ;; do not run configure
347 (substitute* "autogen.sh"
348 (("^.*\\$srcdir/configure.*") ""))
349 (system* "bash" "autogen.sh")
350 ;; create configure script in ./ijs/
351 (chdir "ijs")
352 ;; do not run configure
353 (substitute* "autogen.sh"
354 (("^.*\\$srcdir/configure.*") "")
355 (("^ + && echo Now type.*$") ""))
356 (invoke "bash" "autogen.sh"))))))
357 (synopsis "IJS driver framework for inkjet and other raster devices")
358 (description
359 "IJS is a protocol for transmission of raster page images. This package
360 provides the reference implementation of the raster printer driver
361 architecture.")
362 (license license:expat)
363 (home-page (package-home-page ghostscript))))
364
365 (define-public gs-fonts
366 (package
367 (name "gs-fonts")
368 (version "8.11")
369 (source (origin
370 (method url-fetch)
371 (uri (string-append "mirror://sourceforge/gs-fonts/gs-fonts/"
372 version
373 "%20%28base%2035%2C%20GPL%29/ghostscript-fonts-std-"
374 version
375 ".tar.gz"))
376 (sha256 (base32
377 "00f4l10xd826kak51wsmaz69szzm2wp8a41jasr4jblz25bg7dhf"))))
378 (build-system gnu-build-system)
379 (arguments
380 `(#:tests? #f ; nothing to check, just files to copy
381
382 #:modules ((guix build gnu-build-system)
383 (guix build utils)
384 (srfi srfi-1))
385 #:phases
386 (modify-phases %standard-phases
387 (delete 'configure)
388 (delete 'build)
389 (replace 'install
390 (lambda* (#:key outputs #:allow-other-keys)
391 (let* ((out (assoc-ref outputs "out"))
392 (dir (string-append out "/share/fonts/type1/ghostscript")))
393 (mkdir-p dir)
394 (for-each
395 (lambda (file)
396 (copy-file file (string-append dir "/" file)))
397 (find-files "." "pfb|afm"))
398 #t))))))
399 (synopsis "Free replacements for the PostScript fonts")
400 (description
401 "Ghostscript fonts provides fonts and font metrics customarily distributed with
402 Ghostscript. It currently includes the 35 standard PostScript fonts.")
403 (license license:gpl2)
404 (home-page "https://sourceforge.net/projects/gs-fonts/")))
405
406 (define-public libspectre
407 (package
408 (name "libspectre")
409 (version "0.2.8")
410 (source (origin
411 (method url-fetch)
412 (uri (string-append "https://libspectre.freedesktop.org/releases/libspectre-"
413 version ".tar.gz"))
414 (sha256 (base32
415 "1a67iglsc3r05mzngyg9kb1gy8whq4fgsnyjwi7bqfw2i7rnl9b5"))))
416 (build-system gnu-build-system)
417 (inputs `(("ghostscript" ,ghostscript)))
418 (native-inputs `(("pkg-config" ,pkg-config)))
419 (synopsis "Postscript rendering library")
420 (description
421 "libspectre is a small library for rendering Postscript documents.
422 It provides a convenient easy to use API for handling and rendering
423 Postscript documents.")
424 (license license:gpl2+)
425 (home-page "https://www.freedesktop.org/wiki/Software/libspectre")))