gnu: Add shakespeare-spl.
[jackhill/guix/guix.git] / gnu / packages / esolangs.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
3 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages esolangs)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages bison)
23 #:use-module (gnu packages flex)
24 #:use-module (gnu packages ncurses)
25 #:use-module (guix build-system cmake)
26 #:use-module (guix build-system copy)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages))
32
33 (define-public cfunge
34 (package
35 (name "cfunge")
36 (version "0.9.0")
37 (source (origin
38 (method git-fetch)
39 (uri (git-reference
40 (url "https://github.com/VorpalBlade/cfunge")
41 (commit version)))
42 (file-name (git-file-name name version))
43 (sha256
44 (base32
45 "18ir0h10vxdb5jb57w5hjbgi8spjxg9x2148agadhhmbhsja02m7"))))
46 (build-system cmake-build-system)
47 (arguments
48 ;; The tests are not designed to be run and evaluated automatically.
49 '(#:tests? #f))
50 (inputs
51 `(("ncurses" ,ncurses)))
52 (home-page "https://github.com/VorpalBlade/cfunge")
53 (synopsis "Fast conforming Befunge93/98/109 interpreter in C")
54 (description "@command{cfunge} is a fast conforming Befunge93/98/109 interpreter
55 written in C. It supports several @dfn{fingerprints} (opt-in language extensions
56 identified by unique ID codes).")
57 (license license:gpl3)))
58
59 (define-public shakespeare-spl
60 (package
61 (name "shakespeare-spl")
62 (version "1.2.1")
63 (source (origin
64 (method url-fetch)
65 (uri (string-append "mirror://sourceforge/shakespearelang/spl-"
66 version ".tar.gz"))
67 (sha256
68 (base32
69 "1lxpfhv01kcwy4l4xgx7j765g8g0v74jns0cr908nfw55h5fy1hj"))
70 (patches
71 (search-patches
72 "shakespeare-spl-fix-grammar.patch"))))
73 (build-system copy-build-system)
74 (arguments
75 `(#:imported-modules (,@%gnu-build-system-modules
76 (guix build copy-build-system))
77 #:modules ((guix build copy-build-system)
78 ((guix build gnu-build-system) #:prefix gnu:)
79 (guix build utils))
80 #:install-plan '(("spl/bin" "bin")
81 ("spl/lib" "lib")
82 ("spl/include" "include"))
83 #:phases
84 (modify-phases %standard-phases
85 (add-before 'install 'build
86 (assoc-ref gnu:%standard-phases 'build)))))
87 (native-inputs
88 `(("bison" ,bison)
89 ("flex" ,flex)))
90 (home-page "http://shakespearelang.sourceforge.net/")
91 (synopsis "Write programs like Shakespearean plays")
92 (description "Shakespeare is a programming language with the design goal
93 of making programs read like plays. The characters in the play are variables.
94 If you want to assign a character, let's say Juliet, a positive value, you put
95 her and another character on the stage and let that character praise Juliet.")
96 (license license:gpl2+)))