gnu: libvorbis: Fix CVE-2017-{14632,14633}.
[jackhill/guix/guix.git] / gnu / packages / patches / libvorbis-CVE-2017-14632.patch
1 Fix CVE-2017-14632:
2
3 https://gitlab.xiph.org/xiph/vorbis/issues/2328
4 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14632
5
6 Patch copied from upstream source repository:
7
8 https://gitlab.xiph.org/xiph/vorbis/commit/c1c2831fc7306d5fbd7bc800324efd12b28d327f
9
10 From c1c2831fc7306d5fbd7bc800324efd12b28d327f Mon Sep 17 00:00:00 2001
11 From: =?UTF-8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
12 Date: Wed, 15 Nov 2017 18:22:59 +0100
13 Subject: [PATCH] CVE-2017-14632: vorbis_analysis_header_out: Don't clear opb
14 if not initialized
15
16 If the number of channels is not within the allowed range
17 we call oggback_writeclear altough it's not initialized yet.
18
19 This fixes
20
21 =23371== Invalid free() / delete / delete[] / realloc()
22 ==23371== at 0x4C2CE1B: free (vg_replace_malloc.c:530)
23 ==23371== by 0x829CA31: oggpack_writeclear (in /usr/lib/x86_64-linux-gnu/libogg.so.0.8.2)
24 ==23371== by 0x84B96EE: vorbis_analysis_headerout (info.c:652)
25 ==23371== by 0x9FBCBCC: ??? (in /usr/lib/x86_64-linux-gnu/sox/libsox_fmt_vorbis.so)
26 ==23371== by 0x4E524F1: ??? (in /usr/lib/x86_64-linux-gnu/libsox.so.2.0.1)
27 ==23371== by 0x4E52CCA: sox_open_write (in /usr/lib/x86_64-linux-gnu/libsox.so.2.0.1)
28 ==23371== by 0x10D82A: open_output_file (sox.c:1556)
29 ==23371== by 0x10D82A: process (sox.c:1753)
30 ==23371== by 0x10D82A: main (sox.c:3012)
31 ==23371== Address 0x68768c8 is 488 bytes inside a block of size 880 alloc'd
32 ==23371== at 0x4C2BB1F: malloc (vg_replace_malloc.c:298)
33 ==23371== by 0x4C2DE9F: realloc (vg_replace_malloc.c:785)
34 ==23371== by 0x4E545C2: lsx_realloc (in /usr/lib/x86_64-linux-gnu/libsox.so.2.0.1)
35 ==23371== by 0x9FBC9A0: ??? (in /usr/lib/x86_64-linux-gnu/sox/libsox_fmt_vorbis.so)
36 ==23371== by 0x4E524F1: ??? (in /usr/lib/x86_64-linux-gnu/libsox.so.2.0.1)
37 ==23371== by 0x4E52CCA: sox_open_write (in /usr/lib/x86_64-linux-gnu/libsox.so.2.0.1)
38 ==23371== by 0x10D82A: open_output_file (sox.c:1556)
39 ==23371== by 0x10D82A: process (sox.c:1753)
40 ==23371== by 0x10D82A: main (sox.c:3012)
41
42 as seen when using the testcase from CVE-2017-11333 with
43 008d23b782be09c8d75ba8190b1794abd66c7121 applied. However the error was
44 there before.
45 ---
46 lib/info.c | 1 +
47 1 file changed, 1 insertion(+)
48
49 diff --git a/lib/info.c b/lib/info.c
50 index 7bc4ea4..8d0b2ed 100644
51 --- a/lib/info.c
52 +++ b/lib/info.c
53 @@ -589,6 +589,7 @@ int vorbis_analysis_headerout(vorbis_dsp_state *v,
54 private_state *b=v->backend_state;
55
56 if(!b||vi->channels<=0||vi->channels>256){
57 + b = NULL;
58 ret=OV_EFAULT;
59 goto err_out;
60 }
61 --
62 2.15.1
63