gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / wordnet-CVE-2008-3908-pt2.patch
1 This patch was created by oCert according to
2 http://www.ocert.org/advisories/ocert-2008-014.html
3 Unfortunately the original patch contained a bug which was
4 later fixed by the issuer of the patch Rob Holland <rob@ocert.org>
5 This part was now separated in this file.
6
7 --- a/lib/search.c
8 +++ b/lib/search.c
9 @@ -1568,7 +1568,8 @@ char *findtheinfo(char *searchstr, int d
10 bufstart[0] = '\n';
11 bufstart++;
12 }
13 - strncpy(bufstart, tmpbuf, strlen(tmpbuf));
14 + /* Avoid writing a trailing \0 after the string */
15 + memcpy(bufstart, tmpbuf, strlen(tmpbuf));
16 bufstart = searchbuffer + strlen(searchbuffer);
17 }
18 }