gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / vsearch-unbundle-cityhash.patch
1 diff --git a/src/Makefile.am b/src/Makefile.am
2 index e56a8a2..4adcc48 100644
3 --- a/src/Makefile.am
4 +++ b/src/Makefile.am
5 @@ -3,7 +3,7 @@ bin_PROGRAMS = $(top_builddir)/bin/vsearch
6 if TARGET_PPC
7 AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -mcpu=power8
8 else
9 -AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -march=x86-64 -mtune=generic
10 +AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -lcityhash
11 endif
12
13 AM_CFLAGS=$(AM_CXXFLAGS)
14 @@ -18,8 +18,6 @@ allpairs.h \
15 arch.h \
16 bitmap.h \
17 chimera.h \
18 -city.h \
19 -citycrc.h \
20 cluster.h \
21 cpu.h \
22 db.h \
23 @@ -59,31 +57,26 @@ xstring.h
24
25 if TARGET_PPC
26 libcpu_a_SOURCES = cpu.cc $(VSEARCHHEADERS)
27 -noinst_LIBRARIES = libcpu.a libcityhash.a
28 +noinst_LIBRARIES = libcpu.a
29 else
30 libcpu_sse2_a_SOURCES = cpu.cc $(VSEARCHHEADERS)
31 libcpu_sse2_a_CXXFLAGS = $(AM_CXXFLAGS) -msse2
32 libcpu_ssse3_a_SOURCES = cpu.cc $(VSEARCHHEADERS)
33 libcpu_ssse3_a_CXXFLAGS = $(AM_CXXFLAGS) -mssse3 -DSSSE3
34 -noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a libcityhash.a
35 +noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a
36 endif
37
38 -libcityhash_a_SOURCES = city.cc city.h
39 -
40 if TARGET_WIN
41
42 -libcityhash_a_CXXFLAGS = $(AM_CXXFLAGS) -Wno-sign-compare -D_MSC_VER
43 -__top_builddir__bin_vsearch_LDFLAGS = -static
44 -__top_builddir__bin_vsearch_LDADD = libregex.a libcityhash.a libcpu_ssse3.a libcpu_sse2.a
45 +__top_builddir__bin_vsearch_LDFLAGS = -static -lcityhash
46 +__top_builddir__bin_vsearch_LDADD = libregex.a libcpu_ssse3.a libcpu_sse2.a
47
48 else
49
50 -libcityhash_a_CXXFLAGS = $(AM_CXXFLAGS) -Wno-sign-compare
51 -
52 if TARGET_PPC
53 -__top_builddir__bin_vsearch_LDADD = libcityhash.a libcpu.a
54 +__top_builddir__bin_vsearch_LDADD = libcpu.a
55 else
56 -__top_builddir__bin_vsearch_LDADD = libcityhash.a libcpu_ssse3.a libcpu_sse2.a
57 +__top_builddir__bin_vsearch_LDADD = libcpu_ssse3.a libcpu_sse2.a
58 endif
59
60 endif
61 diff --git a/src/vsearch.h b/src/vsearch.h
62 index f2c244b..5f51bbe 100644
63 --- a/src/vsearch.h
64 +++ b/src/vsearch.h
65 @@ -148,7 +148,7 @@
66 #include <bzlib.h>
67 #endif
68
69 -#include "city.h"
70 +#include <city.h>
71 #include "md5.h"
72 #include "sha1.h"
73