gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / util-linux-tests.patch
1 This test checks whether 'root' is successfully translated to UID/GID 0,
2 using 'getpwnam' in libmount. This doesn't work in the chroot because
3 /etc/passwd doesn't contain an entry for 'root' so skip it.
4
5 The second test requires that '/sys/dev/block' is present, which is not
6 the case inside the build container.
7
8 --- util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:41.181151194 +0100
9 +++ util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:42.829161716 +0100
10 @@ -108,10 +108,6 @@
11 ts_run $TESTPROG --apply --user "noexec,nosuid,loop=/dev/looop0" 0x408 &> $TS_OUTPUT
12 ts_finalize_subtest
13
14 -ts_init_subtest "fix"
15 -ts_run $TESTPROG --fix "uid=root,gid=root" &> $TS_OUTPUT
16 -ts_finalize_subtest
17 -
18 ts_init_subtest "deduplicate"
19 ts_run $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
20 ts_finalize_subtest
21 --- a/tests/ts/lsblk/lsblk 2019-03-11 21:08:23.734387391 +0100
22 +++ b/tests/ts/lsblk/lsblk 2019-03-11 21:12:43.635473111 +0100
23 @@ -22,6 +22,8 @@
24
25 ts_init "$*"
26
27 +ts_skip "/sys/dev/block is not available"
28 +
29 ts_check_test_command "$TS_CMD_LSBLK"
30 ts_check_prog xz
31 ts_check_prog tar