gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / unzip-initialize-symlink-flag.patch
1 Copied from Debian.
2
3 From: Andreas Schwab <schwab@linux-m68k.org>
4 Subject: Initialize the symlink flag
5 Bug-Debian: http://bugs.debian.org/717029
6 X-Debian-version: 6.0-10
7
8 --- a/process.c
9 +++ b/process.c
10 @@ -1758,6 +1758,12 @@
11 = (G.crec.general_purpose_bit_flag & (1 << 11)) == (1 << 11);
12 #endif
13
14 +#ifdef SYMLINKS
15 + /* Initialize the symlink flag, may be set by the platform-specific
16 + mapattr function. */
17 + G.pInfo->symlink = 0;
18 +#endif
19 +
20 return PK_COOL;
21
22 } /* end function process_cdir_file_hdr() */