gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / unzip-allow-greater-hostver-values.patch
1 Copied from Debian.
2
3 From: Santiago Vila <sanvila@debian.org>
4 Subject: zipinfo.c: Do not crash when hostver byte is >= 100
5
6 --- a/zipinfo.c
7 +++ b/zipinfo.c
8 @@ -2114,7 +2114,7 @@
9 else
10 attribs[9] = (xattr & UNX_ISVTX)? 'T' : '-'; /* T==undefined */
11
12 - sprintf(&attribs[12], "%u.%u", hostver/10, hostver%10);
13 + sprintf(&attribs[11], "%2u.%u", hostver/10, hostver%10);
14 break;
15
16 } /* end switch (hostnum: external attributes format) */