gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ungoogled-chromium-system-opus.patch
1 Add missing build dependency on Opus so that system headers are found.
2
3 Taken from upstream:
4 https://chromium-review.googlesource.com/c/chromium/src/+/2644623
5
6 diff --git a/third_party/blink/renderer/modules/webcodecs/BUILD.gn b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
7 --- a/third_party/blink/renderer/modules/webcodecs/BUILD.gn
8 +++ b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
9 @@ -65,6 +65,7 @@ blink_modules_sources("webcodecs") {
10 "//media/mojo/clients",
11 "//media/mojo/mojom",
12 "//third_party/libyuv:libyuv",
13 + "//third_party/opus",
14 ]
15 if (media_use_openh264) {
16 deps += [ "//third_party/openh264:encoder" ]
17 diff --git a/third_party/blink/renderer/modules/webcodecs/DEPS b/third_party/blink/renderer/modules/webcodecs/DEPS
18 --- a/third_party/blink/renderer/modules/webcodecs/DEPS
19 +++ b/third_party/blink/renderer/modules/webcodecs/DEPS
20 @@ -19,6 +19,7 @@ include_rules = [
21
22 "+third_party/libyuv",
23 "+third_party/openh264",
24 + "+third_party/opus",
25
26 "+ui/gfx/color_space.h",
27 "+ui/gfx/geometry/rect.h",