gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / tipp10-qt5.patch
1 https://salsa.debian.org/debian/tipp10/-/raw/debian/2.1.0-5/debian/patches/qt5.patch
2
3 Author: Reiner Herrmann <reiner@reiner-h.de>
4 Description: Port to Qt5
5 Bug-Debian: https://bugs.debian.org/875207
6
7 --- a/tipp10.pro
8 +++ b/tipp10.pro
9 @@ -14,6 +14,7 @@
10 DEPENDPATH += .
11 INCLUDEPATH += .
12 CONFIG += qt
13 +QT += widgets multimedia printsupport
14 QT += sql
15 RC_FILE += tipp10.rc
16 RESOURCES += tipp10.qrc
17 --- a/main.cpp
18 +++ b/main.cpp
19 @@ -24,7 +24,6 @@
20 ****************************************************************/
21
22 #include <QApplication>
23 -#include <QPlastiqueStyle>
24 #include <QString>
25 #include <QSettings>
26 #include <QCoreApplication>
27 @@ -212,7 +211,7 @@
28
29 // Set windows style
30 if (!useNativeStyle) {
31 - app.setStyle("plastique");
32 + app.setStyle("fusion");
33 }
34
35 // Translation
36 --- a/games/abcrainwidget.cpp
37 +++ b/games/abcrainwidget.cpp
38 @@ -235,8 +235,7 @@
39 charballs.last()->wind = (qrand() % 8) + 2;
40 charballs.last()->rad = 0;
41
42 - chartext.append(new QGraphicsTextItem(QString(characterTemp),
43 - charballs.last(), scene));
44 + chartext.append(new QGraphicsTextItem(QString(characterTemp), charballs.last()));
45 chartext.last()->setFont(QFont("Courier", 16, 100));
46 chartext.last()->setPos(-(chartext.last()->boundingRect().width() / 2), -(chartext.last()->boundingRect().height() / 2));
47
48 --- a/sql/chartablesql.cpp
49 +++ b/sql/chartablesql.cpp
50 @@ -137,7 +137,7 @@
51 sortColumn(4);
52
53 headerview->setStretchLastSection(true);
54 - headerview->setResizeMode(QHeaderView::Interactive);
55 + headerview->setSectionResizeMode(QHeaderView::Interactive);
56 headerview->setSortIndicatorShown(true);
57
58 // Resize the columns
59 --- a/sql/lessontablesql.cpp
60 +++ b/sql/lessontablesql.cpp
61 @@ -202,7 +202,7 @@
62 sortColumn(-1);
63
64 headerview->setStretchLastSection(true);
65 - headerview->setResizeMode(QHeaderView::Interactive);
66 + headerview->setSectionResizeMode(QHeaderView::Interactive);
67 headerview->setSortIndicatorShown(true);
68
69 // Resize the columns