gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / tao-fix-parser-types.patch
1 Taken from Debian:
2 https://salsa.debian.org/multimedia-team/taopm/-/raw/master/debian/patches/02-fix-parser-yyerror.diff
3
4 Description: Use a constant char, dummy comment.
5 Author: Tiago Bortoletto Vaz <tiago@debian.org>
6 Last-Update: 2013-04-17
7 --- a/taoparse/taoparser.yy
8 +++ b/taoparse/taoparser.yy
9 @@ -23,7 +23,7 @@
10 #include <stdio.h>
11 #include "taoparserdefs.h"
12
13 -int yyerror(char *s);
14 +int yyerror(const char *s);
15
16 //#ifdef LINUX
17 int yylex(void);
18 @@ -2924,7 +2924,7 @@
19 }
20
21
22 -int yyerror (char *s)
23 +int yyerror (const char *s)
24 {
25 parse_error(what_I_expected_here);
26 std::cout << "PARSE_FAILED";