gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / t1lib-CVE-2011-0764.patch
1 Description: Don't lookup previous point if there isn't any
2 Author: Marc Deslauriers <marc.deslauriers@canonical.com>
3 Forwarded: no
4
5 Index: t1lib-5.1.2/lib/type1/type1.c
6 ===================================================================
7 --- t1lib-5.1.2.orig/lib/type1/type1.c 2011-12-13 14:24:14.280965637 -0600
8 +++ t1lib-5.1.2/lib/type1/type1.c 2011-12-13 14:25:25.893320747 -0600
9 @@ -1700,6 +1700,7 @@
10 long pindex = 0;
11
12 /* compute hinting for previous segment! */
13 + if (ppoints == NULL) Error0i("RLineTo: No previous point!\n");
14 FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx, dy);
15
16 /* Allocate a new path point and pre-setup data */
17 @@ -1728,6 +1729,7 @@
18 long pindex = 0;
19
20 /* compute hinting for previous point! */
21 + if (ppoints == NULL) Error0i("RRCurveTo: No previous point!\n");
22 FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx1, dy1);
23
24 /* Allocate three new path points and pre-setup data */
25 @@ -1903,6 +1905,7 @@
26 FindStems( currx, curry, 0, 0, dx, dy);
27 }
28 else {
29 + if (ppoints == NULL) Error0i("RMoveTo: No previous point!\n");
30 FindStems( currx, curry, ppoints[numppoints-2].x, ppoints[numppoints-2].y, dx, dy);
31 }
32