gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / symmetrica-sort_sum_rename.patch
1 diff -r 5cd656a07aa5 src/bar.c
2 --- a/bar.c Thu May 14 06:01:00 2009 -0400
3 +++ b/bar.c Thu May 14 07:38:17 2009 -0400
4 @@ -237,7 +237,7 @@
5 g = callocobject();
6 e = S_V_I(a,0L);
7 f = S_V_I(a,1L);
8 - erg += sum(f,g);
9 + erg += sym_sum(f,g);
10 j=0L;
11 for (i=0L;i<S_V_LI(e);i++)
12 j += S_V_II(e,i)*(i+1L);
13 @@ -427,7 +427,7 @@
14 for (i=0L;i<S_V_LI(b);i++)
15 erg += kranztypus_to_matrix(S_V_I(c,i),S_V_I(b,i));
16 erg += freeall(c);
17 - erg += sort(b); /* AK 130592 */
18 + erg += sym_sort(b); /* AK 130592 */
19 ENDR("makevectorof_class_bar");
20 }
21
22 @@ -615,7 +615,7 @@
23 c = callocobject();
24 d = callocobject();
25 erg += lehmercode_bar(a,c);
26 - erg += sum(S_V_I(c,1L),b);
27 + erg += sym_sum(S_V_I(c,1L),b);
28 for(i=0L;i<S_P_LI(a);i++)
29 {
30 if (S_V_II(S_V_I(c,0L),i) == 1L)
31 diff -r 5cd656a07aa5 src/def.h
32 --- a/def.h Thu May 14 06:01:00 2009 -0400
33 +++ b/def.h Thu May 14 07:38:17 2009 -0400
34 @@ -3105,7 +3105,7 @@
35 extern INT so_character ();
36 extern INT so_dimension ();
37 extern OBJECTKIND s_o_k();
38 -extern INT sort();
39 +extern INT sym_sort();
40 extern INT sort_rows_tableaux_apply();
41 extern INT sort_vector();
42 extern OBJECTSELF s_o_s();
43 @@ -3271,7 +3271,7 @@
44 extern INT sub_part_part();
45 extern INT substitute_one_matrix ();
46 extern INT substitute_one_monopoly ();
47 -extern INT sum();
48 +extern INT sym_sum();
49 extern INT sum_integervector();
50 extern INT sum_matrix();
51 extern INT sum_vector();
52 diff -r 5cd656a07aa5 src/di.c
53 --- a/di.c Thu May 14 06:01:00 2009 -0400
54 +++ b/di.c Thu May 14 07:38:17 2009 -0400
55 @@ -1355,7 +1355,7 @@
56 m_il_nv(0L,weight_watcher);
57 m_il_nv(0L,perm_vec);
58 copy(S_V_I(FP,0L),fix);
59 - sort(fix);
60 + sym_sort(fix);
61
62 get_perm(hweight,p,b,S_I_I(n),S_I_I(m),0L,
63 perm_vec,weight_watcher,fix);
64 @@ -1502,7 +1502,7 @@
65 if(ind == m)
66 {
67 mult_perm_fix(p,fix,hfix);
68 - sort(hfix);
69 + sym_sort(hfix);
70 if(!hfix_in_ww(hfix,ww))
71 {
72 inc(ww);
73 diff -r 5cd656a07aa5 src/ga.c
74 --- a/ga.c Thu May 14 06:01:00 2009 -0400
75 +++ b/ga.c Thu May 14 07:38:17 2009 -0400
76 @@ -632,7 +632,7 @@
77 else if (what == 0L)
78 erg += vertikal_sum(S_V_L(a),c);
79 erg += copy(a,d);
80 - erg += sort(d);
81 + erg += sym_sort(d);
82 erg += m_il_p(S_V_II(d,S_V_LI(d)-1L),e); /* identitaet */
83 for (i=0L,k=0L,j=S_V_LI(d);i<S_P_LI(e);i++)
84 if (i+1L == S_V_II(d,k) )
85 @@ -722,7 +722,7 @@
86
87 j=0L;
88 erg += append(h,g,h2);
89 - erg += sort(h2);
90 + erg += sym_sort(h2);
91 for (i=0L;i<S_V_LI(g);i++)
92 {
93 erg += m_i_i(S_V_II(g,i),S_P_I(a,j));
94 diff -r 5cd656a07aa5 src/galois.c
95 --- a/galois.c Thu May 14 06:01:00 2009 -0400
96 +++ b/galois.c Thu May 14 07:38:17 2009 -0400
97 @@ -758,7 +758,7 @@
98 }
99 }
100 FREEALL2(v,nv);
101 - sort(res);
102 + sym_sort(res);
103 }
104 S3R(k,phg_c,phg_d,"all_points_phg_store",res);
105 ENDR("all_points");
106 diff -r 5cd656a07aa5 src/macro.h
107 --- a/macro.h Thu May 14 06:01:00 2009 -0400
108 +++ b/macro.h Thu May 14 07:38:17 2009 -0400
109 @@ -1,6 +1,8 @@
110 /* file: macro.h symmetrica source code */
111 #ifndef MACRO_H
112
113 +#include "string.h"
114 +
115 #ifdef SYMMAGMA
116 #define SYM_MALLOC(a) mem_malloc(a)
117 #else
118 #define C_O_K(a,b) ((a)->ob_kind = (OBJECTKIND)(b))
119 --- a/nc.c Thu May 14 06:01:00 2009 -0400
120 +++ b/nc.c Thu May 14 07:38:17 2009 -0400
121 @@ -204,7 +204,7 @@
122 erg += mult(S_NC_C(a),S_NC_C(b),d);
123 erg += m_gl_co(S_NC_GL(a),e);
124 erg += mult_apply(e,d);
125 - erg += sum(d,e);
126 + erg += sym_sum(d,e);
127 erg += m_gl_go(S_NC_GL(a),d);
128 erg += div(e,d,c);
129 erg += freeall(e);
130 @@ -617,7 +617,7 @@
131 erg += mult_nc_kranz(c,a,e);
132 erg += mult(S_V_I(e,1L),f,c);
133 erg += div(c,g,c);
134 - erg += sum(c,S_V_I(S_NC_C(b),S_I_I(d)));
135 + erg += sym_sum(c,S_V_I(S_NC_C(b),S_I_I(d)));
136 }
137 erg += freeall(c);
138 erg += freeall(d);
139 @@ -712,7 +712,7 @@
140 for(j = 0L; j<S_V_LI(c);j++) {
141 kranztypus_to_matrix(S_V_I(c,j),S_V_I(a,j));
142 }
143 - sort(a);
144 + sym_sort(a);
145 freeall(f); freeall(h); freeall(c);
146 return OK;
147 }
148 @@ -739,7 +739,7 @@
149 kranztypus_to_matrix(S_V_I(c,j),S_V_I(h,j));
150 }
151
152 - sort(h);
153 + sym_sort(h);
154 m_l_v(S_V_L(h),a);
155 for(j = 0L; j<S_V_LI(c);j++) {
156 typusorder(S_V_I(h,j), zb, za, S_V_I(a,j), f);
157 @@ -789,7 +789,7 @@
158 erg += kranztypus_to_matrix(S_V_I(c,j),S_V_I(h,j));
159 }
160
161 - erg += sort(h);
162 + erg += sym_sort(h);
163 erg += typusorder(S_V_I(h,S_I_I(i)), zb, za, a, f);
164 erg += freeall(f);
165 erg += freeall(c);
166 diff -r 5cd656a07aa5 src/nu.c
167 --- a/nu.c Thu May 14 06:01:00 2009 -0400
168 +++ b/nu.c Thu May 14 07:38:17 2009 -0400
169 @@ -531,13 +531,13 @@
170 ENDR("add");
171 }
172
173 -INT sort(a) OP a;
174 +INT sym_sort(a) OP a;
175 /* sortiert das object in aufsteigender reihenfolge AK 270787 */
176 /* AK 160986 */ /* AK 280689 V1.0 */ /* AK 050390 V1.1 */
177 /* AK 070891 V1.3 */
178 {
179 INT erg = OK;
180 - EOP("sort(1)",a);
181 + EOP("sym_sort(1)",a);
182
183 switch(S_O_K(a))
184 {
185 @@ -547,9 +547,9 @@
186 erg += sort_vector(a);break;
187 #endif /* VECTORTRUE */
188 default:
189 - erg += WTO("sort",a); break;
190 + erg += WTO("sym_sort",a); break;
191 };
192 - ENDR("sort");
193 + ENDR("sym_sort");
194 }
195
196 INT length(a,d) OP a,d;
197 @@ -641,7 +641,7 @@
198 ENDR("content");
199 }
200
201 -INT sum(a,res) OP a,res;
202 +INT sym_sum(a,res) OP a,res;
203 /* AK 280689 V1.0 */ /* AK 050390 V1.1 */ /* AK 120391 V1.2 */
204 /* AK 140891 V1.3 */
205 /* AK 170298 V2.0 */
206 @@ -649,7 +649,7 @@
207 INT erg = OK;
208 COP("sum(1)",a);
209 COP("sum(2)",res);
210 - CE2(a,res,sum);
211 + CE2(a,res,sym_sum);
212
213 switch(S_O_K(a))
214 {
215 @@ -680,7 +680,7 @@
216 erg += WTO("sum",a); break;
217 };
218
219 - ENDR("sum");
220 + ENDR("sym_sum");
221 }
222
223
224 diff -r 5cd656a07aa5 src/part.c
225 --- a/part.c Thu May 14 06:01:00 2009 -0400
226 +++ b/part.c Thu May 14 07:38:17 2009 -0400
227 @@ -347,7 +347,7 @@
228 if (a == b) { /* a := a+a */
229 if (S_PA_K(a) == VECTOR) {
230 erg += append_apply_vector(S_PA_S(a),S_PA_S(b));
231 - erg += sort(S_PA_S(a));
232 + erg += sym_sort(S_PA_S(a));
233 goto endr_ende;
234 }
235 else if (S_PA_K(a) == EXPONENT) {
236 @@ -406,7 +406,7 @@
237 k=S_PA_LI(b)-1;
238 /*
239 erg += append_apply_vector(S_PA_S(a),S_PA_S(b));
240 - erg += sort(S_PA_S(a));
241 + erg += sym_sort(S_PA_S(a));
242 */
243 inc_vector_co(S_PA_S(a),S_PA_LI(b));
244 for (j=S_PA_LI(a)-1;j>=0;j--)
245 diff -r 5cd656a07aa5 src/perm.c
246 --- a/perm.c Thu May 14 06:01:00 2009 -0400
247 +++ b/perm.c Thu May 14 07:38:17 2009 -0400
248 @@ -833,9 +833,9 @@
249 /* s = Anzahl der spalten */
250
251 s = S_V_LI(S_V_I(a,0L));
252 - sum(S_V_I(a,0L),summe);/* composition ist vector */
253 + sym_sum(S_V_I(a,0L),summe);/* composition ist vector */
254 z = S_I_I(summe);
255 - FREEALL(summe);
256 + FREEALL(summe);
257 m_ilih_nm(s,z,b);
258 C_O_K(b,KRANZTYPUS);
259 for (i=0L;i<s;i++)
260 @@ -1114,7 +1114,7 @@
261 erg += kranztypus_to_matrix(S_V_I(c,i),S_V_I(h,i));
262 }
263
264 - erg += sort(h);
265 + erg += sym_sort(h);
266
267 erg += chartafel(b,ct);
268
269 @@ -1926,7 +1926,7 @@
270 OP c;
271 c = CALLOCOBJECT();
272 erg += lehmercode_permutation(a,c); /*result is a vector */
273 - erg += sum(c,b);
274 + erg += sym_sum(c,b);
275 FREEALL(c);
276 }
277 ENDR("numberof_inversionen");
278 @@ -2364,7 +2364,7 @@
279 COP("rz_lehmercode(2)",b);
280
281 zw = callocobject();
282 - erg += sum(lc,zw);
283 + erg += sym_sum(lc,zw);
284 if (NULLP(zw))
285 {
286 erg += m_il_integervector((INT)0,b);
287 diff -r 5cd656a07aa5 src/rest.c
288 --- a/rest.c Thu May 14 06:01:00 2009 -0400
289 +++ b/rest.c Thu May 14 07:38:17 2009 -0400
290 @@ -3998,7 +3998,7 @@
291 oj = j;
292 }
293 }
294 - erg += sum(c,b);
295 + erg += sym_sum(c,b);
296 eee:
297 erg += freeall(c);
298 ENDR("charge_word");
299 diff -r 5cd656a07aa5 src/ta.c
300 --- a/ta.c Thu May 14 06:01:00 2009 -0400
301 +++ b/ta.c Thu May 14 07:38:17 2009 -0400
302 @@ -1596,7 +1596,7 @@
303 {
304 OP d,e;
305 e = CALLOCOBJECT();
306 - erg += sum(content,e); /* AK 271098 */
307 + erg += sym_sum(content,e); /* AK 271098 */
308 d = CALLOCOBJECT();
309 erg += weight(shape,d);
310 if (NEQ(d,e))
311 @@ -1821,7 +1821,7 @@
312 CE3(matrix, column_index, row_index,matrix_twoword);
313 c = callocobject();
314 erg += zeilen_summe(matrix,c);
315 - erg += sum(c,c);
316 + erg += sym_sum(c,c);
317 erg += m_l_v(c,column_index);
318 erg += m_l_v(c,row_index);
319 for(i=0,l=0;i<S_M_HI(matrix);i++)
320 diff -r 5cd656a07aa5 src/zyk.c
321 --- a/zyk.c Thu May 14 06:01:00 2009 -0400
322 +++ b/zyk.c Thu May 14 07:38:17 2009 -0400
323 @@ -804,7 +804,7 @@
324 zykeltypvec = CALLOCOBJECT();
325 ak_order = CALLOCOBJECT();
326
327 - sum(numztvec,ak_order); /* AK 060295 */
328 + sym_sum(numztvec,ak_order); /* AK 060295 */
329
330
331
332 @@ -1176,7 +1176,7 @@
333 erg += m_i_i(0,c);
334 while (z!=NULL)
335 {
336 - erg += sum(S_PO_S(z),e);
337 + erg += sym_sum(S_PO_S(z),e);
338 erg += hoch(b,e,e);
339 erg += mult_apply(S_PO_K(z),e);
340 erg += add_apply(e,c);